0
Oneplus One [OPO] 4G not working - Vodafone India

  1. zanyguy
    Cupcake Sep 5, 2016

    zanyguy , Sep 5, 2016 :
    Hi,

    I switched over to Vodafone India 4G in April end. Since then I have been facing problems. Initially I could use 4G but no one could reach me when trying to call me. For receiving calls I had to switch back to 3G. Now if I switch to 4G I get no network at all. No calls, no sms and no internet. Even 3G has stopped working! I can use phone and internet only on 2G!

    On checking I realised a few others have the same prooblem and from their experience got the IR connector changed in OPO service centre. However, this has not resolved the problem.

    I have tried workaround given on http://www.ibtimes.co.uk/how-fix-lte-not-working-issue-oneplus-one-cyanogen-os-12-1-update-1517727 However, this also has not helped.

    The sim card is working perfectly on another 4G phone.

    Has anyone else faced a similar issue and if so how to resolve it?
     

    #1
  2. pravin.tribhuvan
    Cupcake Sep 5, 2016

    pravin.tribhuvan , Sep 5, 2016 :
     

    #2
  3. pravin.tribhuvan
    Cupcake Sep 5, 2016


    #3
  4. anand787878
    Cupcake Sep 6, 2016

    anand787878 , Sep 6, 2016 :
    Reset and check it.
     

    #4
  5. zanyguy
    Cupcake Sep 9, 2016

    zanyguy , Sep 9, 2016 :
    Hi Anand,

    Already done that. No change.
     

    #5
  6. shivap88
    Cupcake Sep 28, 2017

    shivap88 , Sep 28, 2017 :
    Hi All,

    I made it working!!
    Vodafone 4G is finally working on my OPO. Here is the steps that i followed..

    1. Go to Settings --> Mobile network settings --> Access point names.
    2. Click on "Reset to default" (you can find this option on Top right corner with 3 vertical dots)
    3. Upon performing step #2, I could see 3 APN's listed i.e "portalnmms", "www", "portalnmms".
    4. Keep only "www" APN and delete rest of the APN's. (Make sure in "Settings --> Mobile network settings --> Access point names" you have only one APN listed and that is "www".
    5. Now, you should see data connected to 4G. (if not, pls restart your OPO once. In my case it worked without restarting OPO)

    Regards,
    Shiva.
     

    #6
  7. Sasitharan90
    Cupcake Oct 5, 2017


    #7
  8. Raghavendran S
    Cupcake Jan 15, 2018


    #8
  9. shashankshekhar7
    Cupcake Aug 21, 2018

    shashankshekhar7 , Aug 21, 2018 :

    Was struggling with the issue for over a month. My OPO with Vodafone connection showed 4G signal, with an exclamation mark.

    I was unable to use any form data for over a couple of months. Surprisingly, only WhatsApp seemed to be working, that too only for the text messages. I kept calling the customer care guys for a solution. They would ask me to update the APN. No solution. I even visited their stores, looking for a more technical help - no solution. They asked me to change my sim. Did it - no solution yet.

    Inserted JIO sim to check if my mobile had any problem. Data worked normally and i was able to access all forms of data and app. So it wasnt a problem with the OPO handset.

    Inserted my Vodafone sim into another mobile and that too worked.

    Performed 'Factory Reset' - painfully long process. The data connection magically worked that night and i happily tried to update/restore all apps and data again until late in the morning. I was so happy that everything worked fine.

    Woke up next morning only to find that the wierd 'exclamation mark' was back, sticking to the network symbol.
    CRAZZZYYY!!

    Repeated the entire process again next week and the results too repeated in the same way. 4G data worked for a while and the exclamation came back again.

    I was about to port my number to another service provider - was with Vodafone since 2006 (It was Hutch then). Didnt want to part ways after 12 years.

    As a last try, tried googling OnePlus Forums and read this thread and tried to follow word - by - word.
    The STEP 4 and STEP 5 did the magic. Earlier, i used to leave the other APNs hanging in there without deleting them. This time, i deleted all other APNs except the one as mentioned in STEP 4.

    And lo... MAGIC happened and i started getting pending notifications and all apps started working normally. Been 2 hours and fingers crossed, all's working fine. Screenshot_20180821-143158.png

    Accept my sincere thanks @shivap88!
     

    #9
  10. amarbs
    Cupcake Oct 8, 2018

    amarbs , Oct 8, 2018 :
    I had exactly same problem in Bangalore.
    The above steps works perfectly.
    Ensure to follow step #4 and #5
     

    #10
  11. OneOneGO
    Honeycomb Oct 26, 2018

    OneOneGO , Oct 26, 2018 :
    Thank you, thank you...thank you!!!!!
     

    #11
  12. Apps Used
    Cupcake Jul 30, 2019

    Apps Used , Jul 30, 2019 :


    Hi, I am using oneplus 3t USA model. I did the above steps still not able to get 4G network.
    Please suggest. I see H+ which is very slow.
     

    #12
  13. VishnuChandran
    Cupcake Sep 18, 2019

    VishnuChandran , Sep 18, 2019 :
    Thanks bro.. Recently I also ported to vodafone and faced the same issue. The steps mentioned by you helped a lot after searching so many other threads which didnt worked out.
     

    #13