0
OnePlus One USB and OTG storage issue and TWRP

  1. akishaha
    Donut Jul 16, 2015

    akishaha , Jul 16, 2015 :
    After a few weeks since I got my OnePlus, I'm having a strange problem. Whenever I try to copy any sort of data to/from the phone, a few seconds after task has been started I get this error

    "Cannot copy file.xxx
    The device has either stopped responding or has been disconnected"

    Also, the OTG storage devices get unmounted randomly and notification pops up
    "USB storage unexpectedly removed"

    I reached the concusion (like most of you would) that maybe USB port is malfunctioning.
    But here is the twist:

    If I connect my phone in MTP mode while in TWRP, the copying/pasting just occurs successfully each time. Even if I mount OTG in TWRP, USB storage works as it should without any issues.

    I've already tried:
    -changing different ROMs (PA, CM)
    -flashing stock kernel, recovery and rom
    -using different USB cables
    -using different PC
    -changing in between MTP and PTP
    -copying directly to root, folders and sub-folders

    But each time, the copying and OTG storage fails while booted into OS but works normally while using TWRP
     

    #1
  2. oneplusmeequalsinfinity
    Donut Jul 16, 2015

    oneplusmeequalsinfinity , Jul 16, 2015 :
    I had the very same problem when i first purchased the OPO. The part where i could not copy files from my PC to the phone was prolly because of faulty drivers as the issues sorted themselves out when i installed the drivers through BRT. Then i suppose the OTG problems also went away when i rooted the phone.. So I am not exactly sure what the cause was but those two things fixed it for me.( I rooted the phone using BRT as well. )
     

    #2
    Aaahh likes this.
  3. Aaahh
    Marshmallow Jul 16, 2015

    Aaahh , Jul 16, 2015 :
    Drivers, and otg is twrp
     

    #3
  4. DaxNagtegaal
    Marshmallow Jul 16, 2015

    DaxNagtegaal , Jul 16, 2015 :
    I'd suggest a clean flash through fastboot as that usually fixes all software related shit
     

    #4
  5. championspike
    Ice Cream Sandwich Jul 16, 2015

    championspike , Jul 16, 2015 :
    Wat app u use and get the error, cm's file manager gave me problem so thought of using different app like es file explorer and it worked...
     

    #5
  6. akishaha
    Donut Jul 16, 2015

    akishaha , Jul 16, 2015 :
    T
    I have tried using ES Explorer and Cyanogen File Browser. There also its flickring.
     

    #6
  7. akishaha
    Donut Jul 16, 2015

    akishaha , Jul 16, 2015 :
    W
    What is BRT ?
     

    #7
  8. AntMunny
    KitKat Jul 18, 2015


    #8
  9. avinashorai
    Cupcake Sep 27, 2015


    #9