2
Oneplus switch won't work

  1. Robin.Roevens
    Donut May 24, 2018

    Robin.Roevens , May 24, 2018 :
    Today my oneplus 6 arrived! So time to move away from my good old oneplus one. Hence installed oneplus switch on it.
    On the OP6 i select 'new phone' and confirm that they old phone is also a oneplus phone. Then I scan the generated QR code with the old phone.
    The devices start connecting and then both report 'connection succesfull'. OP6 goes tot step 3 and tells me to select the desired data to transfer on the old phone.
    on the old phone however nothing happens and switch stays stuck in step 2 telling me that it is connecting and that the connection is succesfull. I have waited for over 10 minutes for something to happen and retried many times . The only thing that sometimes happens is that the connection breaks and then re-establishes. When that happens a few times I get the message to connect manually.. but other than that I never get a dialog to actually select any data to transfer.

    Anyone else experiencing this? any solutions?
     

    #1
  2. kaihp
    Jelly Bean May 25, 2018

    kaihp , May 25, 2018 :
    I have a different variation of the Oneplus Switch app not working: I can open the app, I can only uninstall it(!)

    My phone came with 5.1.0, so I immediately upgraded it (without setting the phone up) to 5.1.5 and proceeded to do OEM unlock and root it with Magisk. I did this first because it wipes the phone, so no point in setting the phone up two times Screenshot_20180525-133147.jpg

    These are the only Apps I see on the phone before adding Google Play account.
     

    #2
  3. Interrogate
    Donut May 25, 2018


    #3
  4. Bartnl
    Lollipop May 25, 2018

    Bartnl , May 25, 2018 :
    Have you updated Switch to the latest version through the Playstore?
    This might help.

    You can also use switch to make a back up, copy the backup file to the OP6 and restore it again with switch.
     

    #4
  5. Gav_W86
    Starting Point Expert May 25, 2018

    Gav_W86 , May 25, 2018 :
    I initially had the same thing. I had swapped my SIM cards already from old to new. I put one SIM back into the old phone, so both had active data connection, and that seemed to work (though it could have been the reboot, or something else).
     

    #5
  6. Robin.Roevens
    Donut May 25, 2018

    Robin.Roevens , May 25, 2018 :
    I had first installed the latest OS update which seems to have the latest version already included as I don't get the option to update using play store.
    On the old phone it was of course also the latest version, straight from playstore.

    I don't get that option on my old phone, despite the fact that it also is a OnePlus..maybe since it is running a resurrection remix ROM.

    I also switched the Sim first. I however only have one and originally it was a micro SIM so I had to cut into a nano SIM before it fitted the OP6. And there is no way back now..so I don't have usable SIM for the old phone anymore..
     

    #6
  7. Interrogate
    Donut May 25, 2018

    Interrogate , May 25, 2018 :
    I'm in the exact same boat still, no option to make a backup and restore that, cut my sim so can't move back but it was failing while I still had it in the previous handset so hey
     

    #7
  8. Interrogate
    Donut May 26, 2018

    Interrogate , May 26, 2018 :
    found a fix, turn off data through the notification tray on the old phone. for some reason it tries to send data that way instead of through the adhoc connection. turned it off even though it was already inactive and it worked!
     

    #8
    tusalum, tidurlagi and shanks the one like this.
  9. jonspack
    Cupcake May 29, 2018

    jonspack , May 29, 2018 :
    Oneplus switch didn't work for me either, after many tries, although it did transfer my contacts. I downloaded Switch Mobile Transfer app to both phones and it worked perfectly. Very fast too
     

    #9
  10. SexAndManCity
    Honeycomb May 29, 2018

    SexAndManCity , May 29, 2018 :
    I've got 1 'other files' and 1 picture file that haven't/won't transfer - they've been stuck for ages - pretty sure that's not going to change. What happens if I just come out of it?
     

    #10
  11. ajaythapa78
    Eclair Jun 3, 2018


    #11
  12. amanv24
    Eclair Jun 3, 2018

    amanv24 , Jun 3, 2018 :
    I faced the same issue while switching from my OnePlus one to oneplus6.
    I noticed that the my older phone tried to reconnect to my home wifi router instead of the hotspot created in oneplus6 (because it didn't had active internet connections sharing ability).
    I tried removing all the known networks in the WiFi range, and then it never faced the issue.

    The OS tries to connect to the network where it can get active interent connection, and hence it creates issues sometimes.
     

    #12
  13. shanks the one
    Cupcake Jun 6, 2018

    shanks the one , Jun 6, 2018 :
    I have exactly the same issue. I tried with both Oneplus 1 & Oneplus 2 but both doe not reach the step 3. NFC is amazing but it transfers only limited stuff otherwise much better than switch. Similarly through bluetooth also is the same. A) Can anyone tell me if a solution to above problem for using switch app exists? B) What is the difference between using NFC/Bluetooth nearly device transfer and using switch app? Cant wait to use the new 6 but this is driving me nuts since last evening!
     

    #13
  14. Gav_W86
    Starting Point Expert Jun 6, 2018

    Gav_W86 , Jun 6, 2018 :
    The switch app seems to have an issue when communicating via the local hotspot if a mobile data connection is not present on both (or disabled on both), not entirely sure but having a SIM in both devices seemed to get it to work (and others have disabled the mobile data on both). Suggest reporting to https://forums.oneplus.com/feedback/ (the bug hunters are gathering data on it) and trying one of the above ideas as a workaround.
     

    #14
  15. shanks the one
    Cupcake Jun 7, 2018

    shanks the one , Jun 7, 2018 :
    Thanks a million for the suggestions! I did not put in a sim into the 6(so no mobile data) and disabled mobile data on the old phone (+1) and it worked! The Switch app is much better than the built in guided NFC/Bluetooth-nearby device route. I really don't know why they cant give the Switch App as one of the transfer options in the initial set up. I spent a fair amount of time with NFC/Bluetooth options till I realised that it doest not transfer all Data( Please check me if I am wrong on this).
    Your suggestion told me exactly what I should do ! Thanks again.
     

    #15
  16. shanks the one
    Cupcake Jun 7, 2018

    shanks the one , Jun 7, 2018 :
    Thanks for the suggestion! I did not put in a sim into the 6(so no mobile data) and disabled mobile data on the old phone (+1) and the Switch App worked like a dream!
     

    #16
  17. chrasmus
    Cupcake Jul 16, 2018

    chrasmus , Jul 16, 2018 :
    Well - as far as I see it - the idea with OnePlus Switch is to transfer data From the Old (in this case as well in mine From an old OnePlus One to a new OnePlus 6) - thus the SIM-card is supposed to be in The New and not the Old - I guess (even the One+ 1 uses a Microcard and the One+ 6 a Nanocard and thus not interchangeable) - leaving the Old without MobileData swtiched on - equal to disabling MobileData on the Old with the SIM card ..

    And - voila! - it works - and don't get stuck in step 2 in the Old phone ..

    I had the same issue as I haven't got a new nano-SIMcard yet so I need the old One+1 till I get a new compatible with the slot in One+ 6 - but thanks to the excellent suggestions from the fellow users in this thread it worked out fine!! ..
     

    #17
  18. tusalum
    Cupcake Oct 14, 2018

    tusalum , Oct 14, 2018 :
    Saved my day! Thanks
     

    #18
  19. masher_uk
    Cupcake Nov 13, 2018

    masher_uk , Nov 13, 2018 :
    Not sure if this is the same problem but I experienced an issue when attempting to transfer data from my old Samsung S5 to a shiny new 6T...

    OP Switch would get to the page where you're asked what items you wish to transfer (ie tick boxes) then just sit there on 0% transferred (I had previously selected the manual method for transfer - auto wouldn't work).

    I finally discovered that the 6T was switching back to my home wifi - solution was to manually force it back to the one used by the S5 and then the transfer began immediately.
     

    #19
  20. kageroh
    Eclair Feb 9, 2019

    kageroh , Feb 9, 2019 :
    Thank you for mentioning that SIM trick, I thought I was going insane because nothing worked.
    What worked for me is cancelling the transfer, killing both apps, then putting the SIM back into the OLD phone, start the apps again and start the transfer again.
    Seriously, OP?
     

    #20