2
OnePlus USB-C headphones not working with 7 Pro

  1. X1574196923451
    Cupcake Dec 9, 2019

    X1574196923451 , Dec 9, 2019 :
    I recently got the 7 Pro and included a set of USB-C bullet headphones in the order. However, the phone doesn't seem to recognize that they're plugged in at all. The headphones work when plugged into my MacBook. What do I need to do to get them to work with my phone?
     

    #1
    L1573558939143 and G_plusone like this.
  2. G_plusone
    Marshmallow Dec 10, 2019

    G_plusone , Dec 10, 2019 :
    Have you tried turning on OTG?
    In developer options check if you have disabled USB audio routing
    Also in developer options change Select USB configuration to Audio source or midi and see if any of this helps
     

    #2
  3. X1574196923451
    Cupcake Dec 11, 2019

    X1574196923451 , Dec 11, 2019 :
    I found out that restarting helps out, but only for a while. If I try plugging the headphones in and they don't work, I can restart and they probably will. But then if I unplug them and come back later, they don't work.

    This means that I pretty much need to restart the phone every time I want to use the headphones, which isn't ideal. It would be great if there were some way to request this be fixed in an update, or even to find out why it's occurring.
     

    #3
    Q1579869703923 and G_plusone like this.
  4. X1574196923451
    Cupcake Dec 17, 2019

    X1574196923451 , Dec 17, 2019 :
    I'll point out that this doesn't solve the problem. It's just a workaround. I still need a permanent solution.
     

    #4
    G_plusone likes this.
  5. Jhir
    Cupcake Dec 20, 2019


    #5
    Q1579869703923 and G_plusone like this.
  6. sd@bs
    Cupcake Feb 5, 2020

    sd@bs , Feb 5, 2020 :
    Hi everyone.

    Exactly the same issue for me with my headphones no detected when plugged.
    OTG doesn't change anyting.
    First I thaught it was a mecanical issue on the connector but the charge works well.
    I plugged the headphones on a desktop and they work well too.
    So now, I'm more guessing a software issue ?

    My Configuration :
    Phone: OnePlus 7 Pro
    Headphones : the basic ones provided with the phone
    Android version : 10
    Oxygen Build : 10.0.3.GM21BA

    Thanks in advance.
    Best Regards
     

    #6
  7. KeepTransisting
    The Lab - OnePlus 7 Pro Reviewer Feb 5, 2020

    KeepTransisting , Feb 5, 2020 :
    Like I replied to you in the other thread:

     

    #7
  8. sd@bs
    Cupcake Feb 5, 2020

    sd@bs , Feb 5, 2020 :
    I recently cleaned the connector but I will try again and keep you informed.
    Thanks
     

    #8
  9. L1573558939143
    Cupcake Mar 11, 2020


    #9
  10. Z1585371126891
    Cupcake Mar 28, 2020

    Z1585371126891 , Mar 28, 2020 :
    Hi community,

    I have my OP 7t around 2 weeks now and recognised a static noise during listen to music and voicemails.
    So listen in a quiet environment with low volume is super annoying with this noise. And keeps until a few seconds after the track ends.
    Also it switched off during the track when the voice is lower as a certain frequency.
    I've read already some other cases with a similar issue. Does anyone knows what it is?

    I have the newest OS 10.3.1
    I tried different headphones and type C adapter's but nothing changed.

    I had the problem that my phone didn't recognised my headphones as well but solved it with a recovery. So far it works.

    Best regards
    Felix
     

    #10
  11. E1588808065329
    Cupcake May 7, 2020

    E1588808065329 , May 7, 2020 :
    Anyone have a fix for this? Tired of having to reboot this phone every time I want to use USB C earbuds.
     

    #11
    A1548264554733 likes this.
  12. lennylim
    Cupcake May 8, 2020

    lennylim , May 8, 2020 :
    I've been using a passive USB C to 3.5mm adapter with my OnePlus 7T and never had any issue. The one I'm using now came with my Sony. With an active adapter (e.g. the one that came with a Pixel 2) it would only work after I reboot the phone.

    Doesn't help if you're using headphones with USB C built-in, but if you use headphones with 3.5mm jacks, the passive adapters work without needing a reboot.
     

    #12
  13. Y1568738561568
    Cupcake May 8, 2020

    Y1568738561568 , via OnePlus 7T , May 8, 2020 :
    I have the same issue . headset is not working after plugging. Not showing the icon also. I tried headphone on other device it's working finely. I restarted the phone but issue remains the same.
     

    #13
  14. dburton1827
    Cupcake Jun 7, 2020

    dburton1827 , Jun 7, 2020 :
    Any updates on this? I have the same issue. I have to reboot my phone for my USB-C headphones to work.
     

    #14
  15. G_Julian_Roberts_qlWu
    Cupcake Jun 16, 2020

    G_Julian_Roberts_qlWu , Jun 16, 2020 :
    Two new 7ta in two months. First phone stopped recognizing plugged in headphones 6 weeks in. Sold it got another new phone. This phone didn't work has the same problem didn't work from day one.
     

    #15
  16. Mknishanth5524
    Cupcake Jun 29, 2020


    #16
  17. X1595424600798
    Cupcake Jul 23, 2020

    X1595424600798 , Jul 23, 2020 :
    AKG type-c earphones not working with OnePlus 8 pro brand new. Phone doesn't recognise it even after a restart.
    I'm surprised that there is no reply from OnePlus on this when the thread has been started since December.
     

    #17
  18. z0rax
    Cupcake Jul 26, 2020

    z0rax , Jul 26, 2020 :
    Thanks man, OTG ON and Disable audio routing = OFF fixed my problem in a heartbeat.
     

    #18
    G_plusone likes this.
  19. G_plusone
    Marshmallow Jul 26, 2020

    G_plusone , Jul 26, 2020 :
    Glad it worked for you
     
    Last edited: Jul 26, 2020

    #19
  20. smach
    Cupcake Aug 4, 2020

    smach , Aug 4, 2020 :
    I have the same problem, but it has to do with using a USB-C charger from a laptop on the phone. The phone charges (it says "charging rapidly"), but the headset won't be detected after that until I reboot the phone. Seems like a software/firmware issue to me.
     

    #20