0
Oneplus X is stuck in fastboot mode. Help?

  1. HridayK
    Cupcake Apr 6, 2016

    HridayK , Apr 6, 2016 :
    Hi everyone. Yesterday I think I might have let my OPX completely drain its battery overnight without my knowledge. I wasn't able to boot it up or get into recovery mode even after charging for 6 hours.
    Today though, I let it charge, and surprisingly the screen responded and the charging LED was working. After letting it charge fully(Once the screen displayed a full green battery image) I tried to switch it on, and it went to fastboot. However it was stuck on the fastboot screen. I then went into recovery mode by holding the volume and power buttons, and tried to reboot from there. It just goes to fastboot again and gets stuck.

    I have tried wiping the cache and data from within recovery mode, and even tried formatting. However it all ends up with the phone just becoming stuck on the "fastboot mode" screen after rebooting. It's just an endless loop :(

    What should I do? Thanks a ton for the help!
     

    #1
  2. Sr Vincenzo
    Ice Cream Sandwich Apr 6, 2016

    Sr Vincenzo , Apr 6, 2016 :
    Sounds like its possibly your vol up button has gotten stuck. That's really the only thing I can think of if it keeps booting right back into fastboot.
     

    #2
    lolreppeatlol and Tokolozi like this.
  3. Tokolozi
    The Lab Reviewer - OPPO Find N Apr 6, 2016

    Tokolozi , Apr 6, 2016 :
    Same here, I suggest he removes a case (if he uses one) and wiggle the volume button back and forth a bit.
     

    #3
    JulieH, lolreppeatlol and Sr Vincenzo like this.
  4. orionaselite
    Gingerbread Apr 6, 2016

    orionaselite , Apr 6, 2016 :
    do you have windows or a mac?

    assuming you have windows get the latest full rom from oneplus here http://downloads.oneplus.net/2016-02-23/opx/OnePlus_X_OxygenOS_2.2.0-hotfix/

    then you need to get the needed tools onto windows just follow this http://lifehacker.com/the-easiest-way-to-install-androids-adb-and-fastboot-to-1586992378

    say we have the rom downloaded onto the desktop now from cmd goto to where you installed the adb and fastboot tools and also put your phone install recovery. from recory mode select install from usb and say ok. then type in cmd adb sideload rom_filename.zip. PM me if you need more hellp
     

    #4
  5. HridayK
    Cupcake Apr 6, 2016

    HridayK , Apr 6, 2016 :
    However even when I reboot normally from the recovery mode, it still goes straight to fastboot. I'm also pretty sure my volume up button is stuck. So this can't be the issue right?
     

    #5
    JulieH likes this.
  6. HridayK
    Cupcake Apr 6, 2016

    HridayK , Apr 6, 2016 :
    Hey.Thanks for the reply! I will try this. Only problem is my internet is kind of slow, and will take a while to download the ROM. Also, should i download the hotfix or the older version? Also my phone isn't showing up when i type in "adb devices" when I open adb in command prompt. Any ideas?
     

    #6
  7. patriciagmiramon2
    Cupcake Apr 11, 2016

    patriciagmiramon2 , Apr 11, 2016 :
    Hello, I have a similar problem, my phones is stuck in recovery mode when I turn it on. I tried doing the mega unbrick but the programme does not recognise my phone as it does nothing when holding the volume up button. What can I do?
     

    #7
  8. roor7
    Honeycomb Apr 11, 2016

    roor7 , Apr 11, 2016 :
    Run cmd as administrator
     

    #8
  9. JulieH
    Cupcake Apr 26, 2016

    JulieH , Apr 26, 2016 :
    this worked for me. thanks
     

    #9
  10. RWBY
    Gingerbread Apr 27, 2016

    RWBY , Apr 27, 2016 :
    try "fastboot devices" after "adb devices" it will show up your devices serial number. also, try to flash some recovery.
     

    #10
  11. mattia1900lazio
    Cupcake Jan 6, 2017

    mattia1900lazio , Jan 6, 2017 :
    good job
     

    #11
  12. mattia1900lazio
    Cupcake Jan 6, 2017

    mattia1900lazio , Jan 6, 2017 :
    lol
    lol
     

    #12
  13. debbenSakye
    Cupcake Sep 22, 2018

    debbenSakye , Sep 22, 2018 :
    how to flash recovery now that i have device listed in fastboot devices?
     

    #13
  14. jasto11
    Cupcake Sep 24, 2018

    jasto11 , Sep 24, 2018 :

    I have one plus x same issue stuck on fastboot mode can I fix using Mac also cable I have with it is charging cable that came with phone !!

    Any advice please help
     

    #14