0
OP 6T uses static IP even though settings in phone are DHCP

  1. e.m.m.a
    Cupcake Jan 17, 2021

    e.m.m.a , Jan 17, 2021 :
    Hi.

    I found out that my OP 6T uses a static IP. I checked the setting for the relevant WiFi network and it's set to DHCP.

    My router does not give an IP to the phone manually. If it would, it would be an IP beginning with 192...The static IP the phone uses starts with 100...

    Any idea what's going wrong here?
     

    #1
  2. drl431
    Community Hero 2020 Jan 17, 2021

    drl431 , Jan 17, 2021 :
    Hi, there is no option to set the phone for a static wifi ip address. Can you post a screen shot of the "Network details" for this wifi connection?
     

    #2
    Caomhin likes this.
  3. Raza_Dawar
    Froyo Jan 19, 2021


    #3
  4. Dunnow
    The Lab - OnePlus 6 Reviewer Jan 19, 2021

    Dunnow , Jan 19, 2021 :
    I don't get it. You don't have a DHCP server on the phone. Your router is set to use or not DHCP and provide an IP to your phone.

    Please provide a more comprehensive description, screens you visit etc
     

    #4
  5. e.m.m.a
    Cupcake Jan 19, 2021

    e.m.m.a , Jan 19, 2021 :
    If you go to Network details you can open a window to change some options. In Advanced Options (don't know the exact english term because my phone is set to german) you can set if the IP is static or DHCP.
     

    #5
  6. e.m.m.a
    Cupcake Jan 19, 2021

    e.m.m.a , Jan 19, 2021 :
    Did the reset. Changed nothing.

    It's strange. The IP the phone shows in Network details is one my router provides by DHCP. But my router shows the different one with the info that two clients are connecting through this device...

    It seems like the phone connects twice to the router. Once with the "normal" IP which is not shown in the router and once with the IP I can't figure out where it comes from...
     

    #6
  7. e.m.m.a
    Cupcake Jan 21, 2021

    e.m.m.a , Jan 21, 2021 :
    OK. Don't know what happened but since today (for now) this behaviour stopped. The phone is shown with the correct DHCP-IP in the router... I did change nothing in the meantime.
     

    #7