0

OP 7 pro Android Auto compatibility

  1. Tudorsp Cupcake Jun 1, 2019

    Tudorsp, Jun 1, 2019 :
    Is anyone using OP 7 pro and Android Auto in an Android Auto compatible car (VW Atlas in my case)? I just ordered my OP 7 pro and read reviews stating that since headphones and charging can not be performed at the same time, even with a dedicated adapter, OP 7 pro won't work with Android Auto compatible head units due to the data/power wired connection. Not sure if it makes any sense... Can anyone confirm/deny this?
     

    #1
  2. Tobikage Nougat Jun 1, 2019


    #2
  3. Tudorsp Cupcake Jun 1, 2019

    Tudorsp, Jun 1, 2019 :
    Here you go!

    From AndroidPolice:

    https://www.androidpolice.com/2019/06/01/updated-oneplus-7-pro-review/

    Like the OnePlus 6T before it, the OnePlus 7 Pro will not play nice with audio & power splitters/dongles. You can get audio or power over Type-C, but not both at the same time, unlike basically every other Type-C-equipped phone.

    If you use standalone Android Auto or even just Google Maps in a car with wired input, that's a bummer, as it means you'll have to choose between power and charging — or pick up a Bluetooth dongle.
     

    #3
  4. upD8R Cupcake Jun 1, 2019

    upD8R, Jun 1, 2019 :
    Indeed, it doesn't make sense. AA is wired anyway, so the phone is connected to the car providing all services (partially through Bluetooth) and it's being charged at the same time.

    OP7pro and AA work like a charm here in a 2019 Skoda Fabia and in a 2018 Mazda 6.
     

    #4
  5. Tudorsp Cupcake Jun 2, 2019


    #5
  6. ipsimprimis Donut Jun 21, 2019

    ipsimprimis, Jun 21, 2019 :
    it's works on my Honda 2019 stock AA support stereo but lately it's having trouble connecting and I have to delete it from Bluetooth and reconnect for it to work
     

    #6
  7. steelew Cupcake Jun 22, 2019

    steelew, Jun 22, 2019 :
    It works in my 2017 Ford explorer but I have issues with spotify saying I don't have a connection to the internet even though my signal (displayed in android auto) says I have full bars. AA also seems to have a problem when using both SIMs it won't offer the choice of SIMs or place a call.
     

    #7
  8. cobosj Cupcake Jul 10, 2019

    cobosj, Jul 10, 2019 :
    i thought the same you have to close all apps in your phone restart the phone turn off car and turn back on then plug in. put in password and unlock wait to it loads then plug in a orinal cable and it might work if it doesn't keep trying and wait a good few minutes for it to load. its like a big and they won't fix it. no other phone does this.
     

    #8
  9. D1565734140011 Cupcake Aug 13, 2019 at 11:15 PM

    D1565734140011, Aug 13, 2019 at 11:15 PM :
    for android auto My subu needs me to do the following
    when i turn off the car you need to unplug the cable to the car. even if only for a minute. every time you turn off your car you need to disconnect your phone.
    when you start your car let the Bluetooth connect THEN you can connect it and let android auto take over.

    this makes mine work flawless... i also ignore the "would you like to connect a device" and it 9 times out of 10 finds the phone anyway..

    hope it helps.

    Now if they could only fix the volume of the phone calls when connect to my car. My Samsung was fine, the pro 7 has no volume that i can find for phone calls period...
     

    #9
  10. Dirk66 Froyo Aug 14, 2019 at 12:07 AM


    #10
  11. barnabyj Honeycomb Aug 14, 2019 at 12:14 AM

    barnabyj, Aug 14, 2019 at 12:14 AM :
    no problems in my Mazda 3. charges, and plays everything fine via USB. when Android auto kicks in, it pretty much disconnects the Bluetooth connection. think it's only used on the initial setup. I can have another phone connected via Bluetooth, so I can listen to that, while AA is running and I'm getting navigation. this is so other people can play stuff from their phone, if needed.
     

    #11
  12. cobosj Cupcake Aug 14, 2019 at 1:26 AM

    cobosj, Aug 14, 2019 at 1:26 AM :
    sometime mine works but lots of times it doesn't. i just got the latest beta build with the new interface that one work a bit better but it still happen where it won't connect at times. The worst part is the mic sometimes ain't work if you press the mic button on the car. if that happens just say ok Google and that seams to work. its to buggy so I'm going back to the Note 10
     

    #12