1
op 7 pro - warp charging not working anymore

  1. ziggyson8911
    Eclair Jun 9, 2019

    ziggyson8911 , Jun 9, 2019 :
    Hi,

    I noticed that there is a problem with warp charhing on my phone. The phone will go to normal charging and sometimes if I wiggle the cable a bit it couls go to warp charging but then go back to normal again or even lower.

    I use original brick and cable. Anybod had the same issue? I tried cleaning with compressed air but it didn't help.

    I also tried w
    ith 3rd party cable just for comparison and it charged faster than with the original one.

    I don't want to send the whole phone in so just asking for any advice.

    attaching a screen with a stock charger& cable. 2 scenarios none of them went to warp.


    p.s. tested the Usb cable on 3rd party brick and it was also around 300mA whilst with 3rd party cable it was higher....seems to me like a cable problem?

    1560095428622.jpg

    1560094962927.jpg
     

    Attached Files:


    #1
    MattBoxer likes this.
  2. MattBoxer
    Gingerbread Jun 9, 2019

    MattBoxer , Jun 9, 2019 :
    I got this problem when I updated to 9.5.7 and it strangely disappears when my phone charged over 90%, about every 4-5 seconds it switches between normal charging and warp charging (without touching the cable). I tried a factory reset today and it's still the same, back in this thread I reached out to a bug hunter (https://forums.oneplus.com/threads/oneplus-7pro-warp-charge-not-working.1049579/#post-20400556) but I've had nothing back yet.

    But yeah, charging this phone off my battery bank is way faster at around 1500mA than the 300-900mA or none at all with the original charger and cable. I'm hoping its the update as my phone was 100% fine till then. What version are you on?
     

    #2
  3. ziggyson8911
    Eclair Jun 9, 2019

    ziggyson8911 , Jun 9, 2019 :
    9.5.7 as well. I only noticed this after the update, but to be honest I can't say if it was there before or not for 100%.

    Just for science, can you try powerbank with the original cable and see if its the same problem. I was playing around and I suspect the cable is the culprit because as soon as I change the cable it becomes a problem.
     

    #3
    MattBoxer likes this.
  4. MattBoxer
    Gingerbread Jun 9, 2019

    MattBoxer , Jun 9, 2019 :
    Yeah I have, and it charges the same on the powerbank with the original cable as well as 3rd party cables, I have even tried my OP5 cable with the original charger and it has the exact same issue (it can warp charge though which is nice I guess). The only reason I think that it was the update that caused this is that the phone vibrates every time it switches between warp, regular and no charging and it has never done that before the update.
     

    #4
  5. ziggyson8911
    Eclair Jun 16, 2019

    ziggyson8911 , Jun 16, 2019 :
    Update: all looks like faulty srock usb cable. waiting for replacement to see if it works.
     

    #5
  6. L1560982531063
    Cupcake Jun 19, 2019

    L1560982531063 , Jun 19, 2019 :
    Even for me facing this issue from past few days after that given a call to customer care they asked me to keep my phone into safe mode and pluginto charging then it works good at that time
    Now again started to give trouble

    Can I go and ask service centre to help out of this orelse should wait for the next update ..?
     

    #6
  7. meatandy
    Oreo Jun 20, 2019

    meatandy , Jun 20, 2019 :
    Go to service center and have the issue addressed as soon as possible.
     

    #7