0
OP2 damaging SIM card

  1. SR89 Froyo Dec 24, 2015

    SR89, Dec 24, 2015 :
    Hey guys!

    Having the OP2 for a couple of weeks and still being very satisfied with it, I'm also having a concern regarding the dual SIM feature. I'm using it for two SIM cards from two major carriers. But now, for the second time within four weeks, it has damaged my second SIM card in a way I have to have it replaced by the carrier. Today was the second time, when I woke up the status of my SIM no. 1 being "Invalid". So I rebooted and got the message: "SIM no. 1 is empty." That's it, nothing else. No PIN requested or anything. It is just broken (tried the SIM with several other phones). The first time I thought it was bad luck, although I didn't break any SIM card before despite using several custom ROMs on my smartphones.

    What I'm asking: Is anyone having a similar issue? Do you think it's software or hardware related?

    I'm using Tasker and this app to turn the SIM no. 1 off after working hours, because it's my business phone number. The first time the SIM got damaged it was in SIM tray no. 2, so I can presume it has nothing to do with the position in the phone. My second card works just fine all the way long (but I didn't use tasker with Dual SIM Control on it).

    Any ideas? Suggestions? Similar experiences?

    Regards and merry christmas,
    SR
     

    #1
  2. magnamentis Ice Cream Sandwich Dec 24, 2015

    magnamentis, Dec 24, 2015 :
    i guess it's a coincidence. if you wanna be sure use tasker on the other sim as well ( i.e. from 2am to 5.am to be on the save side and see what happens. even though tech can behave very weirdly at times, i cannot see any way how deactivating a sim card could damage it. of course this is guesswork from the distance but i'd say make the test and then report back, send me a message because i'm a tasker user for years and for everything and i'w try to reproduce ( take the risk ) if that will happen again with the no never failing sim as well. this is my offer.
     

    #2
  3. joaormf Cupcake Dec 24, 2015

    joaormf, Dec 24, 2015 :
    Hi Sven,

    I'm the developer of Dual SIM Control. Thanks for letting me know about this issue, but I can confirm that it's the first time I know that a user is getting the SIMs damaged by using my app. And many of those users use the app in that way too (switch off/on one SIM every day).

    I use the more high level possible methods to switch SIM on and off, meaning that I don't mess with the ROM implemented way of switching SIMs on/off.

    I would also suggest that you try to switch the SIM on/off manually for a couple of weeks. If it happens again then it's an issue with your phone or ultimately with you carrier SIMs.

    Keep me updated on this please.

    Thanks
     

    #3
  4. SR89 Froyo Dec 24, 2015

    SR89, Dec 24, 2015 :
    This is a good suggestion. I will do so with the other SIM, which is working fine currently and report.

    I will replace the second SIM on monday and will turn it manually on/off for a couple of weeks to see what happens.

    Thanks for the quick reply!
     

    #4
  5. Totenmond Cupcake Dec 25, 2015

    Totenmond, Dec 25, 2015 :
    Hi Everyone,

    definitly there seems to be an issue with damaged sim cards and the OP2. Some days ago my business sim card could not be read, this is the second time now. Also my private sim care (both from the same carrier) was already exchanged once.

    I have the impression that the problems begun after I have set the phone into flight mode.

    I have read several entries for this problem but (unfortunatelly) never heard about a solution, fix or official statement.

    BR
    T.
     

    #5
  6. $Teresa$ Cupcake Jan 6, 2016

    $Teresa$, Jan 6, 2016 :
    Hey!

    I'm from Austria and i have the same problem with invalid sim cards...now it's the third time, a new sim card got damaged...it doesn't matter which slot i take or how i use my phone...it always happenes suddenly...and the last time the sim card got damaged after one month of using...so it was a nearly new card. Please help me! I fear thats a phone problem...and i love my op2!!!
     

    #6
  7. Smacca Cupcake Jan 8, 2016

    Smacca, Jan 8, 2016 :
    This is happening to me with my OPX. I'm on my third sim card now. It's very annoying.
     

    #7
  8. xchris Ice Cream Sandwich Jan 8, 2016

    xchris, Jan 8, 2016 :
    i think your phone has an HW problem and you should raise a ticket.
     

    #8
  9. shrineels10 Honeycomb Jan 8, 2016

    shrineels10, Jan 8, 2016 :
    Are you connecting the phone to a laptop etc with earthing issues? I faced this issue with my previous phone from another maker... and realized it was this... every 3 or 4 times i connect to the laptop the sim used to develop issues. never had it while using charger alone.
     

    #9
  10. Killershot Cupcake Jan 8, 2016

    Killershot, Jan 8, 2016 :
    Have similar issue with my OPX. I used my phone for maybe 2 months with just 1 sim card without any trouble, but 2 weeks ago I putted in second sim and few days ago I had to changed by my carrier. But what is strange, that sim wchich looks dead in OPX worked well in different phone. With new sim everyting work well again, but I worried if it could happen again.
     

    #10
  11. <<<Franchise>>> Donut Jan 8, 2016

    <<<Franchise>>>, Jan 8, 2016 :
    The problem is known. OPO, OP2 and certainly OPX, not talk correctly with SIM cards which have feature MEC-Request (Mobile Equipment Change).

    These cards permanently very many write cycles on the SIM rather than because the phone wrong information returns.

    In German OP+ Forum is about discussed just one year!

    Help bring only one old card without MEC!

    sorry for my english
     

    #11
  12. SR89 Froyo Jan 10, 2016

    SR89, Jan 10, 2016 :
    I've never connected my phone to any other than standard charger from OnePlus neither has it been connected to any PC.

    I'm certainly not able to get such a SIM Card from my carrier. But this is rather annoying. OnePlus has to implement a bug fix here! I will submit a ticket. Do you have the link to the German thread?

    Regards,
    SR
     

    #12
  13. <<<Franchise>>> Donut Jan 10, 2016

  14. SR89 Froyo Jan 11, 2016


    #14
  15. JonasOP Cupcake Jan 11, 2016

    JonasOP, Jan 11, 2016 :
    Hi,

    I am a german One Plus user and am having similar problems: My phone looses the connection with my main carrier and wont't reconnect until the phone was restarted. I had the phone send in and the "RF conenctor" was exchanged, but the problem persists. Recently I discovered the german threads about this issue and am assuming that's the cause of my problem too. I requested a new SIM and will shortly find out if this will fix the issue (for now).

    We need to raise awareness with OnePlus that this bug needs to be fixed!

    BR
    Jonas
     

    #15
  16. waglagon Cupcake Jan 17, 2016

    waglagon, Jan 17, 2016 :
    Hello,

    austrian OPT-user here.
    Using Dualsim with 1 autrian SIM (DREI) for private using and 1 german SIM (T-Mobile) for business.
    DREI-SIM has no problems, but T-Mobile-SIM crashed for the 2nd time in 6 months.
    It's really annoying and I have to switch to my business iphone... (!!!)
    BR
    Florian
     

    #16
  17. jnh010 Ice Cream Sandwich Jan 17, 2016

    jnh010, Jan 17, 2016 :
    Got a simular problem. Had to replace sim card twice (t-mobile) within 3 month. Not sure though if its a problem on op or carriers end.
     

    #17
  18. thgi2 Cupcake Feb 3, 2016

    thgi2, Feb 3, 2016 :
    I can confirm, there is a help forum from the "deutsche telekom", they say there is a feature called MEC (it's mainly for setting phone parameters to match their network), active on all their SIM cards, which is not correctly handled by any of the OnePlus Devices (one, two, x) so it writes constantly to flash memory, killing it arround 100.000 writes which is 3-6 weeks.

    Oneplus Devices say "I can handle this" and when the cards actually wants to activate the feature and fail, it writes an error to the flash memory.

    https://telekomhilft.telekom.de/t5/Handys-Datengeräte/AW-Defekte-Sim-Karte-beim-Oneplus-One/td-p/1589987/page/2


    @Helen maybe you can fix that in an software update?
     
    Last edited: Feb 3, 2016

    #18
    JonasOP likes this.
  19. basi0 Cupcake Feb 5, 2016


    #19
  20. JonasOP Cupcake Feb 5, 2016

    JonasOP, Feb 5, 2016 :
    By now I have a new sim card and my phone is fully functional again :)
    However I have the same type of sim card as before. I expect my phone to fail again in 6-8 weeks :(

    One Plus Team: Please fix the issue (incompaibility with MEC sim cards)!!!
     

    #20