7
[OP3/OP3T] LineageOS 16.0 Offizielle Nightlies

?

Wirst du auf LOS 16.0 upgraden?

  1. Ja, und zwar sofort!

    12 vote(s)
    63.2%
  2. Ja, aber ich warte erst mal das Feedback ab!

    4 vote(s)
    21.1%
  3. Nein, ich bin mit LOS 15.1 voll zufrieden!

    0 vote(s)
    0.0%
  4. Nein, ich bleibe bei Oxygen OS!

    3 vote(s)
    15.8%
  1. Johannes1098
    Jelly Bean Mar 1, 2019

    Johannes1098 , Mar 1, 2019 :
    Lineage OS 16.0 Banner.jpg
    Stand: 24.06.2019

    Ab dem 01.03.19 gibt es tägliche Nightlys von LineageOS 16.0 für das OP3 und OP3T.


    Aktuelle Entwicklungen, Bugs & Workarounds von LOS 16.0:

    -DURCH DIE MIGRIERUNG DER 9ER FIRMWARE IN LOS 16 GIBT ES EINIGES ZU BEACHTEN. DESWEGEN UNBEDINGT DEN ZWEITEN POST DIESES THREADS LESEN.
    WER DAS NICHT MACHT SOLLTE KEINE VERSIONEN SPÄTER ALS 15. JUNI INSTALLIEREN!!!

    - Der TWRP Verschlüsselungsbug, Datumsbug und Backupbug sind behoben. Das heißt dass man zurzeit die neueste TWRP (3.3.1-0) verwenden kann für die Installation, Upgrade, Backup etc.


    Offizielle Ankündigung im Lineage Blog:
    https://lineageos.org/Changelog-22/

    Download Seite:
    https://download.lineageos.org/oneplus3

    Installationsanleitung:
    https://wiki.lineageos.org/devices/oneplus3/install
    Wenn man von der offiziellen LOS 15.1 kommt, kann man dirty zur 16.0 Upgraden, d.h. man kann seine Daten behalten.
    Man muss lediglich System, Cache & Dalvik / ART Cache vor dem Flashen löschen!
    (Backup wird natürlich empfohlen!)

    Wenn man von LOS 15.1 oder auch von LOS 16 Builds vor 16.06 upgraden will auf die neueste Version muss man die besondere Migrierung beachten, siehe 2. Post hier.
    Dies ist sehr wichtig, ansonsten gehen alle deine Daten verloren!!


    Für Google Apps die GApps für ARM64 und 9.0 nehmen
    http://opengapps.org/?arch=arm64&api=9

    Zum Rooten:
    offizielle AddonSu für 16.0, Magisk, SuperSu etc. funktioniert alles.

    Wichtig: Die Firmware muss aktuell sein, sonst kommt es zu Problemen mit dem Mobilfunk!!!
    Für Builds bevor 16.06: Firmware 5.0.8 nehmen
    Fürs Builds seit 16.06: Firmware 9.0.3 nehmen
    Für Firmwareupgrade von 5 auf 9 auf wieder DRINGEND den 2. Post lesen!!
    Links zu Firmwares:
    https://forum.xda-developers.com/oneplus-3/how-to/op3-flashable-firmware-modem-zips-t3816066
    Mirror OP3 https://www.celsoazevedo.com/files/android/oneplus3-modem-firmware/
    Mirror OP3T https://www.celsoazevedo.com/files/android/oneplus3t-modem-firmware/


    Die wichtigsten Neuerungen:

    • Android 9
    • fast alle Features wurden von LineageOS 15.1 übernommen
    • aktuelle Sicherheitspatches von Dezember, Januar & Februar (sowie in Zukunft von weiteren Monaten...)
    • die Styles-API wurde angepasst. So wird der offizielle Dark Mode nun besser unterstützt.
    • der Taschenrechner unterstützt nun den Dark Mode
    • Webview wurde auf Chromium 71.0.3578.99 geupdatet
    • Exchange wird nun unterstützt
    • Trust wurde verbessert - so kann man nun neue USB Geräte blockieren wenn das Gerät gesperrt ist
    • "Als gelesen markieren" kann in der Benachrichtigungsleiste bei einer angekommenden Nachricht ausgewählt werden
    • Auf neue Updates kan nun (wieder) automatisch geprüft werden (nie/täglich/wöchentlich/monatlich)

    Changelog:
    https://download.lineageos.org/oneplus3/changes/

    Aktuelle Probleme & Lösungen:
    Siehe 2. Post

    Thread bei xda:
    https://forum.xda-developers.com/on...ment/rom-lineageos-16-0-oneplus-3-3t-t3866517

    Hands-On Video von xda:
    wurde nur zu LOS 15 erstellt - demnach gibt es zurzeit keins. Man kann aber ein bisschen auf YouTube suchen da findet man schon einiges...
     
    Last edited: Jun 24, 2019

    #1
  2. Johannes1098
    Jelly Bean Mar 1, 2019

    Johannes1098 , Mar 1, 2019 :
    Anleitung zum Migrieren von älteren Builds vor dem 16.06 auf Builds ab 16.06:

    Am 16.06.2019 wurden die Blobs von der offiziellen OOS 9 in LineageOS integriert.
    Als folge ist nun auch zwingend eine neue Firmware einer OOS 9 Version Pflicht.
    Zurzeit wäre die aktuelleste OOS 9er Firmware die der Version 9.0.3

    Nun wird bei der Firmware aber auch der Bootloader und der Keymaster aktualisiert.
    Wenn man nicht weiß was das ist, ist es nicht weiter schlimm.

    Wichtig wird es jetzt nur bei einem verschlüsselten System:
    Der Keymaster der 9er Version ist nicht mit der 5er kompatibel.
    Wenn man jetzt einfach die 9er Firmware auf einen verschlüsselten System flasht werden die Keys korrupt und man kann seine Daten nicht mehr entschlüsseln.
    Diese sind dann KORRUPT und VERLOREN! UNREVERSIBEL!

    Deswegen gibt es jetzt 2 verschiedene Ansätze zum Migrieren.

    1) Man lässt den Keymaster und BL auf der Version von der 5.0.8 und updatet nur die anderen Firmwaredateien auf die 9.0.3.
    1. die neueste TWRP 3.3.1-0 flashen
    2. Nandroid Backup vorsichtshalber machen und dann den kompletten internen Speicher extern (z.B. auf Windows) sichern. Dieser Schritt wird nicht zwingend benötigt doch falls wirklich etwas schief laufen sollte ist man auf der sicheren Seite.
    3. Modifizierte Firmware ZIP flashen
    4. LineageOS.zip flashen sowie weitere benötigte ZIPs (Magisk, SuperSU Addon, OpenGapps etc.)
    5. Cache & Dalvik Cache löschen
    6. ins System starten und glücklich werden mit der neuesten LOS Version mit 9.0.3 Firmware
    Diese Methode würde ich nur übergangsweise empfehlen. Quasi als temporärer Fix. Komplett 100% richtig ist die zweite Methode, wo dann auch der Keymaster und BL von der 9.0.3 stammen.

    2) Da ich die Anleitung original auf Englisch im XDA Forum veröffentlich habe verlinke ich diese jetzt einfach hier - wer dem Englischen nicht mächtig ist soll hier einfach im Thread nachfragen
    https://forum.xda-developers.com/showpost.php?p=79769445&postcount=2516



    Aktuelle Probleme & Lösungen:

    1) NFC geht nicht nach Upgrade

    Einfach /data/nfc/nfaStorage.bin1 löschen
    Danach Handy neustarten und man kann es wieder verwenden

    2) Entsperrpasswort/PIN/Muster ist falsch nach Upgrade oder Backup Wiederherstellung
    Folgende Dateien löschen (wenn nicht alle Dateien vorhanden sind ist es normal, diese dann einfach ignorieren):
    /data/system/locksettings.db
    /data/system/locksettings.db-shm
    /data/system/locksettings.db-wal
    /data/system/gatekeeper.password.key
    /data/system/gatekeeper.pattern.key
    Danach Sperre neu einrichten

    3) Fingerabdrucksensor geht nicht mehr nach Upgrade oder Backup Wiederherstellung
    Folgende Dateien löschen:
    /data/system/users/0/fpdata/user.db
    /data/system/users/0/settings_fingerprint.xml
    Danach Fingerabdrücke neu einrichten
     
    Last edited: Jun 24, 2019

    #2
  3. Huberle
    Honeycomb Mar 1, 2019

    Huberle , Mar 1, 2019 :
    Offensichtlich, Stand 1.3.19, 12:56, ist es noch nicht verfügbar. Sehe nur das 15.1 er
     

    #3
  4. Johannes1098
    Jelly Bean Mar 1, 2019


    #4
    Huberle likes this.
  5. RalfK-2304
    Froyo Mar 2, 2019


    #5
  6. RalfK-2304
    Froyo Mar 2, 2019


    #6
  7. Johannes1098
    Jelly Bean Mar 2, 2019

    Johannes1098 , Mar 2, 2019 :
    jip, habe es selber probiert zu installieren (habe es instant geflasht wo noch kein Feedback da war...)
    Es bootet sofort in den Bootloader - also es macht noch nicht mal irgendwelche Versuche zu starten (und dann Bootloop etc.) - nein, es bricht sofort ab.

    Schade dass wir so eine Pechsträhne haben - vllt klappts ja wirklich morgen. Aber naja, deswegen sind es ja nightlys und keine stables.
     

    #7
  8. dm82m
    Donut Mar 3, 2019

    dm82m , Mar 3, 2019 :
    es ist da und funktioniert: https://mirrorbits.lineageos.org/fu...age-16.0-20190303-nightly-oneplus3-signed.zip

    wichtig ist, dass ihr das aber mit dieser TWRP version https://androidfilehost.com/?fid=11410963190603866112
    flasht, da in der aktuellen offiziellen twrp ein bug enthalten ist mit dem dauerhaft die hardware encryption gekillt wird sofern die data partition formtiert wird. das kann auch nicht mehr restored werden - heißt 1x kaputt gemacht bleibt es kaputt! siehe hier: https://forum.xda-developers.com/on...h-recovery-t3742894/post78332159#post78332159
     
    Last edited: Mar 3, 2019

    #8
    Huberle and Johannes1098 like this.
  9. JelleZon
    KitKat Mar 3, 2019

    JelleZon , Mar 3, 2019 :
    wieso bekommt One Plus den Dark Mode nicht so gut hin wie bei LOS?
    da ist zb auch das Notifications Center komplett schwarz...
     

    #9
    Huberle likes this.
  10. cca79
    Cupcake Mar 3, 2019

    cca79 , Mar 3, 2019 :
    Confirmed. I had the same issue with my OnePlus 3T. I kept getting the bootloader screen. Never managed to see the Lineage logo loading.

    NOTE that I simply used the latest TWRP (twrp-3.2.3-1-oneplus3.img). I wasn't aware of any issues in TWRP which seem to be addressed in this older version: https://androidfilehost.com/?fid=11410963190603866112
     
    Last edited: Mar 3, 2019

    #10
  11. dm82m
    Donut Mar 3, 2019

    dm82m , Mar 3, 2019 :
    it works with the current build, just check the links in my post above and enjoy lineageos 16 on your oneplus3/t
     

    #11
  12. Huberle
    Honeycomb Mar 5, 2019

    Huberle , Mar 5, 2019 :
    @dm82m Kannst Du für alle hier die "defekte" TWRP Version bitte benennen? Welche konkret ist es? Am besten im Thread direkt, wo Du das geschrieben hast. Danke :)
     

    #12
  13. Johannes1098
    Jelly Bean Mar 5, 2019


    #13
  14. Johannes1098
    Jelly Bean Mar 9, 2019

    Johannes1098 , Mar 9, 2019 :
    Seit heute ist der März Patch integriert.
    Manche haben Probleme mit dem internen Updater (Installation in TWRP bricht ab)
    dann einfach (mit der neuesten gefixten TWRP Version - siehe 1 Post weiter oben) das Update manuell flashen in TWRP.
    Wenn der Downloader es heruntergeladen hat liegt die Datei unter /data/lineageos_updates.
    Dann sollte alles klappen...
     

    #14
  15. cca79
    Cupcake Mar 10, 2019

    cca79 , Mar 10, 2019 :
    In the meanwhile I installed LineageOS 16 using the updated guide
    https://wiki.lineageos.org/devices/oneplus3/install

    NOTE this one recommends to install TWRP
    twrp-3.2.3-10-oneplus3.img

    Updating to another nightly update with TWRP is still an issue though
    Updater process ended with ERROR: 7
    Error installing zip file '/data/lineageos_updates/.........
     
    Last edited: Mar 10, 2019

    #15
  16. cca79
    Cupcake Mar 10, 2019


    #16
  17. RalfK-2304
    Froyo Mar 10, 2019

    RalfK-2304 , Mar 10, 2019 :
    Important: starting with the March 7th build, the minimum firmware required ist 5.0.8, otherwise the update will fail!

    If you don't have it, you should do this as next step.
    I use the zip provided here: https://forum.xda-developers.com/oneplus-3/how-to/op3-flashable-firmware-modem-zips-t3816066
    ... but the one in the link you mentioned is also fine.

    The reason why your link lists it under Android 8 is simply because OnePlus itself does not have released Android 9 yet, so officially they don't have a Android 9 firmware yet (and they don't have an "Open Beta" anymore for 3/3T). But it works perfectly with LOS Android 9.
     

    #17
  18. cca79
    Cupcake Mar 11, 2019

    cca79 , Mar 11, 2019 :
    Yes the install of Stable5.0.8+Firmware+Modem_OnePlus3T.zip made it possible to install the nightly updates with the updater app. Thanks for the input!
     

    #18
  19. lukass2000
    Donut Apr 22, 2019

    lukass2000 , Apr 22, 2019 :
    Hi Leute,
    läuft LineageOS 16 auf dem OnePlus 3/3T mittlerweile "stabil" für den täglichen Einsatz, oder gibt es noch Probleme?
    Danke!
     

    #19
  20. Johannes1098
    Jelly Bean Apr 22, 2019

    Johannes1098 , Apr 22, 2019 :
    Ich benutze sie seit Anfang an und habe bis jetzt noch keine Fehler oder Probleme feststellen können.
    Es fehlen aber noch manche LOS Features. So kann man zum Beispiel zurzeit die Uhrzeit nicht in die Mitte der Statusleiste packen. (Wenn man dies vor dem Upgrade macht und dann nichts verstellt bleibt sie allerdings in der Mitte). Der Netzwerkmanager ist dann aber dahinter ab und zu (den muss man dann halt ausschalten...)

    Und wenn man eine SIM pin hat und man zu schnell nach dem Start entsperrt kann es sein dass die SIM Pin Abfrage nicht mehr kommt. Dann muss man Flugmodus an und wieder ausmachen. Dann kann man die Karte entsperren und benutzen. Da das aber nur einmalig bei einem Start ist stört mich das jetzt nicht.

    Akkulaufzeit ist ok. Komme mit meinem OP3T auf ~4h.

    Das wars dann aber auch von den kleinen Sachen... Ansonsten kannst du einfach von 15.1 ohne Factory Reset upgraden. Wichtig ist nur dass du vorher die Firmware von OOS 5.0.8 installierst. (nicht die von der Openbeta 40, Wichtig! den mit der verliert man alle Daten!)
    Aber ohne die Firmware von der 5.0.8 lässt sich LOS nicht installieren.
    Und bei den Gapps halt die richtige Version nehmen. TWRP Version 3.2.3-10 von hier https://androidfilehost.com/?fid=1395089523397907195 nehmen.

    Dann sollte alles klappen. Aber trotzdem in TWRP natürlich ein Backup der /data anlegen!
     

    #20