0
OP3 OxygenOS 3.2.7 seems to have re-introduced the echo problem

  1. eralaj
    Eclair Oct 24, 2016

    eralaj , Oct 24, 2016 :
    Since my OP3 was updated to OxygenOS 3.2.7 callers complain that they hear their own voice as an echo.

    This is a recurring problem with OnePlus devices that seem to come and go as OS updates are deployed. This is the first time I get feedback about echo since I got my OP3 in June.

    Anyone else that can confirm that this seem to be related to the deployment of 3.2.7?
     

    #1
  2. bwgreen
    Froyo Oct 24, 2016


    #2
  3. ColinB63
    Ice Cream Sandwich Oct 24, 2016

    ColinB63 , Oct 24, 2016 :
    Are you on speakerphone? This happens to me when my wife uses speakerphone on her Oneplus one to call me.
     

    #3
  4. lordtay
    Cupcake Oct 25, 2016

    lordtay , Oct 25, 2016 :
    I too have this problem when people call me on the speaker phone or not. I upgraded to 3.2.7 before I had the chance to make or receive calls so I can not confirm if it was there before the upgrade.
     

    #4
  5. SimonFullerImagery
    Jelly Bean Oct 25, 2016

    SimonFullerImagery , Oct 25, 2016 :
    I get this on all builds. If I remove my case altogether it's fine or if I enable speaker phone it works also. Not just one case, any case.
     

    #5
    Amith-bd likes this.
  6. nmga
    Cupcake Nov 16, 2016


    #6
  7. oneplus23456
    Eclair Dec 19, 2016

    oneplus23456 , Dec 19, 2016 :
    Even I have this issue ever since I bought OP3.I tried to do every possible workaround I could.Even I had the PCB(motherboard) replaced from Oneplus Service center.But no luck.Its utterly frustrating.I cannot make or receive calls properly because of this bug.
     

    #7
  8. Amith-bd
    Cupcake Dec 21, 2016

    Amith-bd , Dec 21, 2016 :
    Device: 1+3
    OS: 3.2.8

    Caller hears echo when they call me. I thought it's a network issue but later found out it's my phone. Switching to loud speaker for a second fixes the problem and the problem doesn't appear all the time. Some said closing google's voice detection helps , well it did not help my case. I use Spigen rugged case and I am doubting it can be due to the case. I will try to use phone without case and see if I could generate the echo problem again. One Plus knows this issue as some of their latest 3T are also affected by it. Lets hope one plus would be able to fix this with the next update.

    Update, removing cases help. I did not face the problem using phone without the case. I recently received my rosewood official case and the problem returns when i use that case. this is likely to be a hardware issue.
     
    Last edited: Dec 22, 2016

    #8
  9. Amith-bd
    Cupcake Dec 22, 2016

    Amith-bd , Dec 22, 2016 :
    Do you face it while using phone without case?
     

    #9
  10. JorgeManuelSilva91
    Ice Cream Sandwich Dec 22, 2016

    JorgeManuelSilva91 , Dec 22, 2016 :
    Using 3.2.8 Stable. No problem here on calls, everything is okay, there is no echo on speaker mode either. It's an hardware or case issue.
     

    #10
  11. G_JV_jafa_CNtv
    Cupcake Dec 22, 2016


    #11
  12. oneplus23456
    Eclair Dec 23, 2016

    oneplus23456 , Dec 23, 2016 :
    Yes Amit.With or without case, its the same.One cannot even think of buying other phone considering the amount of money invested on this crap device.I've tried almost every possible solution.But nothing seems to work.
     

    #12
  13. paragtj
    Cupcake Mar 16, 2017

    paragtj , Mar 16, 2017 :
    i am having the same problem for the past six months, what should u do?
     

    #13
  14. Oleg Pittsyk
    Donut Jun 5, 2017

    Oleg Pittsyk , Jun 5, 2017 :
    For OP 3/3T.
    There is a temporary fix for echo issue.
    Open "settings" => "advance" => "accessibility" => scroll down to "mono audio" and turn switch on.
    You should try this setting and check then echo issue.
     

    #14