OP3 OxygenOS 4.0.3 Cellular Data

  1. PrismKDog Cupcake Feb 17, 2017

    PrismKDog, Feb 17, 2017 :
    Recently installed OxygenOS 4.0.3 update, since then cellular data drops.

    A small exclamation mark appears on the cellular icon on the status bar if Android. When turning cellular data off for a while and back on it finally connects.

    Sometimes after the data connection has been established for some time, again the little exclamation mark appears and no data connection exists.

    Please look into this!

  2. Kiran.a.joseph Jelly Bean Feb 17, 2017

    Kiran.a.joseph, Feb 17, 2017 :
    Please try doing a network settings reset and see if it fixes this. Please note that you will lose the saved wifi details on doing a network settings reset and you will have to add the wifi details again.

  3. PTuT Ice Cream Sandwich Feb 17, 2017

  4. PrismKDog Cupcake Feb 17, 2017

    PrismKDog, Feb 17, 2017 :
    APN settings are correct. I've manually selected my network operator from the Network operators option in the SIM settings. That seems to have resolved the issue. So perhaps the auto selection of network operator somehow causes it.

    Just for reference, how would I do a network reset?

  5. PrismKDog Cupcake Feb 17, 2017

    PrismKDog, Feb 17, 2017 :
    Correction: the manual selection of network operator did not fix it, please ignore that observation. Please advise how to reset network settings.

  6. 9038729916 Cupcake Feb 17, 2017

    9038729916, Feb 17, 2017 :
    check network settings
    check apn settings
    if still not resolved turn flight mode on and off.

  7. prajwalpds Eclair Feb 17, 2017

  8. PrismKDog Cupcake Feb 17, 2017

    PrismKDog, Feb 17, 2017 :
    Turning flight mode on and off works, also turning the cell radio power on and off via the testing mode.

    But the problem appears again after switching cellular data off and back on again.

    OnePlus please look into this, seems to be a bug introduced with this update.

  9. runingfrag Cupcake Mar 4, 2017

    runingfrag, Mar 4, 2017 :
    same problem after 7.0 android update my cellular data isn't working it goes to 4g+! and that's it i tried most of suggested things none did help, so i flashed firmware back to android 6.0 and that worked. today was another update that ( i thought might fixed issue) so i installed and same problem.. so pleas oneplus try to fix this... or at least let me turn off notifications for updates is'st anoying.