1
OP6, 7, 8 - Freedom Mobile, Koodo, Telus, Bell - VoLTE and VoWiFi Calling - WORKING!!!

  1. astracd
    Gingerbread Aug 23, 2020

    astracd , Aug 23, 2020 :
    Hello Everyone,

    After trying to get WIFI Calling working for two years - this was my lucky night. (never give up lol). I was in contact with OnePlus and Freedom Mobile bothering them for over two years to make this work, but they didn't do anything about it just pointing fingers to eachother. I was buying cheap freedom mobile phones with broken screens and trying to export freedom mobile options and import to other cheap OP that I had for testing. I was unsuccessful for those two years until other night.

    Confirmed with other users it works with Koodo, Telus and Bell.

    aaa.png

    VoLte.jpg WIFI.jpg

    I have OnePlus 6T - Latest version Android 10 (10.3.5) - With working VoLTE and VOWIFI
    I have people confirmed working successfully on 6, 6T, 7, 7 PRO, 8 and 8 PRO

    Lots of people have issues getting this to work, so I decided to make step by step with pictures to help out.

    Before proceeding please make sure you make a backup via TRWP of your EFS partition BEFORE you flash anything! If you're not rooted, do a nandroid backup via fastboot

    First step is to register / activate your phone number with freedom mobile
    Register WiFi Calling - you should get text from them - if you did this in the past you will not get text. Also make sure you have the latest SIM Card should have P6 on it.

    Second step is to download tools you will need:

    Download drivers only if your computer/laptop doesn't sees your phone
    Install these apps on the phone to make sure you can turn on volte and wifi calling and activate full port during procedure
    Tools to be installed on the computer
    Download mbn file in the EFSTools folder and overwrite one that is in there

    OP6 pick Pixel 3 mbn
    OP7 and OP8 pick Pixel 4 mbn
    Pick Freedom mobile, Koodo or Telus file - whoever is your service provider.

    On your phone open phone dialer and dial *#800# (in this step you can use either EngineerMode, or FactoryMode) - there will be warning just press enter to go to next screen.
    Press oneplus Logkit - go down to Function Switch - check mark VoLTE switch and VoWifi switch
    1 activate volte wifi switch on phone.jpg

    Open Settings --> WiFi & Intenet --> SIM & netwok --> SIM 1 or 2 -->enable VoLTE and VoWifi switch
    Open Settings --> Display --> Status Bar --> Icon Manager --> enable VoLTE and VoWifi

    Connect your phone to the computer (you should hear sound that usb device is connected)
    On your phone open phone dialer and dial *#801# (in this step you need to use EngineerMode)
    Turn on Full Port
    full port.jpg

    On your computer start PDC app as admin
    0 - Starting PDC as admin.png

    Select device and you will get the list of different profiles.
    You should see Oversea-Commercial_DS as active under Sub0 (SIM1) - if you are using your freedom card in SIM1 slot. If your card is in SIM2 you will need to do this under Sub1 that same rule goes in the next steps.
    1.png

    Now select Oversea-Commercial_DS right click and deactivate Sub0 (SIM1)
    After you are done all profiles should show Inactive status
    2 - PDC deactivate Oversea-Commercial DS.png

    Now select Commercial-TMO right click on it SetSelectedConfig - Sub0
    It should show pending under Sub0 for the Commercial-TMO
    Now select Commercial-TMO again and press Activate
    3 - PDC activate Commercial-TMO.png

    Restart your phone
    When it is back up and running check if you still have internet (disable wifi) you should still get 4G/LTE
    Go dialer *#801# and turn on Full port again. - if getting error in CMD then try to turn on Rndis, diag switch instead.
    Run PDC as admin and check if now TMO profile is showing active. - in some cases it goes back to Oversea-Commercial_DS in that case I would try one more time to do same steps and if doesn't stick then I would manually remove it after activating TMO profile then select Oversea and press remove (it is recommended to have EFS backup done here as you are deleting something that can only be fixed by backup, or with reflashing your phone - keep that in mind)

    If you are still on TMO proceed to next steps

    In windows press start and type CMD do not press enter (must be run as administrator) - click with the mouse
    1.png

    Go into folder where you unzipped EFS Tool and run EfsTools.exe efsInfo command to make sure
    you are properly connected. You should not get any errors.

    2.png

    If you are using SIM Card Slot 1 run this:
    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v

    If you are using SIM Card Slot 2 run this:
    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1
    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1
    Restart your phone

    You should have both working now.

    If you have a trouble with these steps let me know and I will try to help you.
     
    Last edited: Oct 26, 2020 at 3:49 AM

    #1
    drmartin likes this.
  2. astracd
    Gingerbread Aug 23, 2020


    #2
  3. danial.aw
    Eclair Aug 23, 2020

    danial.aw , Aug 23, 2020 :
    Thanks for the info... unfortunately did not seem to work for me on my OP7Pro with Telus :(
     

    #3
  4. astracd
    Gingerbread Aug 23, 2020

    astracd , Aug 23, 2020 :
    did you try using telus file?
    ...\Pixel3\mcfg_sw\generic\NA\Telus


    EDIT:
    There are two actually.... try both...
    other one is located in ....\Pixel3\mcfg_sw\generic\Pixel\NA\Telus\Lab\CA
     

    #4
  5. danial.aw
    Eclair Aug 23, 2020

    danial.aw , via OnePlus 7 Pro , Aug 23, 2020 :
    Ya I used the Telus file both the commercial and the lab... Doesn't seem to do anything for me.

    Not sure if that's the carrier IMEI block or if it the method doesn't work on OP7Pro
     

    #5
  6. astracd
    Gingerbread Aug 23, 2020

    astracd , Aug 23, 2020 :
    are you getting errors when using these 3 steps?

    EfsTools.exe efsInfo

    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim

    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
     

    #6
  7. astracd
    Gingerbread Aug 23, 2020

    astracd , Aug 23, 2020 :
    check if you have latest sim card
    and try to activate your volte vowifi with phone that works with Telus then put it in your OP7
     

    #7
  8. zhanyang5858
    Donut Aug 24, 2020

    zhanyang5858 , Aug 24, 2020 :
    EfsTools.exe efsInfo give me an error


    Critical error. Value cannot be null.
    Parameter name: PortName
     

    #8
  9. astracd
    Gingerbread Aug 24, 2020

    astracd , Aug 24, 2020 :
    Make sure that you run CMD as administrator and that you activated *#801# Full port and when you connect your phone make sure to change - charging this device via USB to File transfer to make sure your computer sees the phone.

    after running EfsTools.exe efsInfo you should get this msg:
    Use serial port 'COM4' -> it will show your port mine is com4.
    Version: 1, MaxDirectories: 50, MapPathnameLength: 1024, MaxFileSize: 0, MaxFilenameLength: 768, MaxMounts: 36, MaxSymlinkDepth: 0

    That means you are good to go to next step.
     

    #9
  10. zhanyang5858
    Donut Aug 24, 2020

    zhanyang5858 , Aug 24, 2020 :
    thanks for your guidance, I will try to find a Fido mbn file and then try again. Thanks for the help![e]1f44d[/e]
     

    #10
    astracd likes this.
  11. D1599434657639
    Cupcake Sep 7, 2020

    D1599434657639 , Sep 7, 2020 :
    I am working through this procedure and find my phone defaults back to Oversea-Commercial_DS being active after restart. If I follow the procedure with my SIM card removed it will keep Commercial-TMO as active. The question is can I continue to upload the MBN file with the Freedom profile and then re-insert my SIM? This way I would not have to delete Oversea-Commercial_DS. Anyone try this? Thoughts?
     

    #11
  12. Tholudee
    Cupcake Sep 8, 2020


    #12
  13. Tholudee
    Cupcake Sep 8, 2020

    Tholudee , Sep 8, 2020 :
    having same issue
     

    #13
  14. Tholudee
    Cupcake Sep 8, 2020

    Tholudee , Sep 8, 2020 :
    Just retried the steps using @
    working now alo follwoed the steps from https://forum.xda-developers.com/oneplus-7-pro/how-to/freedom-mobile-volte-vowifi-calling-t4153631

    Thanks so much
     

    #14
  15. A Cow
    Cupcake Sep 27, 2020

    A Cow , Sep 27, 2020 :
    I'm having a awful issue.. OP8Pro

    I can't get the EfsTools.exe to run.. keeps saying "critical error bad command"

    Code:
    C:\Efs>EfsTools.exe efsInfo
    Use serial port 'COM3'
    Critical error. Bad command
    Tried a ton of things.. version seems to work..

    Code:
    C:\Efs>EfsTools.exe version
    EfsTools 0.11.0.11
    But the writeFile also seems to fail

    Code:
    C:\Efs>EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    Use serial port 'COM3'
    Critical error. Bad command
    Update:
    Tried on a second computer.. Exact same error ( even com3 :D surprising because I use a ton of com devices on this computer )

    Any recommendations would be amazing thanks

    Thanks :D
     
    Last edited: Sep 27, 2020

    #15
  16. astracd
    Gingerbread Oct 1, 2020

    astracd , Oct 1, 2020 :
    I posted on xda as well.

    I found that people with 8 PRO are turning on something else (rndis, diag switch) - not full port: "- Select "Rndis, diag switch" - ON (last time we selected "full port switch on")
     

    #16
  17. sachinsatheesh
    Cupcake Oct 2, 2020

    sachinsatheesh , Oct 2, 2020 :
    Hi,

    Thanks for this post. I have been trying to get Volte enabled on my phone, and am glad to know that finally some one made it work.

    QQ. The profile reverts to overseas, after i restart the phone. So, i was planning to remove it after activating TMO.But, i just noticed that when i activate TMO, phone immediately switches to 3G(H+) and is no longer able to connect to 4G network. Is this normal?

    If i activate TMO, remove overseas and restart the phone, will it connect to 4G again?
     

    #17
  18. astracd
    Gingerbread Oct 3, 2020

    astracd , Oct 3, 2020 :
    Did you in the past tried to load some other profiles to EFS with command prompt ?
     

    #18
  19. sachinsatheesh
    Cupcake Oct 3, 2020

    sachinsatheesh , Oct 3, 2020 :
    Nope. Everything is stock. This is the first attempt.
     

    #19
  20. V1593527977049
    Cupcake Oct 11, 2020

    V1593527977049 , Oct 11, 2020 :
    Folks, this method worked for me on OP 8Pro (Freedom Mobile) on OxygenOS 10.
    After upgrading for OxygenOS 11 (release), the method no longer works. Looking forward to updated instructions.
     

    #20