2
OP6, 7, 8 - Freedom Mobile, Koodo, Telus, Bell - VoLTE and VoWiFi Calling - WORKING!!!

  1. stone263964
    Cupcake Oct 11, 2020


    #21
  2. Q1590894697853
    Cupcake Oct 28, 2020

    Q1590894697853 , Oct 28, 2020 :
    For those with a 7pro, on Telus/Koodo/Freedom who got VoLTE working, can you tell me if you previously had a carrier provisioned phone on your account/profile before your 7pro?
    I can not not get my 7pro to IMS register except for Bell/Virgin sim cards. But my Bell Samsung is already provisioned for VoLTE on the Bell account.
     

    #22
  3. S1548100365593
    Cupcake Nov 5, 2020

    S1548100365593 , Nov 5, 2020 :
    Thank you for loading these instructions. However unfortunately I am getting at step 0 "make sure you make a backup via TRWP of your EFS partition". I have tried to install "TRWP" but discovered that in turn this requires yet another two programs called ADB and Fastboot. I have managed to install these, but can't run Fastboot with the TRWP image since it tells me my device is "locked". I then looked up how to fix this, but the website I found said this would delete all the data from my phone.

    Can you give me clear and simple instructions for how to install TRWP (obviously without wiping my phone!). Sorry for the basic questions.
     

    #23
  4. Wii442
    Cupcake Nov 14, 2020

    Wii442 , Nov 14, 2020 :
    any more updates or tricks to get this to work? no matter what commands or computer or administrator powershell/cmd window I use i keep getting

    Use serial port 'COM5'
    Critical error. Bad command
    with Full-port switch on

    and
    Use serial port 'COM6'
    Critical error. Bad command
    when I use Rndis,daig switch on

    if i try to use serial i just get booted from engineerong mode and have to key back in
    My efstools version (which works fine) says 0.11.0.11, is there a newer version I cant find?
    also if i try any verb command (eg. efstools.exe targetinfo) I get "Verb 'targetinfo' " is not recognized

    other than that every prior step has worked great
    - am i using the syntax wrong "efstools.exe efsinfo"
    - is there a way to change the com port if im not on the right one ?(or is the message
    " .\EfsTools.exe efsInfo
    Use serial port 'COM5'
    Critical error. Bad command")
    mean Im on thre right port but im back to the verb being wrong even though it shows up when I use help?

    Im on Shaw/Freedom with an OP8+ Oxy 10.5.12

    Helps, Im sure this will work but no idea what Im missing or going wrong
     

    #24
  5. bsreekanthreddy
    Cupcake Nov 21, 2020

    bsreekanthreddy , Nov 21, 2020 :
    Yayyy!!! I finally got volte and vowifi working on my phone. I am with Telus and using OnePlus 6. The instructions here got Volte working right away but I couldn't get wifi calling working. The missing instructions were that you need to enable wifi calling by registering your number at below site. None of Telus techs know this and I dug this up from some forum. After I enabled wifi calling using below link and rebooted my phone wifi calling started working.. Thanks everyone for everything.

    https://telusidentity.telus.com/as/authorization.oauth2?client_id=telus_egw_2585&response_type=code&scope=ciiotp sub_profile&redirect_uri=https://ent.telus.com/acmegw-android/entitlement/e911
     

    #25
  6. M1606268020182
    Cupcake Nov 25, 2020

    M1606268020182 , Nov 25, 2020 :
    Its not the com port that causing error. qualcomm d
    Its not the com port that causing the error, qualcomm driver are the cause.
    update your port driver from "Qualcomm HS-USB Diagnostics MDM xxxx" to " Qualcomm HS-USB Diagnostics 9001" driver and don't select "Full-port switch" instead "Rndis,diag switch"
    Work for me, both Vowifi and Volte, Freedom Mobile, OOS 11.0.1.1
     

    #26
  7. Wii442
    Cupcake Nov 25, 2020

    Wii442 , Nov 25, 2020 :

    thanks for the info but still no luck. I trired both vervions of the 9001 driver on both Full Port and RdIS and I keep getting the same type of error. I tried different ports on my compurt on the different variations and most of the HS-USD Diagnostics 9000 variations...no luck with any of them.. maybe I should try on an older computer? or any other thoughts?
    I keep getting the

    Use serial port 'COM5'
    Critical error. Bad command

    there has got to be a way... lol

    thanks for any and all suggestions

    OP8 Pro O2 10.5.12 (not ready for 11 till TWRP)
     

    #27
  8. M1606268020182
    Cupcake Nov 25, 2020

    M1606268020182 , Nov 25, 2020 :
    I use efstools 1.1 dont know if that make a different., Rndis,diag, full-port doesnt work for me.(oneplus 8 pro rooted)
    Screenshot (1).png
     

    #28
  9. Dr.VinitShah
    Cupcake Nov 26, 2020

    Dr.VinitShah , Nov 26, 2020 :
    Hi. I'm in the exact same situation but with Bell. Followed this guide and have VoLTE but am not able to get WiFi calling working. I'm sure the reason is I am not able to register for e911 t&c. How did you find this link for Telus? Can you by any chance find something similar for Bell? I have tried but no success.
     

    #29
  10. Wii442
    Cupcake Dec 6, 2020

    Wii442 , Dec 6, 2020 :

    Sorry for being slow to resond and thanks for the help

    so i can get EFSinfo using efstools11 and on the Rndis setting but when i try the next 2 steps i get

    PS C:\efstools11> ./EfsTools.exe efsInfo
    Use serial port 'COM6'
    Version: 1, MaxDirectories: 50, MapPathnameLength: 1024, MaxFileSize: 0, MaxFilenameLength: 768, MaxMounts: 36, MaxSymlinkDepth: 0
    PS C:\efstools11> ./EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    Use serial port 'COM6'
    Critical error. Could not find file 'C:\efstools11\mcfg_autoselect_by_uim'.

    any suggestions on what Im missing now?

    thanks again..

    how do you like OS11? any word on TWRP yet? I havnt seen anything myself
     

    #30
  11. astracd
    Gingerbread Dec 6, 2020

    astracd , Dec 6, 2020 :
    why are you using ./ at front of EfsTools.exe
     

    #31
  12. astracd
    Gingerbread Dec 6, 2020

    astracd , Dec 6, 2020 :
    why are you using ./ at front of EfsTools.exe

    and try to use EfsTools-0.10-modded-1.2-win32.zip instead efstools11. It may be missing some files you need.
     

    #32
  13. Wii442
    Cupcake Dec 7, 2020

    Wii442 , Dec 7, 2020 :


    because im using powershell and its an outside command
     

    #33
  14. Wii442
    Cupcake Dec 7, 2020

    Wii442 , Dec 7, 2020 :

    I just checked and I was using the modded versions of EFSTools
     

    #34
  15. Wii442
    Cupcake Dec 7, 2020

    Wii442 , Dec 7, 2020 :

    ok I think I figured it out.. time will tell..

    so in EFSTools11 (the modded zip) the command
    "mcfg_autoselect_by_uim is not in the folder"
    but it was in EFSTools12, so I compied it over to the 11 folder
    (I will note that anything on EFSTools12 would not work no matter what I tried, EFSTools11 worked great, especially after I copied the autoselect command)
    and it had to be RnDIS as suggested as well as the qualicomm USB diagnostic 9001 v2 drivers

    anyway that you for all your help and information

    I just checked, I put phone on airplane mode, turned on wifi and it all works great. I even have the the symbol in the upper left..very happy
     

    #35
  16. Wii442
    Cupcake Dec 7, 2020

    Wii442 , Dec 7, 2020 :
    now looking forward to upgrading to OS11 and probably have to do it all over again but now I know it can work.. now just to find TWRP for Oxygen 11. LOL
     

    #36
  17. Wii442
    Cupcake Dec 10, 2020

    Wii442 , Dec 10, 2020 :

    hello again..
    So I updated to OS11.2.2 from OS10 and of course lost VoLTE and VoWIFI but the setting stayed in Settings>..Sim 1 so no issues there..
    I had to use
    setprop sys.usb.config diag,serial_cdev,rmnet,adb
    to get PDC running and change those settings
    and they stuck so that is fine
    but no matter what I try with either EFSTools i get the old

    Use serial port 'COM6'
    Critical error. Bad command

    issues again
    I did change the driver to your suggested
    Qualcomm HS-USB Diagnostics 9001 (both versions)
    and several others and with Rndis and full-port all with the same end result

    I have tried the shell command

    setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb

    which I found posted to enable QPST and EFS I can get a little info with QPST but I dont think everything and use EfsTools.exe efsInfo I get port busy but only on the Qulicomm mdm drivers and missing port on the 9001 drivers

    I have noticed that on Rndis i get the to see the port and modem listed as whichever driver I have installed but it changed the USB Mode to tethering but on full-port I dont really see the phone at all unless I put it on file transfer mode

    I think I'm ok at modding and altering android phones and am always learning which is fun.. but then i find out how little I know and appreciate the help of the community.
    is the EFStools an actual program of something pulled out of QPST, what am I looking for in the driver or what is EFSTool looking that it finds the ports but does not seem to communicate? i have tried to dig deeper on google but never seem to get anywhere but lots of similar steps for other phones.. if someone could point me in a direction for more info maybe I could be more help to others..

    anyway all help appreciated once again
     

    #37
  18. M1606268020182
    Cupcake Dec 10, 2020

    M1606268020182 , Dec 10, 2020 :
    If you can get into PDC to change to setting that's great.
    The second part on efstools has nothing to do with QPST, same process as before to get volte to work, make sure to end all QPST process or it will conflict the COM port. Second thing try Command Prompt instead of power shell.
    And one more thing, you can only have one COM port enabled which is 9001, disable all other ports or uninstall it.
     

    #38
  19. Wii442
    Cupcake Dec 10, 2020

    Wii442 , Dec 10, 2020 :
    Ok, I do try both powershell (just works so much nicer) but and usually use the CMD prompt as it seems to be preferd by you and most. (both do seem to work the same except for the ./ part)
    I only tried QPST a couple time to see if it could access the phone but while I think my phone shows it says "No IEMI" found so I dont think its working properly, and EFStools reports as com busy so I get what you are saying for not using or end all the processes. the other port the shows up is not an PORT, but a MODEM port if that makes any difference.. Ill remove it later after and see what happens..thanks again
     

    #39
  20. M1606268020182
    Cupcake Dec 10, 2020

    M1606268020182 , Dec 10, 2020 :
    Ur Welcome.
    Or you can try this to get all port working.
    *#801# click on "Engineer Mode Toggle", update all the drivers to "Qualcomm HS-USB MDM Diagnostics 90B6".
    It works the same without any error. As you can see on my screenshot.
    Screenshot 2020-12-10 144218.png
     

    #40