3
OP6, 7, 8 - Freedom Mobile, Koodo, Telus, Bell - VoLTE and VoWiFi Calling - WORKING!!!

  1. Wii442
    Cupcake Dec 12, 2020

    Wii442 , Dec 12, 2020 :
    Ill attach what I am seeing
    upload_2020-12-11_20-30-53.png

    when you connect your phone and go into engineer mode then select Rndis what mode does your phone go to or do you set it at? mine automatically goes to "tethering" mode and if I switch to files transfer it disapears but im able to view it in file manager and if i switch to no transfer then i get my phone twice (IN2025) with a yellow triangle. which i take to mean no windows access but I can still see it with ADB devices
     

    #41
  2. Wii442
    Cupcake Dec 12, 2020

    Wii442 , Dec 12, 2020 :
    ok, ok.. i kept re reading what you sent last and so I put my phone onto no transfer mode and had the 2 IN2025 with trianges show up, I updated the drivers to the one you suggeted, tried it, no change, rebooted the phone and laptop still nothing changed the drivers from Qualcomm HS-USB MDM Diagnostics 90B6 v2 to v1, no change, unplugged and replugged the phone and voila.. efsinfo gave me the info.. and of course everything else worked as it should from that.. I rebooted my phone and now can conform that I I VoLTE and VoWIFI workinng great on OP8 Pro on OS11.2.2

    thak you and the op who created this post.. hopefully the info I added to your can help others
     

    #42
  3. NateDev
    Honeycomb Jan 24, 2021

    NateDev , Jan 24, 2021 :
    Thanks, confirmed working here on a 7Pro, Freedom Mobile on Android 11 OB1.

    I had to use this mbn file instead: https://mega.nz/file/KcFCzSzS#tgoVBtdaWqLW4ZMyDXbuuIimDD7vhjQZsqwNSL7yiDw and to get PDC to display my phone, I had to run adb shell, su, setprop sys.usb.config diag,serial_cdev,rmnet,adb after enabling full port mode. I also used the drivers given here: README - Google Docs

    If anyone has any problems with the steps just tag me. Tip: try copy pasting EFSInfo command, I would get an error if I didn't do that even though the command looked the same.
     

    #43
    lexcyn likes this.
  4. lexcyn
    Eclair Jan 24, 2021


    #44
  5. luigimario
    The Lab - OnePlus 6T Reviewer Feb 3, 2021

    luigimario , Feb 3, 2021 :
    Wow, this is really interesting. Any idea if it would work with Public Mobile? Technically on the Telus network but not sure if they even support VoLTE.
     

    #45
  6. Wii442
    Cupcake Feb 16, 2021

    Wii442 , Feb 16, 2021 :
    Sorry about this, but I'm back looking for information once again.. I just installed OS 11.0.4.4 and lost VoWIFI and VoLTE again.. and once again I can get everything done up until the efstools part.. where all I get is the

    Use serial port 'COM5'
    Critical error. Bad command

    Ive tried many of the qualicomm drivers all with the same result. (it always wants to revert back to driver Qualcomm HS-USB Diagnostics MDM 90B6)
    Thanks for new ideas and help. if there is a secret or way to find out what driver efttools wants with new update Im more than willing to learn and help others where I can

    thanks
     

    #46
  7. G_Boris_Sweden_lHuW
    Gingerbread Feb 16, 2021

    G_Boris_Sweden_lHuW , Feb 16, 2021 :
    What device mbn files can I use for Oneplus 3/3T?
     

    #47
  8. LSXrex
    Donut Feb 28, 2021

    LSXrex , Feb 28, 2021 :
    So I am under the impression that we are still not able to use the volte and vowifi. I don't understand why OnePlus keeps bringing out updates for us without just unlocking these features to begin with
     

    #48
  9. FTAFreedom
    Gingerbread Apr 7, 2021


    #49
  10. S1616276547926
    Cupcake Apr 8, 2021

    S1616276547926 , Apr 8, 2021 :
    Please help. I'm getting the exact same error. How did you fix it?

    I am making sure my EngineerMode - Engineer Mode Toggle is ON; My USB Debug is ON; and that USB file transfer is turned on (I can see the phone in Windows Explorer).

    What am I doing wrong?
     

    #50
  11. DerNachbar
    Honeycomb Apr 19, 2021

    DerNachbar , via OnePlus 7T Pro , Apr 19, 2021 :
    Here it's backwards. Got VoWifi but no Volte - also koodo
     

    #51
  12. FTAFreedom
    Gingerbread Apr 19, 2021

    FTAFreedom , via OnePlus 9 Pro , Apr 19, 2021 :
    We can't have VOLTE working on OP9 pro until Koodo officially supports the phone....which will never happen...sadly....
     

    #52
  13. DerNachbar
    Honeycomb Apr 19, 2021

    DerNachbar , via OnePlus 7T Pro , Apr 19, 2021 :
    Not 100% right because it worked on my OP6T. Just needed to ask the customer service to enable it in my account. when its activated you can see it in self serve -> add ons
     

    #53
  14. FTAFreedom
    Gingerbread Apr 20, 2021

    FTAFreedom , via OnePlus 9 Pro , Apr 20, 2021 :
    I can confirm this works even if your on Koodo it will add VoLTE to your profile as an add-on which most Koodo CSR won't do or know how to do. WiFi calling will work and if OnePlus ever gets official carrier support your VoLTE will work right away without doing anything.
     

    #54
  15. A1618452204159
    Cupcake May 4, 2021

    A1618452204159 , May 4, 2021 :
    Thanks to all your tips I managed to get everything done with no errors on my new oneplus 8 pro, 11.0.5.5.IN11AA (no root) with Shaw (freedom).
    I had no luck getting 'EfsTools-0.10-modded-1.2' to work without the 'critical error Bad command', but 'EfsTools-0.10-modded-1.1' worked for me. Even though everything seemed to go smooth I still haven't been able to get VoLTE or VoWifi to work at all. Just to confirm I performed some of the steps correctly:
    • in PDC I selected 'Commercial-TMO' and confirmed that it stuck after reboot.
    • I copied the 'mcfg_sw.mbn' file from 'Pixel 4 android 11 mbn\Pixel 4 android 11 mbn\mcfg_sw\generic\Pixel\NA\Freedom\pixel_VoLTE' downloaded from a link above into the EfsTools folder.
    I just bought this phone and would really like to get this working or I will have to return it so I'd appreciate any tips. Would it make any difference if I root the phone? I would be willing to root but would like to avoid if it's not necessary.
     

    #55
  16. I1585847133454
    Cupcake Jun 1, 2021

    I1585847133454 , Jun 1, 2021 :
    It just worked for me.
    I have a one plus 7 with OOS 11.0.1.1 in France
    My operator is Orange, I used the efs method, I copied the Bouygues Telecom mbn from a mi 9t that I founded on phonandroid.fr, then contacted Orange to enable volte and vowifi and everything works fine
     

    #56
  17. W1575158142263
    Cupcake Jun 21, 2021

    W1575158142263 , Jun 21, 2021 :
    HI,

    I am running OnePlus7 Pro Oxygen Android 11.0.1.1.GM21AA and am unable to get this working.

    I called Koodo and they said I am already provisioned. Am I wasting my time with this device to get it working or should I just move on and get a different device that supports WIFI calling?
     

    #57
  18. bubbob
    Froyo Sep 25, 2021

    bubbob , Sep 25, 2021 :
    I'm trying this as well and does not work. Firstly, I'm on OP 8 Pro and am installing Windows driver for the Qualcomm modem, what is the advised driver I should install or does it matter? I've read several forums and they all use different and cannot seem to find one that is definitive.
    Secondly, when I use the PDC it does not find my phone which seems to be attributable to OOS 11 or that my driver is not appropriate. This is where I'm stuck. I'm able to turn on Engineering mode and cannot seem to go further. Seems people all have different avenues to get it working but everyone seems to also encounter different issues. Its so hard to find a clear concise way to enabling VoLTE, VoWifi which is a selling feature of this phone. I'm on Freedom Mobile BTW. Any guidance and advice is appreciated.
     

    #58
  19. astracd
    Gingerbread Oct 4, 2021

    astracd , Oct 4, 2021 :
    This new method requires Root on Android 11.
    Please note Engineering won't work on Android 11. you need to follow the following steps to open the ports.

    You need Adb tool Platform-tool.
    https://dl.google.com/android/repository/platform-tools-latest-windows.zip

    Open CMD run as administrator
    • cd/
    • cd platform (or whatever folder is called where your files are)
    • adb shell (check phone allow connection to PC)
    • su
    • setprop sys.usb.config diag,serial_cdev,rmnet,adb

    Open PDC as administrator
    • Activate Commercial_TMO under Sub0 (SIM1), Sub1 (SIM2); - as per instructions on first page
    Open CMD run as administrator
    • cd/
    • cd op6t/efstools (or whatever folder is called where your files are)
    • EfsTools.exe efsInfo
    If you are using SIM Card Slot 1 run these two codes:
    • EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    • EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
    If you are using SIM Card Slot 2 run these two codes:
    • EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1
    • EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1

    Restart your phone!
     

    #59
  20. bubbob
    Froyo Oct 5, 2021

    bubbob , Oct 5, 2021 :
     

    #60