6
OP6 OxygenOS9 Wi-Fi tethering not working with Volkswagen

  1. Kenny_Vleminckx
    Froyo Sep 25, 2018

    Kenny_Vleminckx , Sep 25, 2018 :
    Hey OnePlus -ers!
    Got a problem since upgrading my OP6 to official Android Pie.
    My Volkswagen head unit successfully connects to my OP6's hotspot but there's no internet connection.
    It used to work on Oreo but now it fails.
    Tethering to a laptop works, I've not changed any settings.

    Anyone else experiencing this issue?
    Or is there anyone with a VW-Audi (or any other VAG-group car) where tethering works on a OP6 running Pie?

    I know it's a first-world-problem but it's a problem none-the-less...
     

    #1
    Ahmet42, Sharry7, bilicide and 3 others like this.
  2. V1537888856937
    Cupcake Sep 25, 2018


    #2
    Joffy_Jose likes this.
  3. rahulmjr
    Cupcake Sep 25, 2018

    rahulmjr , Sep 25, 2018 :
    I am also facing this problem in my OP6 device since yesterday. It's still in Oreo... I haven't got the update yet.. but portable mobile hotspot is not working when connected with laptop...

    need help... thanks
     

    #3
    V1537888856937 likes this.
  4. daniele.tarticchio
    Honeycomb Sep 26, 2018

    daniele.tarticchio , Sep 26, 2018 :
    Same here, not with a Volkswagen but with any device: connected without internet. It was working perfectly before the OTA...
     

    #4
  5. Darthrafa
    Cupcake Sep 30, 2018

    Darthrafa , Sep 30, 2018 :
    Same for me, since upgrade to Android 9.0 (Pie), wifi hot spot is not working properly. It does connect to my laptop but does not give internet access.
     

    #5
  6. Kenny_Vleminckx
    Froyo Oct 1, 2018

    Kenny_Vleminckx , Oct 1, 2018 :
    Hi all, thanks for chiming in!
    Às the issues you're describing don't match fully to what I'm experiencing, I suggest you to create your own topic.
    I've been contacted by Celia Chen from OnePlus's bug hunters to provide more logging - which I did.
    Hopefully the issue can be pinpointed and fixed !
     

    #6
  7. hans.rymenants
    Cupcake Oct 3, 2018

    hans.rymenants , Oct 3, 2018 :
    I have exactly the same problem with my VW and OnePlus 6 Android pie. The tethering connection is made but no internet available. Also it isn't possible anymore to automatically start up wifi tethering with Tasker.
     

    #7
  8. slopface
    Cupcake Oct 21, 2018


    #8
    tuoniemi likes this.
  9. leonardo.burchi
    Cupcake Oct 21, 2018


    #9
  10. lordsgaki
    Cupcake Oct 21, 2018

    lordsgaki , Oct 21, 2018 :
    can y update y VW?
     

    #10
  11. G_Chris_Ingham_IMKW
    Eclair Oct 27, 2018

    G_Chris_Ingham_IMKW , Oct 27, 2018 :
    I have exactly the same on my 2017 passat.

    The car was working fine until the update the infotainment system knows it has a connection but no access to the Internet.

    Infotainment works fine connected to other phones but not the OP6.

    On the hotspot page in the settings there is a section that shows connected devices. When I conect another device to the OP6 hotspot you get a name come up but when the car connects all you get is a *

    I belive the infotainment system is not passing the MAC address to the OP6 so the OP6 does not give it a port?
     

    #11
  12. G_Chris_Ingham_IMKW
    Eclair Oct 27, 2018

    G_Chris_Ingham_IMKW , Oct 27, 2018 :
    Hi the infotainment system is at the latest software.
    The infotainment system works with several other phones on there hotspot.
     

    #12
  13. G_Chris_Ingham_IMKW
    Eclair Oct 28, 2018

    G_Chris_Ingham_IMKW , Oct 28, 2018 :
    Hi
    Have you had any more response from OP on this problem?
     

    #13
  14. Kenny_Vleminckx
    Froyo Oct 28, 2018

    Kenny_Vleminckx , Oct 28, 2018 :
    there's a new action in Tasker to start tethering. had the same issue, resolved it by using 'toggle tethering' action.
     

    #14
  15. Kenny_Vleminckx
    Froyo Oct 28, 2018

    Kenny_Vleminckx , Oct 28, 2018 :
    yes, the dev team is actively working on this issue. I've had an update file after providing radio logs, which didn't fix it. they're now analyzing the new logs
     

    #15
  16. G_Chris_Ingham_IMKW
    Eclair Oct 28, 2018

    G_Chris_Ingham_IMKW , Oct 28, 2018 :
    Thanks Kenny
    Hope they fix soon. The sat nav in the VW is useless with out Internet.
    Could you please keep us posted on this thread?
    In the hotspot setting page on your OP6 down at the bottom under connected devices does it show a name or just a *

    If I conect a iPad to my phones hotspot I get a name of the device come up?
    I belive this to be the problem.
     

    #16
  17. Kenny_Vleminckx
    Froyo Oct 28, 2018

    Kenny_Vleminckx , Oct 28, 2018 :
    Same issue, only shows a *
    Will keep y'all posted
     

    #17
  18. G_Chris_Ingham_IMKW
    Eclair Nov 2, 2018

    G_Chris_Ingham_IMKW , Nov 2, 2018 :
    Hi Kenny

    Have you had anything back from oneplus?
     

    #18
  19. Kenny_Vleminckx
    Froyo Nov 2, 2018

    Kenny_Vleminckx , Nov 2, 2018 :
    nope, nothing yet. Got to give those dev's some time too. Let's be patient.
     

    #19
  20. G_Chris_Ingham_IMKW
    Eclair Nov 2, 2018

    G_Chris_Ingham_IMKW , Nov 2, 2018 :
    Lol thanks for the reply.
     

    #20
    Kenny_Vleminckx likes this.