0
OP6: Qualcomm Crashdump Mode when fastboot boot twrp.img - 2021

  1. Enoal Fauchille
    Cupcake Oct 14, 2021

    Enoal Fauchille , Oct 14, 2021 :
    Hello. I recently updated my Oneplus 6 to OxygenOS 11 by the Oxygen Updater. My device is Rooted so i lost my root. But when I'm trying to root again my phone with TWRP by "fastboot boot twrp-3.5.2-enchilada.img", it show a beautiful "Qualcomm Crashdump Mode" page with the content:
    "Attemped to kill init! exitcode=0x0000000b, complete_and_exit"
    My device is actually alive and not bricked, and i want to keep my datas without a factory reset.

    My goal is to start TWRP by "fastboot boot".
    After some hours of searching, i found somes issues, but outdated (2 years).
    We need to create a new solution in 2021, to help everyone who's lost like me.

    I already found some pieces of a way to find an issue:
    I tried to press Vol Up + Power on the Qualcomm error page and it did a black screen but i don't know if i did that correctly.
    I don't want to lost my datas by the MSM tool, flash stock ROM or something like this.
    I don't know if there is a "bypass" method to start TWRP properly.
    I heard something about the Emergency Mode (EDL), but i think it's for flashing Stock ROM.

    Please help me and everyone.
    Thank you so much
     

    Attached Files:


    #1
  2. Artemus
    Junior Moderator, Community Hero 2020 Junior Moderator Oct 14, 2021

    Artemus , Oct 14, 2021 :
    Which guide did you follow?
     

    #2
  3. Enoal Fauchille
    Cupcake Oct 15, 2021


    #3
  4. Ganesha07
    Honeycomb Oct 17, 2021


    #4
  5. Enoal Fauchille
    Cupcake Oct 21, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 21, 2021 :
    Hello, I'm sorry I can't help you.
    If you need help, create a new thread, and please do not comment to an other thread. Thank you
     

    #5
  6. orteeltjes
    Cupcake Oct 21, 2021

    orteeltjes , Oct 21, 2021 :
    ------------------------------------------------------------------------------------
    Hi Enoal.

    I have exactly the same problem. I too have done this way dozens of times after installing an update. Now suddenly this problem. I'm going to try something else this week, but if anyone has a solution I'd love to hear it.

    My way that always worked.
    Open a powershell in ADB.
    Install there in temporary twrp via fastboot and run.
    In temporary twrp install the permanent twrp.
    Then install in permanent twrp magisk.

    Now after fastboot boot twrp.img comes the fastboot logo and then the error attempted to kill init

    Greetings André from Holland
     

    #6
    Enoal Fauchille likes this.
  7. Enoal Fauchille
    Cupcake Oct 21, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 21, 2021 :
    Hello !
    Oof thank you I am not alone with that problem. You have exactly the same problem. This weekend I'll try to backup my datas and use the MSM tool to repair the Qualcomm system. It will to a wipe data and I think "delete" the Qualcomm error problem.

    https://www.droidwin.com/fix-qualcomm-crashdump-mode-oneplus/
    On this link, I already tried the first method and now I'll try to make the second.
    From a Google search "Qualcomm Crashdump mode fix" we can find so much website this theses methods.

    To solve this problem we need a HERO !!!
     

    #7
    orteeltjes likes this.
  8. orteeltjes
    Cupcake Oct 21, 2021

    orteeltjes , Oct 21, 2021 :
    Hope it works. I have no much time this weekend. :-(

    How do you backup your data? Google?
     

    #8
  9. orteeltjes
    Cupcake Oct 22, 2021

    orteeltjes , Oct 22, 2021 :

    The first method is also working for me.
    Maybee I try the second also soon.
     

    #9
  10. Enoal Fauchille
    Cupcake Oct 22, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 22, 2021 :
    Ye google, pack extractor, pick files with a PC. And 🤞
     

    #10
  11. Enoal Fauchille
    Cupcake Oct 26, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 26, 2021 :
    Hi. I have news. I have an idea. I searched and we are doing update and after root again the device. But most of people do the update, don't restart, root TWRP and Magisk on the second slot. And when restart they have the update and root.
    Like that we can do that I think. So I'll try that steps by steps :
    1 - Save data (for a potential wipe data)
    2 - downgrade the version, to remove the Qualcomm Crashdump mode error and root again
    3 - root again the device
    4 - flash the updated, flash TWRP (if you want) and Magisk on the second slot
    5 - Restart and enjoy

    I'll try that and I will let you know if it's working

    Source : https://forum.xda-developers.com/t/...0000;component=com.opera.gx/.MainActivity;end
    "That makes SafetyNet pass? I did the classic routine:
    - Install full zip (OnePlus6TOxygen_34.J.60) via 'Local upgrade' - no rebooting
    - Flash TWRP installer (I had 3.4.0-11) via Magisk - no rebooting
    - Flash Magisk via Magisk to other slot
    - Reboot! All done."
     

    #11
  12. orteeltjes
    Cupcake Oct 26, 2021

    orteeltjes , Oct 26, 2021 :

    Great find Enoal.

    I will here from you and when I have an evening free and enough time, I will try it also.
    Then you here from me.
     

    #12
  13. Enoal Fauchille
    Cupcake Oct 26, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 26, 2021 :
    Ok I will try that tomorrow or Thursday
     

    #13
  14. orteeltjes
    Cupcake Oct 27, 2021


    #14
  15. orteeltjes
    Cupcake Oct 27, 2021


    #15
  16. Enoal Fauchille
    Cupcake Oct 28, 2021


    #16
  17. orteeltjes
    Cupcake Oct 28, 2021

    orteeltjes , Oct 28, 2021 :
    great!
    Did you the Android 11 upgrade with update in Oxygen, then flash TWRP and Magisk without reboot. Then reboot?

    And how did you flash twrp and magisk without reboot? With magisk?
    I try tonight.
     
    Last edited: Oct 28, 2021

    #17
  18. Enoal Fauchille
    Cupcake Oct 28, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 28, 2021 :
    Yes this is steps of how I did that:
    - Download a OxygenOS of Android 10 (i did 10.3.11)
    - Download TWRP and Magisk
    - Save your data (wipe data)
    - Open settings --> Updater --> Local Update
    - Put your OOS 10 in your main storage
    - So click on your version in Local Update
    - Installing....Reboot and say bye... Wiping data
    - Start on Android 10, so put TWRP zip and img and Magisk to root your device. Fastboot steps to root i think you know how 😄
    - Restart your rooted device on Android 10, and Download the Android 11 update and same steps install it in Local Update
    - Do not reboot, from magisk, go to modules, Install From Storage, and flash the TWRP zip, go to main menu of Magisk and click on Install, and choose OTA Method, after that Reboot
    - And you're rebooting on Android 11 ROOTED
    Ask me if you have any questions
     

    #18
  19. orteeltjes
    Cupcake Oct 28, 2021

    orteeltjes , via OnePlus 6T , Oct 28, 2021 :
    IT Worked for me to!! Great!
    I installed Oxygen android 11 stable version downloaded from XDA.
    Now the updater is Telling me to update to 11.1.1.1
    Is this also in your 6T? said:

    Do you think that I can do the update don't restart, flash twrp and install magisk.
     
    Last edited: Oct 29, 2021

    #19
  20. Enoal Fauchille
    Cupcake Oct 29, 2021

    Enoal Fauchille , via OnePlus 6 , Oct 29, 2021 :
    Nice, Congratulations!
    So now if you're not in OOS 11.1.1.1, you need probably to do the update. For me, i just did the Android 10-11 Upgrade directly by OOS 11.1.1.1 so I don't have updates to do.
    Now if we are on Android 11 and an upgrade to do, we need to do this steps :
    - Save datas (if you want, no wipe data)
    - Download and install OOS update, do not reboot
    - In Magisk manager, Modules, Install from Storage, TWRP zip
    - In Magisk again, Magisk Install, OTA Method, and reboot
    - Starting on Android 11 update OOS with Root TWRP and Magisk !!

    To answer your question, yes you need to do this steps.
    Ask me if you have other questions 😄
     

    #20