0
OP6t & Project fi

  1. timcol
    Cupcake Nov 9, 2018

    timcol , Nov 9, 2018 :
    Currently running the OP6t on a project fi sim that was activated on another phone. I understand I'll be missing out of the network jumping that makes project fi what it is & will basically just be using TMobile. I can get over that, but my phone won't send or receive mms, I've played around a little with no luck. Anyone have any suggestions?
     

    #1
  2. sbramell
    Gingerbread Nov 9, 2018


    #2
  3. grxmetal
    Eclair Nov 9, 2018


    #3
  4. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    Correct, technically it's not. However, it will still work. the main thing is you lose some of the features, mainly being auto network switching, in which it switches between T-Mobile, AT&T, Sprint & US Cellular picking whichever has the strongest signal at the time. So, in his case it's stuck on T-Mobile which he's fine with. He just can't send & receive SMS & that may be an issue that can't be worked around. However, I'm still going too try & help the man.
     

    #4
    CCMize likes this.
  5. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    try this my friend:

    So long as you sim has been activated in one of the official 5 devices, it will be usable in any device as long as you follow the correct steps.

    Download Google’s Project Fi app

    Let it activate your phone (ignore the message saying your phone is not supported)

    Go to your phone’s settings > Networks > Access Point Names (APN)

    Create a new APN with the following set of parameters:

    Name: Project Fi - Tm

    APN: h2g2

    Proxy: Not set

    Port: Not set

    Username: none

    Password: none

    Server: *

    MMSC: http://mmsc1.g-mms.com/mms/wapenc

    MMS proxy: Not set

    MMS port: Not set

    MCC: 310

    MNC: 260

    Authentication type: Not set

    APN type: default,supl,mms,fota,cbs,ims

    APM protocol: IPv4

    APN roaming protocol: IPv4

    Bearer: Unspecified
     

    #5
  6. samprocat
    Honeycomb Nov 9, 2018


    #6
  7. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    but he's not using T-Mobile he's using Project Fi, the APN settings & requirements are different. T-Mobile is simply providing connectivity, the MMS etc is being handled by Project Fi's end not T-Mobile. If it was Project Fi wouldn't be able to switch between T-Mobile, AT&T, Sprint and/or US Cellular as they all use different APN settings.
     

    #7
  8. timcol
    Cupcake Nov 9, 2018

    timcol , Nov 9, 2018 :
    so, I made Hangouts my primary SMS app and all is working (texts, pictures and group messages). if it was unclear in the post I was getting texts but not pictures or group texts. my apologies is at project fi - Tm and volte on.

    will update after a days use
     

    #8
  9. timcol
    Cupcake Nov 9, 2018

    timcol , Nov 9, 2018 :
    using project fi but afi sim in a OP6t will only access TMobile, not all the network that uses
     

    #9
    sbramell likes this.
  10. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    I know, that's fine. I was just stating that T-Mobile's MMS APN settings won't work here, because you needed to use Project Fi's APN. You're better off being stuck on T-Mobile anyways, when I was on Project Fi I would force mine back to T-Mobile anytime it switched.

    That long list of APN settings should fix any issues you have if not already resolved.

    Let me know if you run into anymore issues. Just because it says "not compatible" doesn't mean it won't work.
     

    #10
  11. CCMize
    Cupcake Nov 9, 2018

    CCMize , Nov 9, 2018 :
    I'm trying the same setup. I can't get to APN?
     

    #11
  12. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    what do you mean? you don't know how?
     

    #12
  13. CCMize
    Cupcake Nov 9, 2018

    CCMize , Nov 9, 2018 :
    yes, I'm not finding the setting.
     

    #13
  14. Jherrild
    Cupcake Nov 9, 2018

    Jherrild , Nov 9, 2018 :
    I got my OnePlus 6t working with all MMS on my project Fi sim (activated on my old Pixel XL) by making Hangouts my default messaging app and enabling "Project Fi calls and SMS" under account settings in the Hangouts app. I can receive/respond to group messages and receive MMS.
     

    #14
  15. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    Settings
    WiFi & Internet
    SIM & Network
    Access Point Names
     

    #15
    CCMize likes this.
  16. timcol
    Cupcake Nov 9, 2018

    timcol , Nov 9, 2018 :
    wifi & network-> sim & network settings -> sim 1
     

    #16
  17. CCMize
    Cupcake Nov 9, 2018

    CCMize , Nov 9, 2018 :
    Are you using Hangouts for your project fi number and messages for a different carrier?
     

    #17
  18. sbramell
    Gingerbread Nov 9, 2018

    sbramell , Nov 9, 2018 :
    Yes, thank you. I'm using the T-Mobile version of the OnePlus 6T which only has 1 SIM. So, yes the non-T-Mobile versions will be SIM 1 (if that's your Project Fi SIM.

    Sorry about that!
     

    #18
  19. Jherrild
    Cupcake Nov 9, 2018

    Jherrild , Nov 9, 2018 :
    No, I don't have a different carrier- just my project Fi number.
     

    #19
  20. CCMize
    Cupcake Nov 9, 2018

    CCMize , Nov 9, 2018 :
    This didn't work for me. Hangouts seems to work, but if I use a GIF from g-board it doesn't show for the recipient.
     

    #20