3
OxygenOS OP6T - Random Reboots

  1. switch.xp Eclair Jan 5, 2019

    switch.xp, Jan 5, 2019 :
    I'm a conservative person. I use the same apps and layout on all my phones: OP3, OP3T and OP6T. Same settings mostly (since there are differences between 3/3t and 6t).

    I have issues with the 6T running 9.0.7 / 9.0.11 - it has started randomly rebooting. The same apps and usage pattern on all phones. So I spent a lot of cash on a brand new phone and it's unstable as *shit*. I can't connect to car bluetooth reliably, it reboots every few days when left alone. I would've returned the phone had it not been more than one month since purchase. My experience is terrible so far. Totally oposite to the 3/3T I got two years ago.

    What can I do to collect troubleshooting logs and provide feedback on the issue? Maybe it's the way OP6T (or Android 9) interacts with some common apps (nothing special - all apps I use fit on the homescreen). I don't even use ANY social apps. Just two highly common mail apps and a few trinkets I've been using for years.

     

    #1
  2. MarkoBatrac Gingerbread Jan 6, 2019


    #2
  3. switch.xp Eclair Jan 7, 2019

    switch.xp, Jan 7, 2019 :
    Not sure: screen goes black, I get the dot-square-thing animation then a password prompt. Looks soft to me...

    Just happened twice today. Honestly...
     

    #3
    G1542828796976 likes this.
  4. G12c4 Donut Jan 8, 2019

    G12c4, Jan 8, 2019 :
    Same here, getting soft reboots and sometimes locks me out while using it and asking me for a password.
    I'm on 9.0.11
     

    #4
  5. 9777224474 Cupcake Jan 9, 2019


    #5
    G1542828796976 likes this.
  6. HenrikOnePlus Eclair Jan 10, 2019

    HenrikOnePlus, Jan 10, 2019 :
    Me too - happens 2-3 times a day. Started after upgrading from 9.0.7 to 9.0.11.
    Always happens when the screen is off, sometimes right after it locks and other times when it has been idle/unused for ½ an hour.
    I have tried to clear cache, but did not help.
    Have not done a complete factory reset.
     

    #6
  7. AlanDS Donut Jan 10, 2019

    AlanDS, Jan 10, 2019 :
    No use of factory reset. I tried everything and it still happens. This soft reboot problem is present in all versions released after 9.0.7.. I tried 9.0.10, 9.0.11, OB1 & OB2 with full wipe. But no use. So far I have not found a specific action through which this issue can be reproduced.
     

    #7
    G1542828796976 and dsulk like this.
  8. HenrikOnePlus Eclair Jan 11, 2019

    HenrikOnePlus, Jan 11, 2019 :
    I've not had a reboot since yesterday morning - without doing anything.
    OnePlus has reached out to me for further investigation - really appreciate this. Thanks OnePlus!
     

    #8
  9. AlanDS Donut Jan 12, 2019

    AlanDS, Jan 12, 2019 :
    Even I didn't had a reboot since last 32 hours. Only change I made was, I disabled Private DNS as soon as I had last reboot. Will check further to see if it happens again or not. I am on Open Beta 2 by the way.
     

    #9
  10. HenrikOnePlus Eclair Jan 16, 2019


    #10
  11. AlanDS Donut Jan 16, 2019

    AlanDS, Jan 16, 2019 :
    I didn't had any soft reboot after that last incident 5 days ago. I am on Open Beta 3 now. I heard that Private DNS is broken in Beta 3.
     

    #11
  12. biterror Donut Jan 19, 2019

    biterror, Jan 19, 2019 :
    Are apps also crashing? They are on my son's 6T. Including the OnePlus apps like Settings.
     

    #12
    dsulk likes this.
  13. AlanDS Donut Jan 21, 2019


    #13
  14. HenrikOnePlus Eclair Jan 24, 2019


    #14
  15. switch.xp Eclair Jan 29, 2019

    switch.xp, Jan 29, 2019 :
    Mine did the crashing thing a LOT today. Four times. I'll try disabling the private DNS and a reboot with clear cache.
     

    #15
  16. G_Wayne_Ta_XNO Donut Jan 30, 2019


    #16
  17. biterror Donut Jan 30, 2019

    biterror, Jan 30, 2019 :
    My son's OP6T was taken to "service" (I guess they didn't really do anything) and after a factory reset, it worked ok for about 4 days. After that, the problems returned. Apps are crashing, the UI is rebooting.. his friend's OP6T is doing the same.
     

    #17
  18. G_Wayne_Ta_XNO Donut Feb 1, 2019


    #18
  19. switch.xp Eclair Feb 9, 2019

    switch.xp, Feb 9, 2019 :
    I can confirm that after removing private DNS there were no more random reboots. I *think* the function is poorly implemented.
     

    #19
    G1542828796976 likes this.
  20. peavyprowler Cupcake Feb 17, 2019

    Best Answer

    #20
    switch.xp likes this.