1
Open Mobile API

  1. ehrnleif
    Cupcake Oct 22, 2016

    ehrnleif , Oct 22, 2016 :
    can you develop oxygenOS (integrate mobile api) for using NFC-mobile payment

    ......4 months waiting

    Could you implemet the “Open Mobile API” in the OS Oxygen!

    “So you can send commands to the SIM card through this Open Mobile API now, the baseband processor must support for conformity with commands, allow the Android system, instructions to go to the SIM card, to hand over to the baseband, and the baseband processor sends then to SIM.”
     
    Last edited by a moderator: Oct 22, 2016

    #21
    lasjoh likes this.
  2. dari_one
    Cupcake Feb 12, 2017


    #22
  3. woolfie+
    Froyo Oct 23, 2017

    woolfie+ , Oct 23, 2017 :
    Auch ich möchte auf meinem OnePlus 3T die App ELBA-pay mit einer digitalen Bankomatkarte nutzen und habe versucht, mich ein wenig schlau zu machen, was dafür nötig ist. Soweit ich recherchiert habe, ist die im aktuellen OxygenOS 4.5.1 integrierte Version des SmartcardService nach wie vor L310.0.13 und nicht kompatibel. Die unter obigem Link zum XDA-Forum zu findende Version des Open Mobile API Installers (OMAI v1.0) wurde versucht auf einem ungerooteten OP3T im Recovery Mode zu installieren, was mit einer Fehlermeldung geendet hat. Die Interna des Android Betriebssystems sind nicht mein Ding, ich nehme an, es liegt an fehlenden Rechten bzw. root-Zugang.

    Da ich mich nicht in Schwierigkeiten bringen möchte (brauche ein funktionierendes OP3T für den Firmenzugriff), habe ich es sein lassen, weitere Dinge auszuprobieren, um dann durch fehlendes Wissen mein Smartphone möglicherweise in einen unbrauchbaren Zustand zu bringen. Fall mir nicht jemand einen einfachen und relativ sicheren Weg zeigen kann, ohne das Gerät zu rooten die OM-API zu installieren und die ELBA-pay App mit einer digitalen Bankomatkarte nutzen zu können, dann werde ich warten, bis diese Möglichkeit in einer neueren Version des OS integriert ist.
     
    Last edited: Oct 25, 2017

    #23
  4. puma95
    Jelly Bean Moderator Oct 23, 2017

    puma95 , Oct 23, 2017 :
    Hey, also das ist ein schwieriges Thema ehrlich gesagt, weil wir bezüglich solcher APIs gar keinen Einblick haben.
    Ich könnte dir vorschlagen mal die aktuelle Beta auszuprobieren, eventuell ist die neue Open Mobile API dort schon dabei, kanns aber leider nicht versprechen.
    Ansonsten bleibt halt nur noch auf ein offizielles Update zu warten. :/
     

    #24
  5. woolfie+
    Froyo Oct 23, 2017

    woolfie+ , Oct 23, 2017 :
    Danke, aber zum Beta-Tester will ich dann doch nicht werden. Muss ich eben noch warten und hoffen ...
     

    #25
  6. puma95
    Jelly Bean Moderator Oct 23, 2017

    puma95 , Oct 23, 2017 :
    verständlich :/
     

    #26
  7. woolfie+
    Froyo Dec 4, 2017

    woolfie+ , Dec 4, 2017 :
    So, habe nun mal in der für das OP3(T) ausgerollten OTA des aktuellsten Oxygen OS v5.0 (Android 8) nachgesehen. Leider ist auch in der neuesten OS Version die selbe alte Open Mobile API (Smartcard Service L310.0.13) enthalten. Ich weiß leider nicht, wo man sich da hin wenden müsste und ob ich da überhaupt die Berechtigung dazu hätte, wenn man die Bitte stellen möchte, eine mit der "Payment Service Austria" (https://www.psa.at/ bzw. https://www.bankomatkarte-mobil.at/) kompatible Version der OMAPI in das Betriebssystem zu integrieren. Es wäre fein, wenn auch bei den OP3(T) die mobile Bankomatkarte funktionieren würde.
     

    #27
  8. FlorianOswood
    Cupcake Jun 29, 2018


    #28
  9. woolfie+
    Froyo Jun 29, 2018


    #29
  10. FlorianOswood
    Cupcake Jun 30, 2018

    FlorianOswood , Jun 30, 2018 :
    Ja leider nicht... So ein wahnsinns gerät im Vergleich zum s8.. Aber leider fehlen solche Details halt bei op..dachte mir dass sie dass mittlerweile gecheckt hätten (hatte damals schon das Problem beim op3t)...
     

    #30
  11. woolfie+
    Froyo Aug 3, 2018

    woolfie+ , Aug 3, 2018 :
    Ich bin vor Kurzem auf ein OP 5T umgestiegen, auf dem läuft aktuell OxygenOS 5.1.4 mit Android 8.1.0. Das SmartcardService trägt die Versionsnummer 3.2.1 und was soll ich sagen: in der ELBA-pay App ließ sich die digitale Bankomatkarte problemlos aktivieren! Daumen hoch!

    Auf dem OP 3T mit der aktuellen OxygenOS Version 5.0.4 (Android 8.0.0) trägt das SmartcardService nach wie vor die Versionsnummer L310.0.13 und natürlich ist damit keine digitale Bankomatkarte unterstützt. Daumen runter!

    Beide Geräte sollen nach Verfügbarkeit die Android Version P (9) bekommen. Ich denke, das ist die letzte Möglichkeit, dass sich da beim OP 3T noch was tun könnte.

    Eine kurze Rückmeldung eines OP 6 Besitzers (z. B. @FlorianOswood) zum Thema wäre interessant!
     

    #31
  12. FlorianOswood
    Cupcake Aug 4, 2018

    FlorianOswood , Aug 4, 2018 :


    woolfie+

    Ich bin vor Kurzem auf ein OP 5T umgestiegen, auf dem läuft aktuell OxygenOS 5.1.4 mit Android 8.1.0. Das SmartcardService trägt die Versionsnummer 3.2.1 und was soll ich sagen: in der ELBA-pay App ließ sich die digitale Bankomatkarte problemlos aktivieren! Daumen hoch!

    Auf dem OP 3T mit der aktuellen OxygenOS Version 5.0.4 (Android 8.0.0) trägt das SmartcardService nach wie vor die Versionsnummer L310.0.13 und natürlich ist damit keine digitale Bankomatkarte unterstützt. Daumen runter!

    Beide Geräte sollen nach Verfügbarkeit die Android Version P (9) bekommen. Ich denke, das ist die letzte Möglichkeit, dass sich da beim OP 3T noch was tun könnte.

    Eine kurze Rückmeldung eines OP 6 Besitzers (z. B. @FlorianOswood) zum Thema wäre interessant!​


    Op6 mit oxygen 5.1.9 (Android 8.1.0) und es geht leider gar nicht.

    Was genau ist smart card Service? Lg

    Ps: Dinge wie gps(runtastic) oder Google maps(weg ansage bleibt stumm wenn parallel Spotify läuft) machen auch ständig Probleme. Hab schon jegliche Apps und fixes aus dem Forum hier probiert...
     

    #32
  13. woolfie+
    Froyo Aug 4, 2018

    woolfie+ , Aug 4, 2018 :
    Soweit ich das verstanden habe ist das SmartcardService die Open Mobile API und fungiert als Bindeglied zu den Bezahl-Apps.

    Wenn du dir die Apps in den Einstellungen ansiehst und in der Anwendungsliste rechts oben auf die drei Punkte drückst, kannst du dir auch die Systemprozesse anzeigen lassen. Die Version des SmartcardService wäre interessant.
     

    #33
  14. FlorianOswood
    Cupcake Aug 4, 2018

  15. woolfie+
    Froyo Aug 4, 2018

    woolfie+ , Aug 4, 2018 :
    Das müsste dann aber funktionieren. Hast du die ELBA-pay App installiert und dir angesehen, was die App dir mitteilt, wenn du rechts oben auf das Plus tippst und dann auf Digitale Bankomatkarte? Was ist abgehakt und wo steht was in roter Schrift dabei? Möglicherweise passt auch die SIM-Karte nicht, die muß einen geschützten Speicherbereich haben, wo die digitale Bankomatkarte abgelegt wird. Leider verhindert die App aus Sicherheitsgründen das Erstellen eines Screenshots, um das Ergebnis abbilden zu können.

    Falls du nicht Raiffeisen-Kunde bist und eine andere Bezahl-App verwendest, müsste es sich ähnlich verhalten.
     
    Last edited: Aug 4, 2018

    #35
  16. FlorianOswood
    Cupcake Aug 4, 2018

    FlorianOswood , Aug 4, 2018 :
    Mobile bankomart Karte (erste bank). Bisher (s8) hatte ich nie Probleme...
     

    #36
  17. woolfie+
    Froyo Aug 4, 2018

    woolfie+ , Aug 4, 2018 :
    Und welche Probleme hast du mit dem OP6? Wenn es beim OP5T mit selbem SmartcardService funktioniert, wundert mich das schon sehr. Gibt es Probleme bei der Installation der mobilen (digitalen) Bankomatkarte oder erst später bei der Verwendung? Verwendet habe ich sie ja noch nicht, weil erst gestern installiert.
     

    #37
  18. FlorianOswood
    Cupcake Aug 4, 2018

    FlorianOswood , Aug 4, 2018 :
    Die App crasht ständig... Kann durchaus sein dass es an der App liegt... Aber wenn ich auf die Liste gehe mit den Voraussetzungen dann stand immer was von API bla bla
     

    #38
  19. Thomas DD
    Nougat Aug 4, 2018

    Thomas DD , Aug 4, 2018 :
    also mein Op6 scheint geeignet zu sein. bei mir wird nur die SIM und der ungeeignete Tarif (wahrscheinlich weil's ein deutscher Tarif ist) angemeckert. Beim Phone ist ein Häkchen.

    Die App selbst kann ich nicht testen.
     

    #39
  20. Truster82
    Cupcake Sep 15, 2018

    Truster82 , Sep 15, 2018 :
    @woolfie+ ich hatte bis vorgestern LineageOS auf meinem Gerät weil früher die Smartcardservices fehlten. Durch dein Posting bin ich darauf aufmerksam geworden, dass es nun gehen sollte. Mir wird allerdings mit dem aktuellen OxygenOS angezeigt, dass auf die NFC SIM nicht zugegriffen werden kann. Ich habe sie in beiden Slots versucht (oneplus 5t).Betreiber ist Drei.
     

    #40