60
ROM [OPO] OxygenOS 2.1.4 - TWRP version

  1. Psk.it KitKat Jan 22, 2016

    Psk.it, Jan 22, 2016 :
    as the thread's title says here you can found a "OxygenOS 2.1.4" rom flasheable with TWRP v2.8.6.0

    n.b.: pay attention to:
    - the recovery version, the zip contains a new modem and firmware, you can run in bootloop if you have a different recovery
    - the file md5 checksum, to ensure the file is not corrupted

    the only changes I applied are:
    - added supersu
    - made the updater-script TWRP friendly

    that's all.

    edit:
    for those who prefer flashing superSU by them self, there is also the rom only "twrp ready", no superSU embedded

    when you rebot in recovery
    pay attention to perform a "poker of wipe" (system + data + cache + dalvik) before flashing

    Gapps are included - don't try to flash others over
    superSU - depends on the zip you downlaod
    I don't know about multirom support

    Screenshot_2016-01-23-00-14-42.png
    disclaimer:
    I am not responsible if your OPO were damaged from a corrupted download or other errors you can run into

    unzip the rom, copy the content as is in a local folder (suppose c:\XYZ)

    reboot the OPO in fastboot mode, plug it to the PC

    on PC open a dos prompt as admin
    cd /d "c:\XYZ"
    c:\adb\fastboot flash modem .\firmware-update\NON-HLOS.bin
    c:\adb\fastboot flash sbl1 .\firmware-update\sbl1.mbn
    c:\adb\fastboot flash dbi .\firmware-update\sdi.mbn
    c:\adb\fastboot flash aboot .\firmware-update\emmc_appsboot.mbn
    c:\adb\fastboot flash rpm .\firmware-update\rpm.mbn
    c:\adb\fastboot flash tz .\firmware-update\tz.mbn
    c:\adb\fastboot flash LOGO .\firmware-update\logo.bin
    c:\adb\fastboot flash oppostanvbk .\RADIO\static_nvbk.bin
    c:\adb\fastboot flash boot .\boot.img
    c:\adb\fastboot oem unlock
    c:\adb\fastboot reboot

    -- N.B.: ensure all paths are correct before start flashing
    -- you must have adb installed don your PC

    edit:
    when this post has been written, TWRP v3.0.0.0 were the latest version, but it was affected by a bug on writing firmware/modem files (that causes boot-loop and/or problems with modems).
    Nowadays TWRP v3.0.2.0 is safe to use since the bug has been fixed.
    To update TWRP, you can get it from the TWRP's official repository.
     
    Last edited: Aug 22, 2016

    #1
  2. rick97 Honeycomb Jan 22, 2016


    #2
  3. CesarOPO Eclair Jan 23, 2016


    #3
  4. jstepa KitKat Jan 23, 2016

    jstepa, Jan 23, 2016 :
    Firmware? Baseband? Recovery version?
    You have tried yourself?
     
    Last edited: Jan 23, 2016

    #4
  5. rphlfjrd KitKat Jan 23, 2016

  6. Kattis Lollipop Jan 23, 2016

    Kattis, Jan 23, 2016 :
    And magic mike said it could not be flashed via twrp ..very good Mr ;);)
     

    #6
    pa5t1s likes this.
  7. jstepa KitKat Jan 23, 2016

    jstepa, Jan 23, 2016 :
    Well nobody has yet tried it, so let's wait ;)
     

    #7
    pa5t1s likes this.
  8. Kattis Lollipop Jan 23, 2016

    Kattis, Jan 23, 2016 :
    Well I have no idea what I am talking about .. I am just not fond of magic mike ;)

    [​IMG]
     

    #8
    pa5t1s likes this.
  9. jstepa KitKat Jan 23, 2016

    jstepa, Jan 23, 2016 :
    Swedish women never have, or should I say women everywhere ;)
    I'm gonna regret saying this, but it's said anyway :p
     

    #9
    pa5t1s likes this.
  10. ravikiranreddi Cupcake Jan 23, 2016


    #10
  11. Kattis Lollipop Jan 23, 2016

    Kattis, Jan 23, 2016 :
    That you will o_Oo_Oo_O hej my name is kattis

    [​IMG]
     

    #11
    Sharelhun and Deactivated User like this.
  12. Psk.it KitKat Jan 23, 2016

    Psk.it, Jan 23, 2016 :
    the screenshot is taken from my OPO
    there are all the info you need :p

    @Kattis ciao Principessa!!!
     

    #12
    Kattis likes this.
  13. jstepa KitKat Jan 23, 2016

    jstepa, Jan 23, 2016 :
    Outch! I'll take it back, Swedish women, cleverest on earth :)
     

    #13
    pbergonzi likes this.
  14. Kattis Lollipop Jan 23, 2016

    Kattis, Jan 23, 2016 :
    Ciao :):):)
     

    #14
  15. jstepa KitKat Jan 23, 2016

    jstepa, Jan 23, 2016 :
    So Firmware included? Only TWRP 2.8.6.0 needed?
     

    #15
  16. Psk.it KitKat Jan 23, 2016

    Psk.it, Jan 23, 2016 :
    why I made you mad, man?
    I am here to help others... ok in my way ;)
     

    #16
  17. jstepa KitKat Jan 23, 2016

    jstepa, Jan 23, 2016 :
    That post was not for you, pay attention...
     

    #17
  18. Kattis Lollipop Jan 23, 2016

    Kattis, Jan 23, 2016 :
    If you did not know .. why is your avatar a Viking ??

    [​IMG]
     

    #18
  19. Psk.it KitKat Jan 23, 2016

    Psk.it, Jan 23, 2016 :
    yes,
    I suggest to make a "poker of wipe" (system + data + cache + dalvik) before flashing
    superSU is embedded - I included it
    GApps are already in
    only xposed if you use it, must be flashed separately
     

    #19
    Kattis likes this.
  20. massigann Donut Jan 23, 2016


    #20
    kaushal7007 likes this.