2
Opo screen going black during use

  1. devonlad
    Eclair Jun 29, 2016

    devonlad , Jun 29, 2016 :
    Hello all, I have searched this but find it all a muddle.
    When my opo say for games or browsing the screen goes black for a few seconds and non responsive. Sometimes I double tap or push the power button and it vibrates and the bottom lights come on for a millisecond. It doesn't totally switch the phone of and reboot etc. It just comes back on what ever task you were doing. So say if watching you tube black screen for few seconds normally about five to ten secs.
    Having dealt with customer support before and failing miserably am reluctant for their remote diagnosis.
    Whilst typing this the phone went blank three times.
    Thanks
     

    #1
    Yashtej and IvanMuse like this.
  2. IvanMuse
    Ice Cream Sandwich Jun 29, 2016

    IvanMuse , Jun 29, 2016 :
    Has your opo ever felt
    It could be a loose ribbon cable
     

    #2
  3. devonlad
    Eclair Jun 29, 2016

  4. devonlad
    Eclair Jun 29, 2016

    devonlad , Jun 29, 2016 :
    Hello not quite sure what a lose ribbon cable is but will check it out. Some days it doesn't go of at all.
     

    #4
    IvanMuse likes this.
  5. IvanMuse
    Ice Cream Sandwich Jun 29, 2016

    IvanMuse , Jun 29, 2016 :
    It's a cable that connects your screen to your motherboard
    It can get loose if you dropped your phone a few times
     

    #5
    Tobikage likes this.
  6. devonlad
    Eclair Jun 29, 2016

    devonlad , Jun 29, 2016 :
    Thanks I don't think its that as when it has its black screen its like it is trying to boot or crashed or something. When it happens it could be laying on a table and go off. Comes back on in a few secs.
    Thanks
     

    #6
  7. devonlad
    Eclair Jul 2, 2016


    #7
  8. Yashtej
    Cupcake Jul 12, 2016


    #8
  9. laptop
    Cupcake Jul 26, 2016


    #9
  10. bhuns08
    Cupcake Jul 27, 2016

    bhuns08 , Jul 27, 2016 :
    I am having the same problem. tired factory reset too but problem persists .it first occurred a week ago, now its been 3 or 4 times. everytime time takes for display to life is increasing, last time it took more than 12 hrs . Please help.

    I would like to check that ribbon and get back.
     

    #10
  11. bhuns08
    Cupcake Jul 27, 2016


    #11
  12. bhuns08
    Cupcake Jul 27, 2016


    #12
  13. BANE007
    Cupcake Jul 28, 2016

    BANE007 , Jul 28, 2016 :
    May be messages or even missed calls
     

    #13