1
oreo hotspot with tasker [how to]

  1. iamdarren
    Eclair Dec 2, 2017

    iamdarren , Dec 2, 2017 :
    I like to have play music and a hotspot start and stop when i am driving, this is the solution, as tasker wont allow me to use hotspot toggle with the new oreo open beta, due to restrictions and changes by google with oreo.



    simply create a tasker task, but use this plugin to manage the toggle. works well, I have 1 profile to detect my car, then start the hotspot+music, and then end music+hotspot on car disconnect.

    1. install TASKER
    2. install toggle plugin
    https://play.google.com/store/apps/...control&rdid=com.matejdro.taskertethercontrol

    3.use this profile or create one.
    here is my xml profile for tasker, if you want to get an easy import
    https://drive.google.com/open?id=1tisIvqGcwtI4zDYaZLazaVZ1swbVmiAc
     

    #1
    Steelstar likes this.
  2. Steelstar
    Eclair Dec 6, 2017

    Steelstar , Dec 6, 2017 :
    Man you saved me, I love you.
    I wrote about this in the forum a couple of times but nobody had the solution.
    Thanks!

    PS I have a Oneplus 3T
     

    #2
    iamdarren likes this.
  3. iamdarren
    Eclair Dec 6, 2017

    iamdarren , Dec 6, 2017 :
    Glad I can help. I hated how OREO just killed that function. Now you can enjoy album art while driving.
     

    #3
  4. stevenpauwels
    Cupcake Jan 2, 2018

    stevenpauwels , Jan 2, 2018 :
    The solution above doesn't work for me on OP5.

    The following worked for me:

    Prereqs: Tasker & Nougat+ Tasker Tethering Control
    1. New Profile -> State -> Net -> BT Connected
    2. New Task -> Plugin -> Toggle Tethering -> Click Config Pencil -> Enable Tether -> Open setting buttons below -> Toggle Allow modify system settings
    3. Go back, don't worry about clicking Installapp to system and go back again, and back one more time -> Click the play button at the bottom left to test to see if it works. Prosper! (Don't turn tethering off just yet)
    4. Go back to profiles, and long press on the Toggle Tethering Enable tether task and click Add Exit Task
    5. New Task -> Plugin -> Toggle Tethering -> Click Config Pencil -> Click Disable Tether radio button -> go back 2 times -> click the play button at the bottom left to test to see if tethering has been turned off.
     
    Last edited: Jan 3, 2018

    #4
  5. G_Pete_Busby_NmAz
    Cupcake Feb 8, 2018

    G_Pete_Busby_NmAz , Feb 8, 2018 :
    Legend
     

    #5
  6. lappendeluxe
    Cupcake Mar 25, 2018

    lappendeluxe , Mar 25, 2018 :
    Hi... This doesn't work for me...OP5T. I don't know what I did wrong ...here is a Screenshot for the profile...
     

    Attached Files:


    #6
  7. vishal1.kumar
    Cupcake May 28, 2018

    vishal1.kumar , May 28, 2018 :
    This worked for me and you saved lot of time for me. Another issue which i see regularly is that after enabling the hotspot most of the time (70%) the other device doest see the wifi crrated by the hotspot. Then I have to switch my airplane mode to reset the network of the phone and then after some retry and enabling the hotspot my other devices see the wifi network of my hotspot created by my oneplus 5. Have you seen such issue?

     

    #7
  8. stevenpauwels
    Cupcake Jun 4, 2018

    stevenpauwels , Jun 4, 2018 :
    No, I haven't experienced that issue. So I suppose supt must be a problem wwith your other device
     

    #8