1
OTA CM12S Phone Encryption

Thread Status:
Not open for further replies.
  1. Deactivated User
    Apr 14, 2015


    #21
  2. Deactivated User
    Apr 14, 2015


    #22
  3. sergioreja
    Honeycomb Apr 14, 2015

    sergioreja , Apr 14, 2015 :

    Sure, so far it's good. No performance nor battery issues.
     

    #23
    Deactivated User likes this.
  4. sergioreja
    Honeycomb Apr 14, 2015

    sergioreja , Apr 14, 2015 :
    Cause it's a requirement in order to add an exchange email account for work. Worked like a charm for me...
     

    #24
    Deactivated User likes this.
  5. OndeNast
    Cupcake Apr 24, 2015

    OndeNast , Apr 24, 2015 :
    For the people that did encrypt phone on CM12S can you please let me know how long it took to encrypt the phone? I was running the Encrypted CM11S and remember when I encrypted it, it took a good hour or so for the phone to be encrypted. However, on CM12S I have tried to encrypt twice, both times after fully wiping the phone, and the encryption process takes mere seconds. The green droid shows up for a few seconds and then the phone startup begins with the CYANOGEN OS logo. Upon subsequent reboots I am asked for the phone password before it boots and if I go to settings -> Security, the phone already shows as encrypted.

    So I am just wondering if they somehow managed to make encryption super fast in CM12S or if it is pretending to be encrypted but is not really encrypted.
     

    #25
  6. Dr. Indest
    Lollipop Apr 24, 2015

    Dr. Indest , Apr 24, 2015 :
    Backup and then encrypt. If anything, restore from the backup.
     

    #26
  7. lobotiger
    Donut Apr 25, 2015

    lobotiger , Apr 25, 2015 :
    Another vote for wanting to confirm that those who upgraded to CM12S and enabled encryption for the first that the phone didn't wipe all of your data. The last time I tried encryption with 11S it broke wifi and I had to wipe my phone to get it working again.

    LoboTiger
     

    #27
  8. eudesr
    Cupcake Apr 25, 2015

    eudesr , Apr 25, 2015 :
    OTA with encrypted device is fine, I just did it. the mini update of 8 Mb fix the bugs for encrypted devices , and then you can do the OTA for CM12 :)

    Be careful, there is a bug in TWRP, to decrypt /data
    ( https://github.com/TeamWin/Team-Win-Recovery-Project/issues/333 ), but this bug do not impact CM 12. You just can use supersu app to install the root binary ;) ( but of course, because TWRP is not able to decrypt /data, the twrp backup will not work, i think ;) )
     

    #28
  9. Sahtor
    Cupcake Apr 25, 2015

    Sahtor , Apr 25, 2015 :
    Workaround to encrypted update using TWRP is to abd sideload the OTA zip file. Seems to be easiest way to get a new update to unencrypted side of the phone.
     

    #29
  10. pigsaw
    Donut May 1, 2015

    pigsaw , May 1, 2015 :
    I'd like to echo the questions of @lobotiger and others here. To be really specific:
    • Did you start with an unencrypted CM11 phone?
    • Was your phone entirely unmodded? I.e. not rooted, no custom bootloader, no twrp, no nothing?
    • Did you then upgrade to the OTA (over the air) CM12?
    • Did you then encrypt your phone?
    If you answered YES to all of the above (not some of them, but all of them) then we'd love to hear from you. What was your experience? Because many of us who did that on CM11 had real problems.

    If you answered YES to all the above, please do let us know what happened.

    Many thanks
     

    #30
  11. thirstylizard
    Cupcake May 10, 2015

    thirstylizard , May 10, 2015 :
    I am using 12S and have my phone encrypted. However, when I started up my phone and entered my password, the phone said password correct by encryption is corrupted, the only option is for me to do a factory reset. This just happened to me, the second time in 4 weeks
     

    #31
  12. Uffie
    Froyo May 10, 2015

    Uffie , May 10, 2015 :
    You can't decrypt the phone. Once encrypted is stays that way. It was an issue for getting the Ota but CM and Google found a way.
     

    #32
  13. millicoelho
    Eclair May 10, 2015

    millicoelho , May 10, 2015 :
    I encrypted it after updating to 12s. I notice the following:

    * Every reboot says android is upgrading....finishing up boot...
    * data is corrupt...reset your phone message if the password is entered incorrectly once. this is pretty consistent behavior. @thirstylizard can you confirm if you get the data corruption message even when you enter the correct password the first time.
     

    #33
    redrunnerbeans likes this.
  14. lobotiger
    Donut May 12, 2015

    lobotiger , May 12, 2015 :
    Is anyone feeling comfortable to enabling encryption if they're on 12s? The past couple of posts still have me hesitant.

    LoboTiger
     

    #34
  15. millicoelho
    Eclair May 12, 2015

    millicoelho , May 12, 2015 :
    They don't lead to any issues so far other than those messages don't make sense.
     

    #35
  16. geowolf1000
    Cupcake May 13, 2015

    geowolf1000 , May 13, 2015 :
    I have encrypt
    I had this messages but i disable the option to pin from boot
    This make pin proccess to lockscreen and messages gone
     

    #36
  17. vshivaku
    Froyo May 15, 2015

    vshivaku , May 15, 2015 :
    I have manually downloaded CM12S OTA and flashed. I would like to encrypt my phone to be able to use my office mails
    However strangely I see the encrypt button is already greyed out. I even tried checking this after adding a enabling a security pin. Strangely the encrypt button seems to be disabled.
    Any clue how do I proceed further to encrypt??

    Anyone facing similar issues
     

    #37
    aminkittur likes this.
  18. lobotiger
    Donut May 16, 2015

    lobotiger , May 16, 2015 :
    Ok so I decided to go for it and it appears to be working fine. Just to answer the questions posted previously:
    • Did you start with an unencrypted CM11 phone? - Yes
    • Was your phone entirely unmodded? I.e. not rooted, no custom bootloader, no twrp, no nothing? - Yes
    • Did you then upgrade to the OTA (over the air) CM12? - Sort of. I did the easy, manual way which means downloading the file and rebooting into recovery to launch it.
    • Did you then encrypt your phone? - Yes
    So far wifi is working fine and I haven't experienced any other issues. Booting up from scratch simply asks me for my pattern and I enter it in. I don't get any error messages.

    LoboTiger
     

    #38
  19. millicoelho
    Eclair May 16, 2015

    millicoelho , May 16, 2015 :
    Interesting I thought encryption could not be enabled with out setting pin/password.
     

    #39
  20. lobotiger
    Donut May 17, 2015

    lobotiger , May 17, 2015 :
    Oh I did have a password/pattern already enabled before I did the encryption.

    LoboTiger
     

    #40