4
OxygenOS Overslept to work - alarm not going off

  1. darmach
    Eclair Dec 29, 2016

    darmach , Dec 29, 2016 :
    I overslept to work because that damn alarm did not go off! That was few days ago, and since then I set my wife's S5 to start alarm 10 minutes later. Thank god I did that, today this happened again. Every time I get to bed early - coincidence? I don't think so. It's the damn doze. When I go sleep early because I have to get up at 5:30, it seem that few hours is enough to kick in and sleep the alarm to death.

    And yes, I did switch "battery optimization" to "not optimized" for the clock app.

    OnePlus do something with that! We can't have unreliable phones, especially unreliable alarm clocks!
     

    #1
  2. gdigenis2
    Froyo Dec 29, 2016

    gdigenis2 , Dec 29, 2016 :
    I set alarms for each day of the week when I received my phone almost a month ago and it has never failed to go off
     

    #2
    artexjay likes this.
  3. darmach
    Eclair Dec 30, 2016

    darmach , Dec 30, 2016 :
    Keep fingers crossed. I received my phone few days into December, and that's the second time... You know the point, people can't 'wonder' if their alarm will go off in the morning or not. Alarm have to be rock solid sure thing.
     

    #3
  4. darmach
    Eclair Dec 30, 2016

    darmach , Dec 30, 2016 :
    Just wondering. Did you receive OTA update few days ago? What's your fw version?
     

    #4
  5. gdigenis2
    Froyo Dec 30, 2016

    gdigenis2 , Dec 30, 2016 :
    I was on the most recent stock op3t firmware and now I am on the leaked 7.0 beta and it still runs perfect. using stock clock
     

    #5
  6. Batman01388
    Cupcake Dec 30, 2016


    #6
  7. darmach
    Eclair Dec 30, 2016


    #7
  8. roscey
    Cupcake Dec 31, 2016


    #8
  9. ankitgarg10001
    Eclair Dec 31, 2016

    ankitgarg10001 , Dec 31, 2016 :
    Happened with me as well quite a few times. replaced stock clock app with Google's clock app, never missed any alarm ever again after that
     

    #9
  10. jennyhoo
    Cupcake Jan 15, 2019

    jennyhoo , Jan 15, 2019 :
    This happens to me if my phone is not plugged in to power. Oneplus6T using Alarm Clock Plus.
     

    #10
    S1575186890711 likes this.
  11. S1575186890711
    Cupcake Feb 13, 2020 at 4:26 PM

    S1575186890711 , via OnePlus 7 Pro , Feb 13, 2020 at 4:26 PM :
    I have also experienced this while using Google's alarm clock app (not the stock one plus alarm). This tells me it might be a settings/operating system issue. my alarm volume was up all the way. OxygenOS was updated to it's most recent version. The one thing I noticed was that the battery optimization was turned on for the alarm app, so I turned it off by going through Settings>Apps & Notifications>Special App Access> Battery Optimization then select your alarm application, and finally selecting "don't optimize"

    Hopefully, that solves the problem. I'll post back here if it does.
     

    #11