239
Oxygen 1.0.2 Release with Stagefright security patches

  1. Savitra
    Eclair Sep 19, 2015

    Savitra , Sep 19, 2015 :
    Friends,
    While I am trying to flash this file through TWRP, I am getting error with MD5 file. Did someone experience such issue? How to overcome that?
     

  2. eobrien84
    Froyo Sep 24, 2015

    eobrien84 , Sep 24, 2015 :
    No, don't unzip it. Just flash it in recovery.
     

  3. pbergonzi
    KitKat Sep 24, 2015

    pbergonzi , Sep 24, 2015 :
    You are wasting time flashing 1.0.2 when there is a 1.0.3.
     

  4. pbergonzi
    KitKat Sep 24, 2015

    pbergonzi , Sep 24, 2015 :
    Download zip file through a different browser and try it.
    If you get the same error, disable TWRP ability to verify file.
    And install 1.0.3--not 1.0.2. No reason to do it twice.
     

  5. ajmorley28
    Gingerbread Sep 24, 2015

    ajmorley28 , Sep 24, 2015 :
    i believe it said in the instructions to flash each one not just jump from 1.0.0 to 1.0.3 is that wrong? in any case i've already done it and its working good had an issue with my supersu but just flashed it again and i have root access again only bummer at this point is waiting for an update of the os and the fact that i can't use android pay and when the original google wallet worked great with my device being rooted. so yea
     

  6. ajmorley28
    Gingerbread Sep 24, 2015

    ajmorley28 , Sep 24, 2015 :
    i believe it said not to flash the md5 file but just the zip file.. thats what i did and had no problems
     

  7. pbergonzi
    KitKat Sep 24, 2015

    pbergonzi , Sep 24, 2015 :
    Glad you got it working. I'm pretty sure anything about having to flash them in order was just chatter.
    If it doesn't work for someone flashing 1.0.3 directly, one can try it the other way. The official instructions don't say it is necessary, although the official instructions did make a different mistake--@Helen said to follow the instructions for flashing 1.0.0, but there is a step in those instructions that say to download the zip file, then to extract the flash zip file from the downloaded zip file--Helen referred to those same instructions with 1.0.2 and 1.0.3 without acknowledging that those downloadable files ARE the flash zip files and cannot be extracted from themselves. She still has not corrected the statement to reflect this, so for certain, SOME people are extracting the files from the downloaded zip, copying them to the phone, and attempting to flash them--which of course, won't work.
     

  8. pbergonzi
    KitKat Sep 24, 2015


  9. Savitra
    Eclair Sep 26, 2015

    Savitra , Sep 26, 2015 :
    I tried from different laptops. Also tried directly from mobile.
    I am not unzipping any file, just flashing like I did it for 1.0.0. Tried disabling verification in TWRP as well. Still same error.
     

  10. pbergonzi
    KitKat Sep 26, 2015

    pbergonzi , Sep 26, 2015 :
    Try a different version of TWRP?
    You're not trying to flash an MD5 are you?
     

  11. Savitra
    Eclair Sep 26, 2015

    Savitra , Sep 26, 2015 :
    No. In fact TWRP allows only zip files for flashing. I have the version which was referred in oxygen os installation. Will try installing other one. But will that clear all my data?
     

  12. pbergonzi
    KitKat Sep 26, 2015

    pbergonzi , Sep 26, 2015 :
    As far as I know, flashing a recovery does not clear personal files. Of course before anything you need to do some sort of data or nandroid backup, or both. See if you can flash back to your OxygenOS 1, or your original OS--at least you can get your system stable again. Then you'll be in a better position to experiment.
     

  13. ajmorley28
    Gingerbread Sep 30, 2015

    ajmorley28 , Sep 30, 2015 :
    yea they should probably have someone there to help her with the instructions about how to do it and all that but i appreciate the help most people on the forum are usually pretty helpful but you do get those people that are the "know it alls" and get mad when people aren't as smart as them... thanks again
     

    pbergonzi likes this.
  14. amehta11
    Cupcake Oct 1, 2015

    amehta11 , Oct 1, 2015 :
    Need Help!!!
    Got my OPO couple weeks and had been using CM12s and switched to Oxygenos yesterday. The install worked and I've been using since last night.

    Couple issues though, when I first installed the OS, apparently the md5 file was missing (I think its relevant). The other issue is I can't seem to flash the stagefright update and I keep getting error message about mismatch md5 files.

    I tried reflashing oxygenos and tried flashing the patch right after and that didn't work either. Not quite sure what to do next.

    I'm a noob to android not just OPO so any help on the matter will be appreciated.

    Thanks.

    Edit: Sorted it out. Evidently the key was not adding the md5 file with the zip file to the phone.
     
    Last edited: Oct 1, 2015

  15. hennes
    YaImCo Developer Oct 1, 2015

    Last edited: Oct 1, 2015

  16. agarwal.amal
    Froyo Oct 30, 2015


  17. kushalsalvi
    Cupcake Oct 30, 2015

    kushalsalvi , Oct 30, 2015 :
    can i just flash oxygen os 1.0.0 and then get stagefright update over OTA?
    Is the stagefright fix available via OTA yet?
    currently i am on CM 12s
     

  18. EireGobra
    Cupcake Nov 4, 2015

    EireGobra , Nov 4, 2015 :


    Hi Guys

    Wondering if anyone can help me here , i am trying to flash the above but i keep getting a MD5 checksum error for above , can anyone help me here ?
    Not sure what is causing this error , i upload the flash zip and the md5 to the phone and select the flash zip via twrp and then i just get the error and it fails
    Regards
     

  19. laurboss
    Honeycomb Nov 4, 2015


  20. jstepa
    KitKat Nov 4, 2015

    jstepa , Nov 4, 2015 :
    Uncheck the "Zip file signature verification" from TWRP before flashing