94
OxygenOS 10.0.6 for the OnePlus 7T

  1. gregdw
    Cupcake Nov 16, 2019


  2. Swejuggalo , via OnePlus 7 Pro Mirror Gray , Nov 16, 2019 :
    Isolated incidents happen for all brands. Tried resetting APN? Used reset on mobile data/wifi/bluetooth in Reset options?
    Reported it via the feedback tool? What carrier?
     

  3. drgreen
    Cupcake Nov 16, 2019

    drgreen , via OnePlus 7T , Nov 16, 2019 :
    Next Ill try factory reset. This from logcat.

    My carrier dna finland.

    FATAL EXCEPTION: main
    Process: com.android.phone, PID: 7082
    java.lang.RuntimeException: Unable to instantiate application com.android.phone.PhoneApp: java.lang.ClassNotFoundException: Didn't find class "com.android.phone.PhoneApp" on path: DexPathList[[zip file "/system/priv-app/TeleService/TeleService.apk"],nativeLibraryDirectories=[/system/priv-app/TeleService/lib/arm64, /system/priv-app/TeleService/TeleService.apk!/lib/arm64-v8a, /system/lib64, /product/lib64, /system/lib64, /product/lib64]]
    at android.app.LoadedApk.makeApplication(LoadedApk.java:1226)
    at android.app.ActivityThread.handleBindApplication(ActivityThread.java:6594)
    at android.app.ActivityThread.access$1600(ActivityThread.java:231)
    at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1952)
    at android.os.Handler.dispatchMessage(Handler.java:107)
    at android.os.Looper.loop(Looper.java:214)
    at android.app.ActivityThread.main(ActivityThread.java:7682)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:516)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:950)
    Caused by: java.lang.ClassNotFoundException: Didn't find class "com.android.phone.PhoneApp" on path: DexPathList[[zip file "/system/priv-app/TeleService/TeleService.apk"],nativeLibraryDirectories=[/system/priv-app/TeleService/lib/arm64, /system/priv-app/TeleService/TeleService.apk!/lib/arm64-v8a, /system/lib64, /product/lib64, /system/lib64, /product/lib64]]
    at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:196)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:379)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:312)
    at android.app.AppComponentFactory.instantiateApplication(AppComponentFactory.java:76)
    at android.app.Instrumentation.newApplication(Instrumentation.java:1153)
    at android.app.LoadedApk.makeApplication(LoadedApk.java:1218)
    ... 9 more
    Suppressed: java.io.IOException: Failed to open dex files from /system/priv-app/TeleService/TeleService.apk because: Failure to verify dex file '/system/priv-app/TeleService/TeleService.apk': Bad checksum (c0c2207c, expected 277e206c)
    at dalvik.system.DexFile.openDexFileNative(Native Method)
    at dalvik.system.DexFile.openDexFile(DexFile.java:365)
    at dalvik.system.DexFile.<init>(DexFile.java:107)
    at dalvik.system.DexFile.<init>(DexFile.java:80)
    at dalvik.system.DexPathList.loadDexFile(DexPathList.java:444)
    at dalvik.system.DexPathList.makeDexElements(DexPathList.java:403)
    at dalvik.system.DexPathList.<init>(DexPathList.java:164)
    at dalvik.system.BaseDexClassLoader.<init>(BaseDexClassLoader.java:126)
    at dalvik.system.BaseDexClassLoader.<init>(BaseDexClassLoader.java:101)
    at dalvik.system.PathClassLoader.<init>(PathClassLoader.java:74)
    at com.android.internal.os.ClassLoaderFactory.createClassLoader(ClassLoaderFactory.java:87)
    at com.android.internal.os.ClassLoaderFactory.createClassLoader(ClassLoaderFactory.java:116)
    at android.app.ApplicationLoaders.getClassLoader(ApplicationLoaders.java:114)
    at android.app.ApplicationLoaders.getClassLoaderWithSharedLibraries(ApplicationLoaders.java:60)
    at android.app.LoadedApk.createOrUpdateClassLoaderLocked(LoadedApk.java:851)
    at android.app.LoadedApk.getClassLoader(LoadedApk.java:950)
    at android.app.LoadedApk.getResources(LoadedApk.java:1188)
    at android.app.ContextImpl.createAppContext(ContextImpl.java:2499)
    at android.app.ContextImpl.createAppContext(ContextImpl.java:2491)
    at android.app.ActivityThread.handleBindApplication(ActivityThread.java:6497)
    ... 8 more
     

  4. drgreen
    Cupcake Nov 16, 2019


  5. Swejuggalo , via OnePlus 7 Pro Mirror Gray , Nov 16, 2019 :
    Rooted?
    Looks like some kind of cache issue (from what I can see with a quick look on my phone. The app does not show the full log). It should rebuild caches after upgrades though. It checks for matches and rebuilds on demand if I understand it correctly. Perhaps most of the errors are espected and just a result of the upgrade and triggering of cache rebuild. Maybe wipe cache of the phone app.
    Don't think that has much to do with mobile data being lost though. That should be related to APN.
     

  6. drgreen
    Cupcake Nov 16, 2019

    drgreen , via OnePlus 7T , Nov 16, 2019 :
    Yes rooted.

    What I have tried so far:

    - Clear all data from phone app
    - Clear dalvik-cache manually

    If I could get that TeleService folder files from 10.0.4 or 10.0.5 (maybe?) I could give it a shot and make a magisk module out of it to systemlessly replace those files from older fw.
     

  7. Swejuggalo , via OnePlus 7 Pro Mirror Gray , Nov 16, 2019 :
    Have you asked at XDA too? Maybe more rooted users available there.
    If users without root got this issue the forum would probably be filled with complaints by now.
    Strange things happen on rooted devices sometimes. Even seen cases where a certain Magisk version somehow broke Warp charging.
     

  8. drgreen
    Cupcake Nov 16, 2019

    drgreen , via OnePlus 7T , Nov 16, 2019 :
    Yup, asked xda as well. Maybe its some kind of cache issue. Have to try factory reset. Its annoying even with backup.
     

  9. Z1560796484808
    Cupcake Nov 16, 2019


  10. Vaibhav55000
    Cupcake Nov 16, 2019

    Vaibhav55000 , via OnePlus 7T , Nov 16, 2019 :
    means company is not confident that update is working or not
     

  11. X1570635376963
    Cupcake Nov 16, 2019


  12. G_ben_owen_YwOR
    Eclair Nov 16, 2019

    G_ben_owen_YwOR , via OnePlus 7T , Nov 16, 2019 :
    I received the update yesterday. it seems I got the global version on my EU OnePlus 7T and a lot of people got the 10.0.6 update at the same time.

    thanks OnePlus.
     

  13. G_ben_owen_YwOR
    Eclair Nov 16, 2019

    G_ben_owen_YwOR , via OnePlus 7T , Nov 16, 2019 :
    You should appreciate the fast updates OnePlus is pushing out to fix bugs unlike the OEMs that are still on Android 9 Pie. And Samsung has a bug in the in display fingerprint sensor so don't tell me that other OEMs don't have a bugs.
     

  14. Michele Cortese
    Cupcake Nov 16, 2019


    Francesco£ likes this.
  15. ilham_qrsh
    Froyo Nov 16, 2019

    ilham_qrsh , via OnePlus 7T , Nov 16, 2019 :
    Thank you for the update... waiting to get it on my device... noticed couple of days back issue with Bluetooth connection in car. You guys are awesome. i hope this update will resolve the concern.. Thank you OnePlus.
     


  16. Michele Cortese
    Cupcake Nov 16, 2019


  17. Michele Cortese
    Cupcake Nov 16, 2019

    Michele Cortese , via OnePlus 7T , Nov 16, 2019 :
    Allora, avevo il 10.0.1 prima di aggiornare, e anche dopo aver aggiornato continuo ad avere l'aggiornamento di google play al 1 settembre 2019. Hai provato a verificare la presenza di aggiornamenti cliccandoci su? È strana questa cosa che ti è capitata...
     

  18. tm_op , via OnePlus 7T Frosted Silver , Nov 16, 2019 :
    I haven't found a way to delete my original reply so instead I'm editing it to say that I've now read the whole thread and realise I had misunderstood your original post. My answer is completely irrelevant - sorry.



    drgreen

    I lost my mobile data after upgrade. How to roll back? I think this is my last oneplus device.. no phone loses mobile data on upgrade!​





    I presume you mean you lost data as measured by your phone, not your carrier. The readings must have been reset during the upgrade somehow (my upgrade hasn't reset my readings).

    Why don't you get in touch with your carrier to confirm that all is okay with your MBytes and, equally importantly, establish when the monthly data is reset (so that the usage as measured by your phone tallies with the usage as measured by the carrier)
     
    Last edited: Nov 16, 2019

  19. googlemedion
    Cupcake Nov 16, 2019