1372
OxygenOS 10.0 for the OnePlus 7 Pro and OnePlus 7

  1. docnok63
    Jelly Bean Oct 7, 2019


  2. mike_krb
    Gingerbread Oct 7, 2019

    mike_krb , Oct 7, 2019 :
    Since it looks like they skipped the Sept. security update I really hope 10 stable release is coming very soon...
     

    Mrr_Chan likes this.
  3. Swejuggalo
    OnePlus 9 Series Expert Community Expert Oct 7, 2019

    Swejuggalo , Oct 7, 2019 :
    It here free for everyone to grab manually from a moderators links in post 2 on first page. Or with Oxygen Updater if you prefer that. Automatic OTA is slow this time but everyone has been able to download themselfs since first day.
     

  4. SabKaDADDY
    Eclair Oct 7, 2019


  5. T_1500
    Donut Oct 7, 2019

    T_1500 , via OnePlus 7 , Oct 7, 2019 :
    is this the stable one?
     

  6. xythiii
    Ice Cream Sandwich Oct 7, 2019

    xythiii , Oct 7, 2019 :
    Didn't receive update yet, global version aa ????? What's going on?????
     

  7. docnok63
    Jelly Bean Oct 7, 2019

    docnok63 , Oct 7, 2019 :
    Look, it's not my job here to convince you one way or another to use a file or not. The choice is yours. You have received many replies over the last hour and a couple of methods to get back to Pie that will work. Either try them or don't.

    It is the build released with this thread on Sept 19th. It's buggy and very questionably stable.

    Read post #2 of this thread
     

    Georgeoneplus7pro likes this.
  8. kshitishkum
    Cupcake Oct 7, 2019

    kshitishkum , Oct 7, 2019 :
    its been 15 days still u r not giving android 10 update but u have given to 7t model shame on u oneplus even apple gives updates to older and new iphone in one time , Chinese company always be shit
     

  9. SabKaDADDY
    Eclair Oct 7, 2019

    SabKaDADDY , Oct 7, 2019 :
    really sorry bro i dont want 2 irritate u but i just wanted 2 know tht if someone has tried it yet or not....i have no problem with wipe off....plz help
     

  10. A1568869324488
    Cupcake Oct 7, 2019


  11. Swejuggalo
    OnePlus 9 Series Expert Community Expert Oct 7, 2019

    Swejuggalo , Oct 7, 2019 :
    The point is that stable to stable should not be needed. That is why it's only linked in beta threads. And it was only needed when you wanted to go back to stable when stable 10 did not exist. Now it can still be used to get back to stable from beta (but not really needed since stable 10 over beta works too). I have guided people back to stable 9 from stable 10 and it worked (only problem some had was that it refused to use the rollback at first but did second try). Only thing some might want to know is that it reverts to AA build. So if you need BA they need to manually update to BA build.
     

  12. akks
    KitKat Oct 7, 2019

    akks , Oct 7, 2019 :
    Switching to apple?
     

    JayantMorghade likes this.
  13. kshitishkum
    Cupcake Oct 7, 2019

    kshitishkum , Oct 7, 2019 :
    actually before i buyed 7 pro i was using 8plus still working been 3 yrs with that phone
     

  14. SabKaDADDY
    Eclair Oct 7, 2019

    SabKaDADDY , Oct 7, 2019 :
    Is AA BUILD for india..??
     

  15. Swejuggalo
    OnePlus 9 Series Expert Community Expert Oct 7, 2019


  16. docnok63
    Jelly Bean Oct 7, 2019

    docnok63 , Oct 7, 2019 :
    Look at post 12654. It works. It may just take trying to install it twice.

    I have personally used fastboot to flash 9.5.11 directly twice since the revert files bring you back to 9.5.3. This saves me an OTA step. I can confirm 100% this works. Here is the link again:
    https://forum.xda-developers.com/oneplus-7-pro/how-to/rom-stock-fastboot-roms-oneplus-7-pro-t3931424

    Go into About phone\build number. You will either see AA or BA. Use that.
     

    subham_sekhar3112 likes this.
  17. R1567580193602
    Cupcake Oct 7, 2019


  18. SabKaDADDY
    Eclair Oct 7, 2019


    docnok63 likes this.
  19. Stako187
    Gingerbread Oct 7, 2019

    Stako187 , via OnePlus 7 Pro , Oct 7, 2019 :
    Anyone with some more knowledge about using MSM tool... pls help..I have downloaded all latest drivers..(im on Windows 7)wen i press both volume buttons for 5 sec and plug the cable the phone recognize device as it should like Qualcomm..etc etc it stays like that for 2-5 sec than starts charging the phone and starts recognize it like storage device..So i cant flash the Rom (to downgrade to the original build)..Any ideas..?
     

  20. G_Pavlos_Piaditis_znro
    Donut Oct 7, 2019

    Last edited: Oct 7, 2019