2
[Submitted] OxygenOS 10 loosing connectivity on both SIM's and WiFi at the same time

  1. B1557913346552
    Cupcake Oct 25, 2019

    B1557913346552 , Oct 25, 2019 :
    I will loose all cell, data and wifi connectivity. I have 2 SIM's installed. During the issue all 3 SIM and WiFi notification icons show a lack of connectivity. The issue lasts for approximately 2-3 seconds. During this time I will be unable to make calls, data will drop, WiFi connection will drop. Applications will loose their internet connection. I was on a Skype call yesterday while connected to WiFi. During a 37 min call the connectivity dropped about 15-20 times disconnecting me from the Skype call and forcing Skype to reconnect seconds later.

    it appears to be made worse by poor network coverage areas or when moving from inside a building to outside and visa versa.

    I upgraded to OxygenOS ten on Tuesday and I have noticed the issues since then. However, it was not until the Skype call yesterday that I realized how bad the issue is.

    The connectivity issue happened 3+ times in the attached log file.
     

    #1
  2. whiteplasticbag
    Donut Oct 27, 2019


    #2
    B1557913346552 likes this.
  3. B1557913346552
    Cupcake Nov 7, 2019

    B1557913346552 , via OnePlus 7 Pro , Nov 7, 2019 :
    since originally posting I wiped my phone (full reset) and cleared the cache. After this I reinstalled the 10 upgrade again using the local upgrade method. I set the phone up again. It worked better for about 5 days. I would occasionally loose WiFi but not cell. I could tolerate this.

    Today I joined a Skype meeting and the problems came back :-( I had a 15 minute voice call a while ago and I dropped the call 3 times.

    I had been using Skype in the 5 days since wiping the phone without issue.

    This is really getting me down. This is my work phone and I use it for both calls and meetings. I would happily suffer other issues and grant you time to resolve bugs, things like gaming is not a big deal (Call of duty mobile keeps crashing out on me, annoying but a it's a pastime not my job).

    When a phone is unusable as a phone and when a connected device fails to stay connected, then this becomes a useless piece of plastic and glass..

    Is the beta channel something I can join? Is there a beta fix for this issue? If not, can you give me an android 9 image to downgrade to?

    After this my only other option is to find a new phone. I do not want one but I need a functional device for work.
     

    #3
  4. B1557913346552
    Cupcake Nov 8, 2019

    B1557913346552 , via OnePlus 7 Pro , Nov 8, 2019 :
    i re-inserted my second SIM card Tuesday of this week. The radio issues reappeared on Thursday. I cannot see a direct correlation but it is not impossible for the issue to be linked to the second sim.

    Anyone out there with this issue and a dual SIM set up?
    Anyone out there with this issue and a single SIM set up?
     

    #4
  5. B1557913346552
    Cupcake Nov 12, 2019

    B1557913346552 , Nov 12, 2019 :
    Is this issue something that is addressed in the open beta 5 for the OnePlus 7 pro? How can I download this beta version?
     

    #5
  6. whiteplasticbag
    Donut Dec 7, 2019 at 3:12 PM

    whiteplasticbag , via OnePlus 7 Pro , Dec 7, 2019 at 3:12 PM :
    An update on this: I decided to analyze the logs myself and found that errors occur in the logs for the cellular connection before it occurs for the WiFi. This means that the cellular connection crashes first, which then crashes the other network services. I verified that the cellular connection is the problem by removing the SIM and trying to reproduce the issue with just the WiFi connected. once the SIM is removed, the WiFi works fine. I then decided to put the SIM back, but to use the SIM 2 slot instead of the SIM 1 slot. this fixed the problem and it has been 48 hours since the last disconnect. I think there is some corruption in the config of the SIM1 slot that wasn't fixed by clearing the cache.
     

    #6
  7. B1557913346552
    Cupcake Dec 9, 2019 at 9:47 AM

    B1557913346552 , via OnePlus 7 Pro , Dec 9, 2019 at 9:47 AM :
    wow that is brilliant news! I have multiple feedback posts open with OnePlus support and they have only started engaging me in the most recent one. They have not come back to me with any update or progress yet.

    I want a replacement device or a full refund. There is some fault with our phones that does not exist for most other OnePlus 7 pro users and it is not our fault. This issue has made my phone unusable when I really need to use it. I've had to get a new work phone as this phone would not work as a phone.
     

    #7