58
OxygenOS 3.0.1 Beta Buglist

  1. locxFIN
    KitKat May 23, 2016

    locxFIN , May 23, 2016 :
    As the full OxygenOS 3.0.2 has been released this thread is no longer updated! I thank all of you for your contributions and I hope it continues in 3.0.2 buglist thread!

    Here's the thread to gather all the bugs in one convenient location. I'll be updating this thread with each new bug found as often as possible.

    Please check the "Known bugs" section to see if your bug has already been reported, and the "Possible bugs" section, try them on your device so we can determine whether those are bugs in the build itself or just something in a few devices. Also, if possible, please add screenshots / videos / logs about the bugs to make tracking them down easier!

    Remember, this thread is not for whining about how OTA is not here yet or any other matter. It's simply for constructive criticism and as a reference for users.


    Bugs fixed (from previous Beta):

    • Headphone audio quality improved (Link)
    • Min volume lowered (Link)
    • APN screen fixed
    • Display can be turned off by double tapping the notification area after waking it with double tap
    • Pressing calendar in the drop down menu opens the calendar app and pressing clock opens date and time settings (Not sure if that's a concsious design choice or a bug)
    • App permissions settings crash fixed (Link)
    • Trusted faces are working
    • "oxygen" removed from battery stats (although it's probably added to Android System)

    Known bugs:
    • Instant PIN unlock unavailable this is new AOSP security standard (Statement by Helen)
    • Still no option to set different ringtones to different SIMs (Link)
    • Booting into recovery from advanced reboot menu still shows "Factory resetting"
    • LR InControl Remote app doesn't work. This is a bug on LR side, not OP (Link)
    • Phone connects in charging mode to PC even if it's set to something else in Developer options.
    • Download speed missing in the download progress notification (Most probably stock Adnroid change)
    • Side menu's background in File Explorer is pitch black (Uncertain if it's intended or not) (Link)
    • Photos and videos shot on stock camera app are drastically compressed (Uncertain if it's intended or not not)
    • Pressing clear all processes resets Greenify and other screen locking apps in Accessibility settings (Link)
    • Option to set lock screen wallpaper in settings is missing

    Possible bugs:

    • Search bar in the app drawer sometimes has borders and sometimes not (Link)
    • LAF doesn't work in Snapchat
    • Camera keeps refocusing
    • Transition to recent apps animation is bugged, shadow at the bottom suddenly just pops
    • Exchange account option missing in Gmail app on some users (Fix)
    • Screen doesn't rotate while in Navigation mode in Maps
    • USB camera doesn't work
    • Users on MVNO carriers are required to activate roaming
    • Speaker output is disrupted when Bluetooth connection is established but not used
    • Android Wear doesn't synch with or stay connected to smartwatch
    • R for roaming is missing in the notification bar
    • Random crashes while Wynk is running
    • Screen shuts down when watching and Instagram video longer than the screen timeout
    • [Some users] Interactive USSD codes not working as expected (Link)
    • [Some users] Slow WiFi upload and download speeds
    • [Some users] Laser Autofocus doesn't work in video mode
    • [Some users] Screenshot makes a sound even while volume is turned off or silent mode is toggled
    • [Some users] Some gestures don't work or they stop working after a while
    • [Some users] PIN/password is sometimes required after fingerprint unlock, even when the phone wasn't rebooted
    • [Some users] Random (soft) reboots
    • [Some users] Very long charging time (8+ hours)
    • [Some users] Overheating while charging
    • [Some users] Fast(er) battery drain
    • [Some users] GPS signal periodically lost when using Strava or Runtastic (at least)
    • [Some users] Clicking on Sounds and vibration in Dialer settings takes you back to the dialer (Fix)
    • [Some users] Can't open Access permissions in App settings (Fix)

    Changelog etc.:

    You can find the official info in the official announcement thread:
    https://forums.oneplus.net/threads/oxygenos-community-build-update.447426/



    Installation instructions:
    There's a great thread by @Naman Bhalla that should answer all your questions:
    https://forums.oneplus.net/threads/installation-instructions-faqs-oxygenos-3-0-0.439108/


    Mirrors in case the official is too slow:
    1) https://www.androidfilehost.com/?fid=24533103863143103
    2) https://mega.nz/#!ZIM1VD7R!2pbjyTDTQfueVytNACQseafBIKsvHEzaII6UZBafTo0
     
    Last edited: Jun 5, 2016

    #1
  2. sahil_starrh
    Honeycomb May 23, 2016

    sahil_starrh , May 23, 2016 :
    Updating to the new beta as we speak! Will see if there are any bugs to report. I've dirty flashed it.. Is that ok?
     

    #2
    locxFIN likes this.
  3. marinobiagio
    KitKat May 23, 2016


    #3
    locxFIN likes this.
  4. locxFIN
    KitKat May 23, 2016

    locxFIN , May 23, 2016 :
    That's what I did, only wiped cache before and after.
     

    #4
  5. katheria09
    Ice Cream Sandwich May 23, 2016


    #5
    locxFIN likes this.
  6. KpVarun_
    Honeycomb May 23, 2016


    #6
  7. sahil_starrh
    Honeycomb May 23, 2016


    #7
  8. merewoodbebox
    Jelly Bean May 23, 2016

    merewoodbebox , May 23, 2016 :
    maxxaudio or?
     

    #8
  9. xandexer99
    Gingerbread May 23, 2016

    xandexer99 , May 23, 2016 :
    Pls tell me there's maxxaudio
     

    #9
  10. Vasilachi Eugeniu
    Honeycomb May 23, 2016

    Vasilachi Eugeniu , May 23, 2016 :
    you mean the sound quality in headphones now is well?
     

    #10
  11. sahil_starrh
    Honeycomb May 23, 2016

    sahil_starrh , May 23, 2016 :
    Yes, for me the quality sounds brilliant now!
     

    #11
    SergiuszJasper, otto2 and locxFIN like this.
  12. locxFIN
    KitKat May 23, 2016

    locxFIN , May 23, 2016 :
    No Maxxaudio. Min volume seems to have gone lower (I thought it was too high before) but sound quality is still quite bad. Not sure if there's slight improvement but not anywhere near OOS 2.x.x
     

    #12
    gamsurslicki and Gaurav Rohilla like this.
  13. Jitesh Saitawadekar
    KitKat May 23, 2016

    Jitesh Saitawadekar , May 23, 2016 :
    Thanks for this thread I was gonna make one for keeping a track on buglist and how's the update working you made it easy for me. I'll keep a track on it. ;)
     

    #13
    Mani Maaran and locxFIN like this.
  14. SaltLife
    Ice Cream Sandwich May 23, 2016

    SaltLife , May 23, 2016 :
    I may have found a small bug: instant unlock is no longer an option after updating. You have to press the check mark if you enter in your PIN.
     

    #14
    schizzooo, VigneshKishan and locxFIN like this.
  15. locxFIN
    KitKat May 23, 2016

    locxFIN , May 23, 2016 :
    Sure, you can help me here too :p
     

    #15
    Jitesh Saitawadekar likes this.
  16. RichtigerLurch
    Gingerbread May 23, 2016


    #16
    jtalexandre and Mani Maaran like this.
  17. peppeuz
    Froyo May 23, 2016

    peppeuz , May 23, 2016 :
    I've just dirty flashed with modified TWRP, only wiped cache before and after. Seems pretty smooth right now. I can't tel very much right now, but they surely solved the APN list bug with Dark theme
     

    #17
  18. Naman Bhalla
    Recognized developer Recognized Developer May 23, 2016

    Naman Bhalla , May 23, 2016 :
    Build is only some hours old.But doze has been tweaked heavily and one can expect better standby by around 50% !!!
     

    #18
  19. sahil_starrh
    Honeycomb May 23, 2016

    sahil_starrh , May 23, 2016 :
    I've noticed that Oxygen isn't appearing in my battery usage anymore? Can anyone else confirm this?
     

    #19
    schizzooo and ButterFlYnez like this.
  20. Vasilachi Eugeniu
    Honeycomb May 23, 2016


    #20