453
OxygenOS 3.0 Community Build Now Available for OnePlus 2

Thread Status:
Not open for further replies.
  1. Micky_adi
    Eclair Apr 4, 2016

    Attached Files:


    anz563 likes this.
  2. jc.durand
    Gingerbread Apr 4, 2016

    jc.durand , Apr 4, 2016 :
    OTA of what ? oxygen 3.0 or an update after that ?
     

  3. SoniaB
    Community Hero 2020 Apr 4, 2016

    SoniaB , Apr 4, 2016 :
    Please do not post misleading information. The OTA has not yet been released.
    There is no official announcement from OnePlus.
     

  4. vamshi prasad
    Gingerbread Apr 4, 2016

    vamshi prasad , Apr 4, 2016 :
    That guy freaked me out
     

  5. bassgenerator
    Gingerbread Apr 4, 2016


  6. vamshi prasad
    Gingerbread Apr 4, 2016

    vamshi prasad , Apr 4, 2016 :
    What do you mean by what has changed?
     

  7. bassgenerator
    Gingerbread Apr 4, 2016

    bassgenerator , Apr 4, 2016 :
    you wrote that Oxygen has changed ...
     

    vamshi prasad and VigneshKishan like this.
  8. coolcontent
    Eclair Apr 4, 2016

    coolcontent , Apr 4, 2016 :
    Battery life seems to be worse and i had problems with networks but on the other hand, fingerprint scanner is faster
     

    anz563 and tucci0 like this.
  9. wurstsemmel2015
    Cupcake Apr 4, 2016

    wurstsemmel2015 , Apr 4, 2016 :
    Hello Community, Hello @Helen ,

    I want to share my experience with OOS 3.0 Community Beta.

    Device: OnePlus Two A2003, encrypted, no root, no CustomROMs, OOS 2.2.1
    System: Mac OS X 10.11.4

    Installation of OOS 3.0 beta via adb sideload as phone is encrypted:
    • Install Java JDK 8 (not the JRE)
    • Install Android SDK
    • Launch Android SDK Manager from ../tools and install Android SKD Tools and Android SDK Platform-tools
    • Enable USB Debugging on the phone
    • Reboot phone according to guide from OnePlus, choose "Install from USB"
    • Install ROM via adb sideload
    • Disable USB Debugging on the phone
    Bugs experienced so far:
    • Daydream does not work
    • File Transfer: Missing notification in phone status bar upon connection with Mac via USB. For file transfer it is required to slide down and choose "MTP". However, a small notification icon is missing in phone status bar to direct the user to the required settings.
    • DualSIM: In quick settings, a network coverage icon for the mobile network without data services is missing. The icon for mobile network with data services is present. Add a second icon for the second mobile network. Bug already present in OOS 2.2.1
    • [05 Apr 2016]: Settings -> Location -> Scanning is missing in UI, only accessible via search function in settings
    • [05 Apr 2016]: Developer Options available in search function in settings although Developer Options are disabled
    Feature requests:
    • Dialer: Allow easy picking of SIM1 or SIM2 for dialing, e. g. from recent call log. Motorola does a pretty good job by allowing to change SIM while phone is dialing. Motorola phone quits call and re-dials with other SIM. The "ask every time" function from OOS is annoying, as in most cases I want to dial with SIM1. Allow at least picking of SIM from recent call log.
    • Bug Tracker: Implement a bug tracker on the community websites to simplify bug reporting
    Overall, OOS 3.0 beta does a great job. No problem so far with connectivity or battery drain. Slightly snappier compared to OOS 2.2.1.

    Kind regards,

    wurstsemmel2015
     
    Last edited: Apr 5, 2016

    domingo19_ likes this.
  10. skb_shaikh
    Cupcake Apr 4, 2016

    skb_shaikh , Apr 4, 2016 :
    I was talking about the kernel for lollipop i.e the oxygen 2.2.1
     

  11. varunsur
    Gingerbread Apr 4, 2016

    varunsur , Apr 4, 2016 :
    This should be an app issue doubt re flashing for such a small issue will help.
     

    vamshi prasad likes this.
  12. Trevor Hawkes
    Cupcake Apr 4, 2016

    Trevor Hawkes , Apr 4, 2016 :
    You really should not be pushing for an OTA release. What we need is a OnePlus thread detailing all the bugs and problems they have gathered and put on their list together with their take on the causes and details of the solutions they have found and implemented so far. This list should be edited to show their progress, even if it only notes those things they are working on, those things solved and any new reported bugs and problems that have been reported. We are beta testing their software, as many people begged to be allowed to do only a couple of weeks ago, and we should be kept up to date with what is happening as a result of our work.
    The OTA should only come out when the list reports "solved" against all or most items.
     
    Last edited: Apr 4, 2016

  13. bassgenerator
    Gingerbread Apr 4, 2016

  14. rmoneplus
    Cupcake Apr 4, 2016

    rmoneplus , Apr 4, 2016 :
    HI there,

    my bugs:
    Home button not working / Fingerprint too.
    Notifications on lockscreen show still which app does have a (even on full hide), would be cool if it will behave like it was on 2.2.1 - just the Notification light and no apps (noone can spy which ap is running /sending me notifications).
    Volume is not set in the right manner or way too loud.

    OK:
    Battery bit more consuming then on old 2.2.1 still fine.

    I'll update on further issues if found.
    Best Regards
     

  15. tucci0
    Gingerbread Apr 4, 2016


  16. tucci0
    Gingerbread Apr 4, 2016

    tucci0 , Apr 4, 2016 :
    Can I re-install the same update to see if it solves the problem? Or risk of locking the phone?
     

  17. sfksuperman
    Honeycomb Apr 4, 2016

    sfksuperman , Apr 4, 2016 :
    t
    then go for boeffla kernel
     

  18. Mattia Orza
    Cupcake Apr 4, 2016

    Mattia Orza , Apr 4, 2016 :
    Nope, it doesn't work
     

  19. sfksuperman
    Honeycomb Apr 4, 2016

    sfksuperman , Apr 4, 2016 :
    1) Goto recovery mode (obviously twrp recovery).
    2) Clear (dalvic, system, data, cache) and not (internal).
    3) Flash the ROM, then flash the RECOVERY by selecting "install image" and selecting "recovery".
    4) Go back to main page of TWRP & Reboot and when it asks (system, recovery, fastboot), choose recovery.
    Then you just wait, it will reboot back to the new TWRP (orange color).
    5) Now flash the ROM once again. But before flashing, must clear cache again like in step 2.
    6) Clear cache.
    7) Reboot now. it takes approx 1mins and shows new bootanimation.

    Now, when you get Marshmallow page, set everything up like in starting. Then

    8) Flash SuperSU file via recovery to get root access.




    MUST HIT THANKS
     

    Baw2607 and VigneshKishan like this.
  20. sfksuperman
    Honeycomb Apr 4, 2016

    sfksuperman , Apr 4, 2016 :
    i have rooted my device. so any download link for next v3.0 update?