161
OxygenOS 3.1.3 (Marshmallow) OTA for OnePlus X

Thread Status:
Not open for further replies.
  1. G_rushikesh_kumbhar_lGHB
    Eclair Oct 12, 2016


  2. Bassidon
    Gingerbread Oct 12, 2016

    Bassidon , Oct 12, 2016 :
    Is someone facing the following problem?
    On opening the camera app, 'messenger stoped working or maps stopped working' these types of pop-ups.
    If yes, help me out.
    Im talking about opx marshmallow,oxygen os 3.1.3
     

  3. johndirch
    Froyo Oct 12, 2016

    johndirch , Oct 12, 2016 :
    With stock kernel I had 15% drop at the night. I did all for battery drain. Wi-Fi off scanning. Location off. Bluetooth off. The phone goes to sleep. With bluspark I had not this battery drain on sleep. I had 1% drop on the hour at night. Please tell us about the battery with boefla and the governor you use. Thanks.
     

    Seeds26 likes this.
  4. G_Ravi_Raval_GkkR
    Eclair Oct 12, 2016

    G_Ravi_Raval_GkkR , Oct 12, 2016 :
    Ya... Its including it.. Just update to 3.1.3 it has gujarati support
     

  5. Guidoce
    Ice Cream Sandwich Oct 12, 2016

    Guidoce , Oct 12, 2016 :
    Still wondering about battery performance, one night in airplane mode drains 2% two days ago, 5% last night...
     

  6. vinz_uk80
    Gingerbread Oct 12, 2016

    vinz_uk80 , Oct 12, 2016 :
    OK, great to hear that there are other good kernel available for MM on the OPX. I'll stick stock for the moment, and I think I'll try this kernel in the near future.

    By the way, I keep having the issue when gesture are not responding anymore. I did a wipe of dalvik/art cache, and wipe cache and reboot. But it works for maybe 12h, and then, suddently, it stops working. Strange.
    To re-enable it, I activate the proximity wake up, and then, it works again. If then I disable the proximity wake up, I still works.
    I had an issue with the proximity sensor creating lots of wakelocks under OOS2.2.2 and before this. Maybe I have an issue with my proximity sensor?
    Other than that, my OPX works perfectly well. Much less heat and battery drain under Waze in the car. And battery life still seems strong, 5h30 SOT and 25% remaining.

    I had 1% drain over night with OOS 2.2.2 + Blu_spark kernel. Here, stock under 3.1.3 but rooted, I also have 1 to 2% drain over night. Do you use BBs or GSAM to monitor wakelocks?
     

  7. johndirch
    Froyo Oct 12, 2016

    johndirch , Oct 12, 2016 :
    I am rooted and I have wakelock detector. Google services wake up 50x in 2 hours (net scheduler). On night I don't use airplane mode.
     
    Last edited: Oct 12, 2016

  8. 1961767
    Cupcake Oct 12, 2016

    1961767 , Oct 12, 2016 :
    Please bring back individual ringtones for SIM 1 ans SIM 2.
    Dualsim is useless without this function.
    It is not not comprehensible why this simple useful feature is gone lost in a major update.
     

  9. vinz_uk80
    Gingerbread Oct 12, 2016

    vinz_uk80 , Oct 12, 2016 :
    I have BBS, and the com.google.android.gms alarm, wakes up the phone 17.4 times per hour.
    Since yesterday, I installed Greenify, that triggers quicker Doze mode, maybe it can help.
     

  10. nickvatalis888
    Cupcake Oct 12, 2016

    nickvatalis888 , Oct 12, 2016 :
    Good morning guys. I was wondering where is the option now for deleting some recent calls in the call history? It has only clear call history option which means clear all call history. Any idea ?
     

  11. FaleshC
    KitKat Oct 12, 2016

    FaleshC , Oct 12, 2016 :
    Just goto Settings>Apps>Camera>Permissions and allow Storage permission
    Repeat the same for Maps and Messenger
    and Voila!!!! no more annoying pop ups anymore!!!!!!!
    simple is it not??
     

    Mr. BG likes this.
  12. fabiolanzi
    Ice Cream Sandwich Oct 12, 2016

    fabiolanzi , Oct 12, 2016 :
    You need to select the call, go to details, delete from there
     

    nickvatalis888 likes this.
  13. nickvatalis888
    Cupcake Oct 12, 2016

    nickvatalis888 , Oct 12, 2016 :
    Thank you very much
     

  14. fabiolanzi
    Ice Cream Sandwich Oct 12, 2016


  15. JasonLim25
    Cupcake Oct 12, 2016

    JasonLim25 , Oct 12, 2016 :
    Hello guys , need help here.

    The problem would be after updating to marshmallow . All of the files was all right but only one file was unable to open. I have tried using PC to transfer the file but it was unable to copy/cut . Tried opening the photos on the computer but it can't be opened. It said that " Windows Photo Viewer can't open this picture because either Photo Viewer doesn't support this file format, or you don't have the latest updates to Photo Viewer." The photo folder has turned into some weird document that can be opened. The photo folder is very important to me and i must retain back the photos.

    https://s18.postimg.org/ieec7rj4p/Problem.jpg
    https://s3.postimg.org/79zducnlf/Problem_1.png
    https://s14.postimg.org/ri8wb57i9/Problem_2.png
    https://s13.postimg.org/skojmqgjb/Problem_3.png
     

  16. guisbro
    Ice Cream Sandwich Oct 12, 2016

    guisbro , Oct 12, 2016 :
    email to transfer photo to PC

    try gimp on PC to see if that will open the photo file
     

    JasonLim25 likes this.
  17. fabiolanzi
    Ice Cream Sandwich Oct 12, 2016

    fabiolanzi , Oct 12, 2016 :
    my guess is that that folder got somehow corrupted... it will be hard to get it back, it is very strange that it happened though...
     

    JasonLim25 likes this.
  18. Kéno40
    Jelly Bean Oct 12, 2016

    Kéno40 , Oct 12, 2016 :
    Is that the same with others folders around?
    Did you try to take a new photo with camera?

    Any autorisation problem?
     

  19. SapilautX
    Ice Cream Sandwich Oct 12, 2016

    SapilautX , Oct 12, 2016 :
    with stock kernel I had no battery drain issue at all. got 6 hrs+ of sot. you'll need to see what apps that caused your battery drains too fast over night or in sleep mode. check your stats.
    *try perform wipe dalvik/cache only in recovery once you've finished installing all apps.

    this is the first time I am using boeffla, used to bluspark. I am using default profile since it gives balance for performance and battery (closely to stock kernel).
    for battery life I can't tell you right now..I'll report back in few days
     
    Last edited: Oct 12, 2016

  20. SapilautX
    Ice Cream Sandwich Oct 12, 2016

    Last edited: Oct 12, 2016