OxygenOS 3.1.3 (Marshmallow) OTA for OnePlus X

Thread Status:
Not open for further replies.
  1. gigitek
    Froyo Oct 3, 2016

    gigitek , Oct 3, 2016 :
    The OTA will not erase your data.

    umesh3034 likes this.
  2. script
    Moderator Moderator Oct 3, 2016

    script , Oct 3, 2016 :
    It's how it is in MM now. Feature, not a bug.

  3. m_hamizan
    Froyo Oct 3, 2016

  4. Guidoce
    Ice Cream Sandwich Oct 3, 2016

    Guidoce , Oct 3, 2016 :
    Scroll this post and you'll get the answer...

  5. Maychine
    Cupcake Oct 3, 2016

    Maychine , Oct 3, 2016 :
    I got an OTA update for my OPX for OxygenOS 3.1.3 (Marshmallow). As soon as I updated my phone, I started getting a popup stating "Unfortunately Google Play Service has stopped". This popup appears every 2 secs making my phone almost unusable. I've tried the following but nothing seems to be working:

    1. Tried opening Google Play Store to update Google Play Services but Play Store app crashes. Tried to do the same by accessing Play Store on my laptop but the error kept coming.
    2. Tried clearing cache and data for Google Play Services and Play Store but this also didn't work.
    3. Reboot also did not help.
    4. Tried removing and re-adding my Google Account but this also failed and created another problem. Now I can't even see my OPX device when I login to play store on my laptop using the same account.

    Does anyone have an idea on how to update Google Play services without having access to Play Store?

    justinplusonemore likes this.
  6. justinplusonemore
    Gingerbread Oct 3, 2016

    justinplusonemore , Oct 3, 2016 :
    I am having same issues as above, real pain as cannot even play pokemon go whilst riding to work today(and was about to hatch an egg)
    In all seriousness this google play thing is a real pain, I have tried so many fixes but none seem to work, any ideas oneplus????

  7. sreenivasulu reddy.k
    Donut Oct 3, 2016

    sreenivasulu reddy.k , Oct 3, 2016 :
    Thnks, but have to swipe right

  8. Maychine
    Cupcake Oct 3, 2016

    Maychine , Oct 3, 2016 :
    Facing the same problem. Tried a number of things suggested on various forums but nothing seems to work. Were you able to find a solution for this?

  9. G_Viswanath_T_UOmV
    Cupcake Oct 3, 2016

    G_Viswanath_T_UOmV , Oct 3, 2016 :

    even i had these issues but once after the factory reset.. every is solve ... EXCEPT THE BATTERY ISSUES


  10. amrinh
    Cupcake Oct 3, 2016

    amrinh , Oct 3, 2016 :
    Hi, After upgrading to 3.1.3 I'm facing few issues:
    1) "Messenger crash" when any picture is clicked.
    2) How to remove default lock screen wallpaper?

    Can anyone help please?

  11. dreggar
    Cupcake Oct 3, 2016

  12. gigitek
    Froyo Oct 3, 2016

    gigitek , Oct 3, 2016 :
    @Berg P. Great update. Not having any issues.
    Upgraded from 2.2.3 to 3.1.2 and then to 3.1.3
    Before the jump to 3.1.2 did a Factory reset, Wipe cache, Wipe data.
    After 3.1.2 update also did a Factory reset.
    After 3.1.3 update just a Wipe cache.
    I did not noticed problems with heating, battery drain, lags.
    Loving the New Alert Slider.
    Using Nova Launcher Pro, no shelf.

    script and Deactivated User like this.
  13. G_Vijay_Singh_qqMj
    Cupcake Oct 3, 2016

    G_Vijay_Singh_qqMj , Oct 3, 2016 :
    I dont see any new icon pack or wallpaper frm the version 3.1.2, if ders any new thing added other den security patch let me knw guys???... ;)

  14. Deactivated User
    Oct 3, 2016

  15. alexsandalis
    Cupcake Oct 3, 2016

    alexsandalis , Oct 3, 2016 :
    How is it I've been upgrading to the latest versions including this one yet it sais my OxygenOS is still on 2.2.3?

    wraaagh likes this.
  16. G_Vijay_Singh_qqMj
    Cupcake Oct 3, 2016

  17. TdGoutham
    Eclair Oct 3, 2016

    TdGoutham , Oct 3, 2016 :
    Goto settings>apps>messenger>permissions.
    Grant all permissions to messenger.

  18. Luso90
    Donut Oct 3, 2016

    Luso90 , Oct 3, 2016 :
    to all the people who have had various problems after upgrading to 3.1.3: do a factory reset and fix everything! Now the phone is very fast, the battery lasts much! and doze works perfectly. tonight at 9 hours of standby has taken only 1% of battery

    TdGoutham likes this.
  19. TdGoutham
    Eclair Oct 3, 2016

    TdGoutham , Oct 3, 2016 :
    Make sure to backup your data before updating. After the update, factory reset and then restore your data.

  20. grucha2666
    Froyo Oct 3, 2016

    grucha2666 , Oct 3, 2016 :
    guys I got 3.1.1 community update and still I have not recived OTA 3.1.3. Should I reset my phone or do a factory reset? Or should I just wait and it's normal to wait so long for OTA?