1
Permissions of applications are blocked after upgrade of Oxygen

  1. Andrei_Erch
    Donut Jun 10, 2016

    Andrei_Erch , Jun 10, 2016 :
    What's going on with new update 3.0?

    After downloading and installation all of permission of all applications are blocked. The applications do not have access to photos, microphone, etc. Antivirus is blocked. Truing to reinstall the applications, it did not resolve the problem. Oxygen blocked an access of applications to the phone's features.

    Kind regards,
    Andrei
     

    #1
    iNarinder likes this.
  2. kclaes83
    Cupcake Jun 10, 2016

    kclaes83 , Jun 10, 2016 :
    Last night my Oneplus 2 updated to OxygenOS version 3.0.2

    Whatapp needed a permission for storage. When I tried to enabled that permission, it asked another permission for "Screen overlay". But it's not possible to enable this.
    I tried a factory reset of my permissions. Still it's not possible to enable a single permission. So now, I lost most of my permissions and my phone is almost useless.

    I'm getting really tired of my OnePlus 2. By far the worst smartphone software I ever encountered.
     

    #2
  3. marinobiagio
    KitKat Jun 10, 2016

    marinobiagio , Jun 10, 2016 :
    Settings>App> (tap on the tree dots in the right corner to show this) Reset app preferences.
    Turn off app that works "above" the screen (like blue light filter) and it will works.
    It worked for me!
     

    #3
    mkernbach likes this.
  4. wpeelen
    Cupcake Jun 10, 2016

    wpeelen , Jun 10, 2016 :
    Same problem here
    After upgrade the "permissions" cannot be changed. Whatsapp (and problably other apps too) don't work properly.
    Please fix this asap as the OnePlus2 cannot be properly used until this is fixed.
     

    #4
  5. kclaes83
    Cupcake Jun 10, 2016

    kclaes83 , Jun 10, 2016 :
    tdlo found a solution:

    tdlo, 25 minutes ago :
    I was hitting this issue as well. It turns out that one of the apps I had installed was dealing with overlay in a way other apps didn't like. The app was File Manager HD.

    Go to: Settings | Apps | Click the setup icon on the top right | Draw over other apps

    From here there are two approaches:
    1) You can set the overlay permission for every app in the list to 'No'. The app that was complaining in the first place should now work. This is a bit draconian though, as the apps in that list wanted the permission for a reason. You may find some of those apps don't work properly anymore or ask for the permission again.
    2) Second approach is process of elimination (recommended). You can can set the overlay permission to 'No' one at a time and try the app with the overlay issue to see if it works. That way hopefully you narrow the problem down to one app (in my case it was File Manager HD). Once you figure it out, leave that one set to 'No' but set/leave the rest of them to 'Yes'. Hopefully it's just one app causing the problem otherwise deducing what combination you need to turn off is a little more tedious.
     

    #5
    iNarinder likes this.
  6. wpeelen
    Cupcake Jun 10, 2016

    wpeelen , Jun 10, 2016 :
    Thanks Marinobiagio, that actually helped. I reset app preferences, now the menu for permissions appears and i can change settings. I need to do check all apps . . . that is a pity at least it works
     

    #6
  7. a867asfd
    Donut Jun 10, 2016


    #7
  8. mkernbach
    KitKat Jun 10, 2016

    mkernbach , Jun 10, 2016 :
    Yes, you're right. I started with re-installing apps but the I saw fc's when I tried to go to app-permissions settings so I did the trick with the tree dots in the right corner and... voilla! it works now, few apps were asking again for permissions but this is not a big deal
     

    #8
    marinobiagio likes this.
  9. marinobiagio
    KitKat Jun 10, 2016

    marinobiagio , Jun 10, 2016 :
    You are welcome I'm happy that it worked! :)
     

    #9
    mkernbach likes this.
  10. lorenzoletti
    Cupcake Jun 10, 2016

    lorenzoletti , Jun 10, 2016 :
    Sorry Marinobiagio but it doesn't work for me...
    What did i fail?
    I can't find BLUE LIGHT FILTER. Wher it is?
    Could you help me?
     

    #10
  11. iNarinder
    Eclair Jun 10, 2016

    iNarinder , Jun 10, 2016 :
    I was also fiddling with the settings to get it resolved last night and only solution that seems to work is to disable them all, then reenable. Kind of ridiculous since I have about 25 apps that require the permission to draw over other apps. They should at least provide a switch that turns off the permission for all apps and when we want, turn on the only ones we had on prior to turning off. Resetting preferences is kind of lousy and doesn't work every time.
     

    #11
  12. Andrei_Erch
    Donut Jun 10, 2016

    Andrei_Erch , Jun 10, 2016 :
    I tried to do it. But it does not work. This is some "magic circle". App is asking permission then turn off app that works again. I did and this sh..t asks again and again.
     

    #12