4
OxygenOS Phone Call Echo Issue

  1. G_Juergen_Mueller_ggQV
    Froyo Jun 25, 2017

    G_Juergen_Mueller_ggQV , Jun 25, 2017 :
    Unfortunately this latest built has still the call echo issue. The person whom I calling with hears his own voice after a while with 1-2 second delay. I dont hear the echo. Only the person I am calling with.
    There are many posts about the echo issue in this forum. I tried every advice, nothing helped.
    All OxygenOS version are having this issue on my phone

    Device: 3T Oneplus (2 months old). Issue was from the beginning.

    I did a lot of investigation and the following facts:
    • with the Linage OS Rom built from the 27.04.2017 there is no issue with the echo at all - cannot be an Hardware issue
    • removal of the protection case -> no change echo is still there
    • Factory Reset of Oxygen OS -> no change
    • all Linage OS builts despite the built from the 27.04.2017 having again this issue
    • I tried as well Oxygen Beta 8 & 9 same Problem but with Beta 9 it didn't occur so often
    • switching off the ok Google recognition doesn't change. Still echo issue
    • I tried latest built from Paranoid Android, RR Rom same issue with the echo
    • switching speakers on and off during the call Reliefs from the echo
    • if I put tape over the microphone at the Button - > no echo issues any more but the person I am calling with cannot hear myself very well
    • I updated and tried many Firmware and Modem drivers including the latest. No change still echo

    Conclusion: it has definitely something to do with the noise cancellation Software of the phone.

    Does anyone can help me? How can I switch off / Bugfix The noise cancelation Software? The Nexus phones had the Same issue and Google Brought a fix out.

    Your help is very much appreciated :)
     

    #1
  2. ykonijn
    Cupcake Jun 26, 2017

    ykonijn , Jun 26, 2017 :
    Same problem on OP3 with the latest OxygenOS build. This is getting annoying.
     

    #2
  3. G_Adir_Gadka_PciQ
    Cupcake Jul 6, 2017


    #3
    radocernak likes this.
  4. cstyves
    Donut Jul 18, 2017

    cstyves , Jul 18, 2017 :
    Same problem OP5 random issue and it happen many times during any calls (on and off echo toggling).
     

    #4
  5. radocernak
    Gingerbread Jul 24, 2017


    #5
    JBowdery_LXIS likes this.
  6. radocernak
    Gingerbread Aug 4, 2017


    #6
  7. JamesAnscomb
    Cupcake Aug 9, 2017

    JamesAnscomb , Aug 9, 2017 :
    I'm also having this issue particularly when taking through calls through Ring central my VOIP provider. Please can OP look into this ASAP as it's looking very unprofessional!
     

    #7
  8. G_harshal_eri_JNEO
    Cupcake Aug 12, 2017


    #8
  9. anick16
    Cupcake Aug 12, 2017

    anick16 , Aug 12, 2017 :
    same issue with my OP3T, it's very annoying and I have to use headset for every call.
     

    #9
  10. G_Rahul_Bhat_ODQH
    Cupcake Aug 12, 2017


    #10
  11. G_Juergen_Mueller_ggQV
    Froyo Aug 12, 2017

    G_Juergen_Mueller_ggQV , Aug 12, 2017 :
    Hi I flashed now the latest RR ROM Version and its significantly better but still sometimes having the issue. I really don't know why oneplus doesn't do anything about it. Its obvious that this is a Software issue
     

    #11
  12. G_Juergen_Mueller_ggQV
    Froyo Aug 15, 2017

    G_Juergen_Mueller_ggQV , Aug 15, 2017 :
    Echo Issue FIXED!!!!!!!!

    Hi all, after trying and investing hours and hours to find a solution for the echo issue I found a soll which fixed thr Problem the App is called DeFluence. You can find it in the Google playstore. It modifies the noise cancelation Software and FINALLY! it really works! After months and after trying out many ROMs, other advices etc I can use my Oneplus 3T without any echo during calls. You need root access for the DeFluence App. I just flashed RR Rom which brings root access within the built.

    Dear Oneplus Team : it is now prooven that the echo issue is a Software Bug in the noise cancelation Software. Please fix this issue in your Oxygen OS Software
     

    #12
  13. G_Haim_L_bcYM
    Cupcake Aug 15, 2017


    #13
  14. G_Juergen_Mueller_ggQV
    Froyo Aug 15, 2017


    #14
  15. G_Juergen_Mueller_ggQV
    Froyo Aug 15, 2017


    #15
  16. sumitsharma90
    Cupcake Aug 23, 2017

    sumitsharma90 , Aug 23, 2017 :
    Thank you so much... Worked for me.... [e]1f44d[/e]
     

    #16
  17. JamesAnscomb
    Cupcake Aug 25, 2017

    JamesAnscomb , Aug 25, 2017 :
    OP you need to respond to this issue. I've bought a phone for professional use and you are making me look stupid. I'm outside my 14 days otherwise I'd return the unit.
     

    #17
  18. radocernak
    Gingerbread Aug 25, 2017

    radocernak , Aug 25, 2017 :
    Same for me. I have in my phone mandatory installed business application which doesn't work in rooted device. Therefore I'm not able to use solution mentioned above.
    Still waiting for official fix from OnePlus.
     

    #18
  19. jnconeplusone
    Cupcake Jan 9, 2018

    jnconeplusone , Jan 9, 2018 :
    Oneplus, my 3t also has the echo issue.
    I don't want to root my phone as there is too much risk.
    Can you please let me us how to fix this issue please?
    Or advise when you plan to release an update to correct this issue?
     

    #19
    mattx307 likes this.
  20. G_Valery_Khamenya_pCsg
    Cupcake May 18, 2018


    #20
    mattx307 likes this.