0
Phone/Contacts :- You have disabled a required permission

  1. Z1560348110682
    Cupcake Oct 21, 2019

    Z1560348110682 , Oct 21, 2019 :
    Hi,

    I have got a Oxygen OS 10 2-3 days back and I updated it. But after that my phone asked me required permissions for Phone/Contacts app, and mistakenly I denied it.

    Now, when I try to open any contact information it is shows "You have disabled a required permission" error text with no clue and steps to allow those permissions.

    Could you please help ?

    PS: I have tried allowing permissions for Google and necessary apps going into settings.
     

    #1
  2. xnutzii
    Lollipop Oct 21, 2019

    xnutzii , via OnePlus 6T , Oct 21, 2019 :
    You said that you've enabled permissions in the settings, but not for the phone app?

    Hold down onto the phone app until you see a little "menu", it shows a few options and some shortcuts within the phone app, tap onto "app-info", then after that, open the "permissions" tab and enable the disabled one.
     

    #2
  3. W1571649340212
    Cupcake Oct 21, 2019

    W1571649340212 , Oct 21, 2019 :
    Even after giving all permissions, the contact details don't open.
     

    #3
  4. Wackencorpse
    KitKat Oct 21, 2019

    Wackencorpse , Oct 21, 2019 :
    You should do this also with the contact app. Phone and Contact are two different apps with different permissions.
     

    #4
    xnutzii likes this.
  5. xnutzii
    Lollipop Oct 21, 2019

    xnutzii , via OnePlus 6T , Oct 21, 2019 :
    do as mentioned here
    thanks
     

    #5
    Wackencorpse likes this.
  6. W1571649340212
    Cupcake Oct 21, 2019

    W1571649340212 , Oct 21, 2019 :
    Thanks
     

    #6
  7. Z1560348110682
    Cupcake Oct 22, 2019

    Z1560348110682 , Oct 22, 2019 :
    I checked in the app info, but there is no permission in the denied space. I guess this is a big with Oxygen OS 10, as there is no option showing which permissions to give.
    1571725371448.jpg
     

    #7
  8. X1563615703750
    Cupcake Oct 22, 2019

    X1563615703750 , Oct 22, 2019 :
    I am also facing the same issue
     

    #8
  9. Z1560348110682
    Cupcake Oct 22, 2019

    Z1560348110682 , Oct 22, 2019 :
    Hi,

    I have just found a solution for this.

    SOLUTION:-
    1) Go-to Settings -> Apps and notifications
    2) Click on "SEE ALL 100 APPS" (your no. of apps)
    3)Click on 3 dots which are in the upper right corner.
    4)Select "Reset app preferences"
    5) Open "Phone" application and allow all permissions again!

    Thank you.
     

    #9
  10. Wackencorpse
    KitKat Oct 22, 2019

    Wackencorpse , Oct 22, 2019 :
    There must be another App called "Contacts". Perhaps you have also denied the permission in this app. You are only showing a screenshot of you "Phone" App where no contacts are saved.
     

    #10
  11. Z1560348110682
    Cupcake Oct 22, 2019

    Z1560348110682 , Oct 22, 2019 :
    Yes, but I have found the solution.

    Thanks anyways!
     

    #11
  12. Pipapops
    Cupcake Oct 22, 2019

    Pipapops , Oct 22, 2019 :
    What you have found is not a solution and users should avoid doing that, unless they want to have the hassle of having to set the permissions for all apps all over again.

    Resetting the permissions for ALL apps, when all you had to do was to modify the permissions for ONE app (contacts), is like using a nuclear bomb to kill a mosquito.

    Like Wackencorpse said, it's not the phone app that needs the permissions, it's the OnePlus Contacts app. And if you deny even one of those, it will refuse to work, stating that you denied a "required" permission.

    I understand why the contacts app needs permission to access contacts, phone, and storage, but I fail to see why it is *required* that the app has access to my location in order to work properly, so I denied it and it refused to work.

    The solution is simple - you either are OK with it and allow everything it asks for, or you disable the OnePlus Contacts app (since it can't be uninstalled without root) and install a different and less intrusive contacts app
     

    #12
  13. Z1560348110682
    Cupcake Oct 22, 2019

    Z1560348110682 , Oct 22, 2019 :
    Umm...you're right!

    I think I've checked Contacts app as well..but I don't know, I must have mistakenly kept those permissions disabled.

    Thanks for clearing that.
     

    #13
  14. Q1571719173425
    Cupcake Oct 23, 2019

    Q1571719173425 , via OnePlus 7 Pro , Oct 23, 2019 :
    The best solution would be to have contacts app fixed by OnePlus, so it would not require access to localisation.
    I failed to find a third party app that would integrate dialer, call history and contacts in the nice way... :(
     

    #14
  15. Pipapops
    Cupcake Oct 23, 2019

    Pipapops , Oct 23, 2019 :
    It's the Phone app that integrates all that in the same place. It's only when you tap on a contact in the phone app that it switches over to the contacts app.
    Google Contacts, for example, only needs access to phone, contacts and storage and it integrates seamlessly with the existing OnepPlus Phone app.
     

    #15
    Q1571719173425 likes this.
  16. O1571896672930
    Cupcake Oct 24, 2019

    O1571896672930 , Oct 24, 2019 :
    Thanks you so much buddy, this solved my problem. After taking these actions, need to allow permission for Contact as well as Phone app
     

    #16