0
Phone displays incorrect carrier

  1. Ceasedd
    Marshmallow May 26, 2015

    Ceasedd , May 26, 2015 :
    Bingo.:)
     

    #21
    JElder likes this.
  2. cabanaj
    Honeycomb May 29, 2015

    cabanaj , May 29, 2015 :
    Well I'll be... this afternon after a reboot, just got back randomly to "normal" Well it shows VL (Videotron Limited I guess -it was showing Videotron on CM11s) instead of Rogers. No change to APN were made.
     

    #22
  3. cabanaj
    Honeycomb Jun 2, 2015

    cabanaj , Jun 2, 2015 :
    And the bug reappeared. Got fed up, giving CM12s a try. Seems to play nice with the magic jack app too, (with Oxygen OS, had to uninstall it).
     

    #23
  4. icest0rm
    Gingerbread Sep 15, 2015

    icest0rm , Sep 15, 2015 :
    ok I just got my OPT yesterday and inserted my 2 sims.

    I get:

    "Telecom Italiz SpA" instead of "TIM" which most phones use (btw should be Telecom Italia and not Italiz)

    and

    "Hutchinson 3g" instead of "3 ITA" which most phones use (that should be H3G carrier).

    so why this wrong names? and also mispelled? any fix yet?
    this is really annoying...
     

    #24
  5. JohnzyFitzgerald
    Froyo Sep 15, 2015

    JohnzyFitzgerald , Sep 15, 2015 :
    Instead of the usual '3', I was getting 'Hutchison 3G IReland limited' (the capital 'R' in 'IReland' isn't my mistake).
    Anyway as I have my phone rooted, I installed a little app called Custom Text, and I have it set to replace all instances of 'Hutchison 3G IReland limited' in the system UI with '3 Ireland'.
     

    #25
  6. digglesworth
    Cupcake Sep 17, 2015

    digglesworth , Sep 17, 2015 :
    I'm getting the same issue with my OPT. I put in a T-Mobile sim and an AT&T sim. T-Mobile is in slot 1 and it's set to be the primary sim but it shows AT&T. I removed the AT&T sim and rebooted the phone twice. It still shows AT&T as the carrier. I checked LTE Discovery and it shows that I'm on Band 12 LTE and that is T-Mobile.
     

    #26
  7. sandmman
    Honeycomb Sep 22, 2015

    sandmman , Sep 22, 2015 :
    Hi Guys,

    I'm having same issue like you do. I live in Poland, use 2 SIMs:
    SIM 1 of mobile op: PLAY (very old name P4)
    SIM 2 of mobile op: ORANGE (very old name PTK Centertel)

    My OPT reports Orange for both SIMs, while in SIM menu (settings) saying that:
    SIM 1 is registered in Orange network
    SIM 2 is registered in PTK Centertel network.

    It's complete mess. I hope OP will do something with that soon... 2 SIMs feature is one of the reasons I bought this phone.
     

    #27
  8. sandmman
    Honeycomb Sep 23, 2015

    sandmman , Sep 23, 2015 :
    UPDATE:
    Today I upgraded to OxygenOS 2.1 and I can say the problem is gone, fixed :)
    Names for mobile operators are properly displayed on my side.
     

    #28
  9. WojtekS
    Eclair Sep 23, 2015

    WojtekS , Sep 23, 2015 :
    As for me I have sim1 from PLAY operator, sim2 from PLUS operator and on the lock screen the displayed names are P4 Sp. zo.o | Polkomtel, as well as on SIMs settings menu.

    Same problem after 2.1.0 Update: the carrier name list stored in ROM is still incorrect.

    I realized the displayed carrier names are in fact legal names instead of commercial names - same as you would say on the car it's the Fuji Heavy Industries Impreza instead of it's a Subaru Impreza, it's a PSA 406 instead of Peugeot 406 etc...

    [​IMG]
     
    Last edited: Sep 23, 2015

    #29
    Tokolozi likes this.
  10. bonello77
    Honeycomb Sep 23, 2015

    bonello77 , Sep 23, 2015 :
    For me the same also with ox 2.1

     

    #30
  11. werner.alessandri
    Donut Sep 23, 2015

    werner.alessandri , Sep 23, 2015 :
    There is a fix for rooted devices. Just create the file 'spn-conf.xml' in system\etc and set the appropriate rights (octal 0644). Here you can put the carrier names you want.
    This example shows translations for the italian carriers Vodafone and TIM ('Telecom Italiz'):
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <spnOverrides>
    <spnOverride numeric="22210" spn="Vodafone IT" />
    <spnOverride numeric="22201" spn="I TIM" />
    </spnOverrides>
    After a reboot the carrier name will be ok.

    Here i've found a link with a carrier list:
    http://www.numberportabilitylookup.com/networks?s=
     

    #31
    WojtekS likes this.
  12. WojtekS
    Eclair Sep 23, 2015

    WojtekS , Sep 23, 2015 :
    It should be fixed by oneplus in a patch ;)

    And when I look on your list I am hppy that I don't have a bealorussian and Finland sims installed - it would not fit in screen width :D :D :D

    Belarusian Telecommunications Network CJSC |
    Elisa Corporation-GSM 900/1800 Finland
     

    #32
  13. kleinbatavia
    Honeycomb Sep 23, 2015

    kleinbatavia , Sep 23, 2015 :
    Haha there's OP engineering for you :)
     

    #33
  14. stefray
    Donut Sep 30, 2015

    stefray , Sep 30, 2015 :
    yes, i had this same issues, updated to 2.1 fixed the problem, also seems like fixed the wifi not reconnect problem also.. nice update!
     

    #34
  15. ChefChaudart
    Honeycomb Oct 14, 2015


    #35
  16. luca.cavicchioli
    Cupcake Oct 15, 2015

    luca.cavicchioli , Oct 15, 2015 :
    I don't think so... Nexus5 shows "TIM", OPT shows "Telecom Italiz SpA" with a spelling error... Italiz instead of Italia :-(
     

    #36
  17. ChefChaudart
    Honeycomb Oct 15, 2015


    #37
  18. Deactivated User
    Oct 15, 2015


    #38
  19. ChefChaudart
    Honeycomb Oct 15, 2015

    ChefChaudart , Oct 15, 2015 :
    I don't think so ...
    My 1+1 displays the correct carrier, and beside, the 1+2 shows incorrect names ...
     

    #39
  20. gzafeiro
    Eclair Oct 15, 2015

    gzafeiro , Oct 15, 2015 :
    I also live in Belgium. I have 2 sims: one form Mobistar and one from a Greek provider Cosmote. My phone shows: France Telecom | France Telecom at the lock screen.
     

    #40
    rcocoon and ChefChaudart like this.