0
Network/Connectivity Phone not responding to calls from certain numbers

  1. Timmmmaaahh
    Gingerbread Jan 15, 2021

    Timmmmaaahh , Jan 15, 2021 :
    Hey community! I'm in somewhat of a pickle here with my Fajita and I've pretty much hit a dead end.

    For some reason, my cellphone is blocking a bunch of people trying to call me but not even in a traditional sense. The caller hears a dialing tone but on my end nothing happens. Eventually the caller is sent to voicemail and I get a text about the new voicemail. This is particularly so with numbers from work (oh the laughs we had on that). Ever since I've started working from home, these issues became more and more apparent.

    The number structure in our company is +1234567890: consisting of country code, company number (same for everyone) and the last 4 digits are the extension (everyone's personal number).

    When I call my cell phone with my personal work device, let's say +12 3456 1111, the call comes through. When my colleague, let's say +12 3456 2222, tries to call me, I get nothing. This is the case for at least 8 colleagues.

    However, when I put my SIM card in another device, the call from 2222 does come through! So I'm confident it's device related.

    What I have tried so far:
    • Checked with our company's phone server manager – we call 'm "Cable Guy" – but no issues there
    • Checked with my ISP but they don't really want to do much digging (because the SIM works, can't blame them)
    • Temporarily blocked 'Telephone' permission on all apps that had it
    • Temporarily revoked root access from any app that had it
    • Removed any numbers I had in my blocklist (just one)
    • Reinstalled Mr. Number with TitaniumBackup, an app I had used before to block numbers, to make sure all block settings are off
    • Tried blocking a number, when that number then calls, 'Dashboard' notifies this in a popup: Call block Blocked call: +12 34...
    • Reboot my device (lol)
    • Reverse calling: using my cellphone to call 2222, which works
    • Updated OOS from latest beta to stable 10.3.7 + wiped data and cache (factory reset!)
    • Rebooting to safe mode
    The result remains the same in every single case: calls from extension 1111 work but from 2222 and a bunch of others, they just don't show up. What am I missing here? Is OxygenOS inherently omitting some calls (some kind of spam protection)? Is there an app on my device that manages to block things without causing any notifications? Some corrupt radio drivers? I have no idea what to try next. How do I troubleshoot this? Any help would be very much appreciated! Thanks.

    Tech details
    OnePlus 6T aka Fajita aka A6013 (8/128GB)
    OxygenOS 10.3.7 (Android 10)
    Baseband 845_GEN_PACK-1.276740.1.331501.2 (stock)
    Kernel 4.9.179-perf+ (stock)
    Rooted with Magisk 21.2 - SafetyNet intact

     

    #1
  2. Timmmmaaahh
    Gingerbread Mar 22, 2021

    Best Answer
    Timmmmaaahh , Mar 22, 2021 :
    Problem solved!
    It was the user-to-user parameter after all. This was the setting:
    upload_2021-3-22_14-10-44.png

    The calls are now coming through perfectly.

    Thanks again @Caomhin for bearing with me on this quite exhaustive troubleshooting adventure!
     

    #18
    Caomhin likes this.
  3. Timmmmaaahh
    Gingerbread Feb 22, 2021

    Timmmmaaahh , Feb 22, 2021 :
    Friendly bump :) No one with any ideas?

    [sarc]Luckily 1+ really shows dedicated support to their devices so I can give Android 11 a go to see if it's fixed before anyone speaks of Android 12[/sarc] ^_^
     

    #2
    Caomhin likes this.
  4. Caomhin
    OnePlus 9 Series Expert Community Expert Feb 22, 2021

    Caomhin , via OnePlus 6T , Feb 22, 2021 :
    Have you reset your Mobile Network adapter. I don't see it mentioned.

    Settings, System, Reset Options, Reset WiFi Mobile Bluetooth.

    Also I note you have rooted your phone. Have you changed any developer settings that may have caused the issue.

    Also backup your contacts, then Clear both the OnePlus Dialler App info Cache and App info Storage as well. This will reset the App, and may reset to default any spam blocking feature.

    Have you also tried the Sim into the 2nd Sim slot?
     

    #3
    Timmmmaaahh likes this.
  5. Timmmmaaahh
    Gingerbread Mar 3, 2021

    Timmmmaaahh , Mar 3, 2021 :
    Heya! Thanks. So far I've tried to clear the phone app and switching SIM slots. I also tried using Google dialer. No success. Will have to try the Network reset later. I'm assuming this will remove all remembered Wi-Fi networks and sever all Bluetooth connections so need to do some research first before losing things I regularly need. Will try that later on!

    There were no developer settings changed. I only use that menu to toggle debugging on and off.
     

    #4
    Caomhin likes this.
  6. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 3, 2021

    Caomhin , via OnePlus 6T , Mar 3, 2021 :
    Yes it will wipe any current WiFi and Bluetooth access as well, so those routers and devices will have to be setup again.
     

    #5
    Timmmmaaahh likes this.
  7. Timmmmaaahh
    Gingerbread Mar 8, 2021

    Timmmmaaahh , Mar 8, 2021 :
    Okay. I was physically at the office today so did some more testing. Network reset went smooth but did not deliver any results. Additionally, I rebooted to TWRP and wiped dalvik/cache, in case anything would've gotten stuck in there. To no avail, the problem remains the same. A call from my device: works perfect. A call from my colleague's device: nothing. I'm lost. It just doesn't make any sense.
     

    #6
    Caomhin likes this.
  8. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 8, 2021

    Caomhin , via OnePlus 6T , Mar 8, 2021 :
    Extremely strange. If it was device related I wonder why it accepts one caller and the others.

    I currently use the Google Phone as my default Dialler on my 6T, I have the OnePlus Dialler disabled, nothing wrong with OnePlus, just Google has a better feature set for my use.

    As a suggestion. Am wondering if you try something the following, even to test if it's the phone or OnePlus Dialler related, install the Google Dialler, Disable the OnePlus Dialler, (can be re-enabled at any point later.)

    Once Google Phone is installed and OnePlus Phone dialler is disabled, restart the phone, and then try the same steps you mentioned above on testing the incoming and outgoing calls calls.

    Let us know how that goes.
     

    #7
    Timmmmaaahh likes this.
  9. Timmmmaaahh
    Gingerbread Mar 15, 2021

    Timmmmaaahh , Mar 15, 2021 :
    Hey again :)

    I tried all combinations: stock alone, stock and Gdialer, Gdialer alone (did not try 'no dialer', lol). No change.

    I've now got in touch with the ISP of my employer and they have initiated testing the PRA-line we're on. They are currently analyzing the trace on the call from the device that isn't getting through to my mobile.

    In the meantime I've been logcatting a bit. I've narrowed the logs down to KeyguardUpdateMonitor that is showing interesting changes when my OP6T receives the call. See attachment. Best viewed in Notepad++ (it looks borked in regular Notepad), lines should be aligned properly. The time I'm being called is put between asterisk lines. Interesting changes:
    • mChannelNumber is switching from a steady 1599 to a whopping 2147483647 when the call comes in, then switches to 10836 for a bit, then 6400 and then back to 1599. I have no idea what this is but it's clearly an indication on my device that something odd is happening.
    • duplexMode switches to 0 during the call.
    • Radio is switching from LTE to HSPA (UMTS) and HSPA+ (UMTS), then back to LTE when the call is over.
    I should probably compare these to a successful call log but I'm throwing these out there already in case anyone has any insights so far. This type of data is far beyond my networking knowledge.
     

    Attached Files:


    #8
    Caomhin likes this.
  10. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 15, 2021

    Caomhin , via OnePlus 6T , Mar 15, 2021 :
    Yes definitely compare to a normal call. And do it from various callers, ordinary mobile to mobile, maybe a friend, and also from the office ext where you can receive a normal call, and also from a standard old Landline.

    It is possible something is being transmitted to your phone when the extension you have the issue with is calling you. As you mentioned it works fine from other extensions, just not the one line. So I would imagine that ext line is transmitting something other than voice. Another consideration, is the outbound Ext line a Voip line, which is basically transmitting a call as data.

    Just a thought, is the extension that you have issues receiving calls on being monitored in some way, and outgoing calls are transmitting something from the monitoring data or setup.? It then may be possible that the phone or Dialler security is having an issue dealing with that excess data from that number.

    If you know someone with another OnePlus phone or Google Dialler such as a Google Pixel phone, try that for comparison.
     

    #9
    Timmmmaaahh likes this.
  11. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 15, 2021

    Caomhin , via OnePlus 6T , Mar 15, 2021 :
    Reply wouldn't go through as a reply with text above, but check out the details of what I wrote.
     

    #10
    Timmmmaaahh likes this.
  12. Timmmmaaahh
    Gingerbread Mar 15, 2021

    Timmmmaaahh , Mar 15, 2021 :
    And so I did, this time filtered the log on KeyguardUpdateMonitor, see attachment (added a part from previous log for comparison, put between hashtag lines).

    Turns out the changes I found "interesting" are very much normal when a call is coming in. This means the call is in fact coming in, it's just not showing it to me. There are two extra lines though!
    When the phone is ringing:
    03-15 13:18:38.370 2327 2327 D KeyguardUpdateMonitor: handlePhoneStateChanged(RINGING)
    When the ringing stops:
    03-15 13:18:48.813 2327 2327 D KeyguardUpdateMonitor: handlePhoneStateChanged(IDLE)

    Note that the asterisks are my own estimation of when it starts and stops, which seems to be off quite a bit, especially the starting point.

    handlePhoneStateChanged or handlePhoneState for that matter cannot be found in the previous failure log.

    I've heard back from ISP testing. There's a "user-to-user" parameter enabled in the config on the "PABX" of my employer's phone system that is possibly interfering with the connection (could be OnePlus can't handle that). This sounds like something you described above so I think we're on the right track here.

    They sent me a partial screenshot of the routing:
    upload_2021-3-15_14-13-57.png

    Cable guy was in the early shift today so we'll try again with the parameter disabled tomorrow. To be continued...
     

    Attached Files:


    #11
  13. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 15, 2021

    Caomhin , via OnePlus 6T , Mar 15, 2021 :
    Just a note on this. As you have tried 2 diallers, OnePlus and Google, it's does not look like it's the dialler app itself. More like additional info being sent when the call is routed, you said it works fine from your extension but not from a colleagues. Even though they use PABX, you would expect all calls to not go through if they were routed exactly the same.

    I would suggest your colleagues phone is being rerouted either before or after the PABX before reaching your phone somehow, and the additional info included on the Call route is being rejected or stalled on security protocols somehow.

    Am guessing that a reroute would be caused by monitoring software or something similar. Either that or a physical cabling issue before or after the PABX.

    Just a thought.
     

    #12
    Timmmmaaahh likes this.
  14. Raza_Dawar
    Gingerbread Mar 15, 2021


    #13
  15. Timmmmaaahh
    Gingerbread Mar 17, 2021

    Timmmmaaahh , Mar 17, 2021 :
    @Caomhin I'll definitely pass that on to our network admin. The origin ISP has concluded the case. They gave me three potential next steps:
    • Check the user-to-user setting on PABX (I think they tested that yesterday as I got some test calls from cable guy).
    • Make a report with the supplier of your smartphone, "ONE PLUS - 6T". They had obviously never heard of the brand, lol. During one of our phone calls, after I had stated "it's a Oneplus", the rep asked me "Is that by Sony or...?" :D
    • Ask Mobile Vikings (my ISP) to trace and analyze the call.
    I guess I can give 1+ support a go as well.

    @Raza_Dawar I'm having this issue in Belgium.
     

    #14
    Caomhin likes this.
  16. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 17, 2021

    Caomhin , via OnePlus 6T , Mar 17, 2021 :
    It's a lot of work for one extension, but as you say, all other extensions work fine through the PABX. I am kind of leaning towards something peculiar going on with the extension. It would be my focus to see if there is some difference in either hardware, cabling or software on that extension. 👍
     

    #15
    Timmmmaaahh likes this.
  17. Timmmmaaahh
    Gingerbread Mar 18, 2021

    Timmmmaaahh , Mar 18, 2021 :
    Well, as both my colleague and I have the same Dect device I'm guessing we can rule out hardware, at least on our end. His extension starts with '33' and mine starts with '24' so the culprit might be found in that area. I know the first two numbers of our extensions can mean a different routing. Eg. extensions starting with '99' cannot call externally.
    I've reached out to 1+ but so far I only got "try resetting to factory settings" 🙄
     

    #16
    Caomhin likes this.
  18. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 18, 2021

    Caomhin , via OnePlus 6T , Mar 18, 2021 :
    As you say possibly the routing. It would be very hard to pin down if it's a phone issue, particularly when all other calls work and just one line can't get through. Do let us know how it works out. 👍
     

    #17
    Timmmmaaahh likes this.
  19. Caomhin
    OnePlus 9 Series Expert Community Expert Mar 22, 2021

    Caomhin , via OnePlus 6T , Mar 22, 2021 :
    You're welcome 😎👍. Great to hear you got to the bottom of the issue and finally located the root cause to solve it. This will help anyone else with just such an issue.
     

    #19
    Timmmmaaahh likes this.