1
Pixel Buds not working correctly after Android 12 update via OnePlus 9

  1. RickyBO89
    Eclair Jan 24, 2022

    RickyBO89 , via OnePlus 9 , Jan 24, 2022 :
    Hi, I've recently updated my OnePlus 9 to the latest Android 12 release (C.44) via OTA.
    After the update I'm having issues with my Pixel Buds, like they're not completely recognized by the system. Their companion app constantly shows them as "Disconnected" (see the attached screenshot) and some of the touch features of the earphones don't work, specifically the swipe up/down for increasing/lowering the volume.

    I've already tried to unpair and pair again but I had no luck.
    Am I the only one with this issue?

    Thanks!
    1643015676366.jpg
     

    #1
    elyal likes this.
  2. Caomhin
    9 Series Expert, Participator of the Year Community Expert Jan 24, 2022


    #2
    RickyBO89 and Aaron2017 like this.
  3. RickyBO89
    Eclair Jan 24, 2022

    RickyBO89 , via OnePlus 9 , Jan 24, 2022 :
    Hi, thank you for your help.
    I tried your suggestion but sadly it didn't work out: the app still isn't able to recognize when the buds are connected. The pairing too is quite problematic and doesn't complete flawlessly as when I did it with Android 11. Seems to me like something is not working correctly with the Google Services Framework...
     

    #3
  4. Caomhin
    9 Series Expert, Participator of the Year Community Expert Jan 24, 2022

    Caomhin , via OnePlus 9 Pro , Jan 24, 2022 :
    It's possible there is a glitch in the system somewhere. Other than backing up the phone and doing a full Erase All Data factory reset to refresh your current installation of OOS on the phone. As per XDA recommendation.
    https://www.xda-developers.com/factory-reset-oneplus-9-series-improve-experience-oxygenos-12/amp/

    You may need to give Feedback on the issues back to the OnePlus OOS developers. So that they can investigate them. Thank you.
    https://forums.oneplus.com/feedback/
     

    #4
    RickyBO89 likes this.
  5. RickyBO89
    Eclair Jan 24, 2022

    RickyBO89 , via OnePlus 9 , Jan 24, 2022 :
    Feedback sent.
    I'm not a huge fan of factory resets, so I'd like to try and wait for another solution. Thanks anyway!
     

    #5
    Caomhin likes this.
  6. igoralcada
    Donut Jan 28, 2022

    igoralcada , Jan 28, 2022 :
    So, I'm not the only one.

    I factory reset phone, factory reset Buds, still nothing.
    Tried another OnePlus 9 with Android 12, issue is the same.
    Meanwhile, tried my older phone (Samsung) with Android 9, all work fine.

    Already in touch with Pixel Buds support.

    So:
    1. Bluetooth display them as connected, we can check each buds battery and case battery;
    2. But Google Assistant settings for the Buds, under "information", say's they are connected;
    3. They work fine, touch, calls, everything;
    4. It's just the Buds app, on Android 12 (C.44) that show them as Disconnected and we can't change any settings or check firmware (says "0"), and can't go through the tutorial, displays a blank page;
    5. Android 9 older phone, all is fine and working 100%.
    6. Everything is more than up-to-date.
    7. Nearby Devices are allowed.

    Don't have any other Android 12 phone from other brand to try it out.

    Let me know if we have some update, or there's a solution.
    Seems to be app-related.
     

    #6
    corravec likes this.
  7. RickyBO89
    Eclair Feb 1, 2022


    #7
    igoralcada likes this.
  8. philidor
    Gingerbread Feb 2, 2022

    philidor , Feb 2, 2022 :
    I solved the problem by
    1) unpairing and resetting the buds
    2) removing the app and installing a older one (com.google.android.apps.wearables.maestro.companion_1.0.390955707-10066411_minAPI23(arm64-v8a)(nodpi)_apkmirror.com.apk)
    3) reconnecting the buds.

    It work again with old app
     

    Attached Files:


    #8
    W1586385925580 and RickyBO89 like this.
  9. RickyBO89
    Eclair Feb 2, 2022

    RickyBO89 , via OnePlus 9 , Feb 2, 2022 :
    It worked! 😀
     

    #9
  10. igoralcada
    Donut Mar 18, 2022


    #10
    RickyBO89 likes this.
  11. elyal
    Donut Apr 21, 2022


    #11
    corravec likes this.
  12. igoralcada
    Donut Apr 30, 2022

    igoralcada , via OnePlus 9 Pro , Apr 30, 2022 :
    So, I'm checking that more people are getting the same issue after android 12, and also at the Play Store reviews. It's been around 6 months, no update from Google or OnePlus...

    I noticed something though, if I'm quick enough, I can toggle the settings, but a second later, and I'm not able again...
     

    #12
  13. W1586385925580
    Eclair May 17, 2022 at 7:26 AM

    W1586385925580 , May 17, 2022 at 7:26 AM :

    This works - it has to be that version of the pixel bud app

    I have set the app not not auto update in the playstore
     

    #13