0
Play store shows downloading but does not download

  1. ajaykd
    Froyo Jan 7, 2015

    ajaykd , Jan 7, 2015 :
    Hi,

    This is quite a strange problem I have on OPO. For last few days, it does not download anything from play store. When I click to update or download any app from play store, it only shows downloading... but it never downloads and complete. Any idea what to do? I have already uninstalled updates to google play store, cleared the cache and data but in vein. Any help will be much appreciated.
     

    #1
  2. vjinhome
    Cupcake Jan 9, 2015

    vjinhome , Jan 9, 2015 :
    I am also facing the same issue..

    i recently purchased oneplus.., i am not able to download any application from Google play store..

    while trying to download any app through google play, for instance, skype, it is just showing downloading.., but it is never getting downloaded..,

    I have already contacted to the customer support and as per their suggestion, i did the factory reset also.., but still the issue is there...

    Thanks in advance for the suggestions to resolve the issue
     

    #2
    ajaykd likes this.
  3. SSCyanogen
    Honeycomb Jan 9, 2015

    SSCyanogen , Jan 9, 2015 :
    Go to Settings
    Go to Security
    Check the box for Unknown Sources.
    Give that a try. Hope it works. Let us know if it does.
     

    #3
    ramsabi likes this.
  4. ramsabi
    Jelly Bean Jan 9, 2015


    #4
    santosh kareena and r6174 like this.
  5. aravindsbabu
    Gingerbread Jan 9, 2015


    #5
  6. RachitMishra
    Cupcake Jan 9, 2015

    RachitMishra , Jan 9, 2015 :
    i am having the same problem.
    it says error 495.
    i tried all the suggestions given online but still nothing helped :(
     

    #6
  7. jain.visky
    Cupcake Jan 9, 2015


    #7
  8. dulila
    Gingerbread Jan 9, 2015

    dulila , Jan 9, 2015 :
    I had issue that play store didn't update.... Pop ups about Google plus kept appearing continuously and couldnt use phone. after factory reset it updated 3rd attempt and is fine now.
    UK, not India.
     

    #8
  9. ramcon12
    Gingerbread Jan 9, 2015

    ramcon12 , Jan 9, 2015 :
    Have the same problem. If you try to update many apps at the same time it is better if you update each one individually. If it us only one app what I do is kill the play store then reset wifi/3g/lte, then try to update again.
     

    #9
  10. RachitMishra
    Cupcake Jan 9, 2015


    #10
  11. manishgupta
    Cupcake Jan 10, 2015


    #11
    ajaykd likes this.
  12. ajaykd
    Froyo Jan 10, 2015

    ajaykd , Jan 10, 2015 :
    Thanks guys for your replies. I saw lots of interesting replies here. Few indicated this belongs to India few suggesting to switch to WEP in security etc. I think this problem is quite often found when you try to tweek settings and don't know what is it going to affect. So there is no common solution for it. For few it may be resolved by clearing the cache and data for Google Play Store and Google Play Services while for few it may be by uninstalling the Goolge Play Store last update. So in my case I found that I somehow turned off the Google Location Detection. So here it is how it works. Google play store determines your location and based on location it allows apps and other services to get downloaded. Since it was not able to detect phone location (aka country) hence it goes to the step where it starts downloading but since it is not able to detect the location, hence it does not start downloads and shows only downloading. I hope this finding will help to others who are facing the same problem. Turn on the location for Google play store / services and it should be ready to go from there. Thanks all...
     

    #12
    ramsabi likes this.
  13. aruncvl
    Cupcake Jan 12, 2015

    aruncvl , Jan 12, 2015 :
    same problem for me too
     

    #13
  14. aruncvl
    Cupcake Jan 12, 2015


    #14
  15. jadecolour
    Ice Cream Sandwich Jan 12, 2015

    jadecolour , Jan 12, 2015 :
    I have a similar issue all the time with OPO, it always stuck at first attempt to download an update APK, then somehow tens of seconds later it will retry and (always) succeed at the 2nd attempt. My Nexus 7 (2012) had the same issue when I was on Stock Android 4.4.4. When I wiped my Nexus 7 and installed PA, the issue disappeared.

    However, the issue on OPO persists. I doubt this is a CM software issue. More like a Google Play application issue.
     

    #15
  16. WillL
    Ice Cream Sandwich Jan 12, 2015

    WillL , Jan 12, 2015 :
    I had some problems with the store shortly after getting my OPO. It was something to do with synching my account if I remember correctly (I logged in using my daughter's google account and could download stuff). Make sure the synch tile is always white (i.e. enabled). Also try just going into your accounts and making the google account re-synch.
     

    #16
  17. MackTheTaylor
    Honeycomb Jan 12, 2015

    MackTheTaylor , Jan 12, 2015 :
    No that isn't the issue. If it's the play store then it isn't an unknown source
     

    #17
    ramsabi likes this.
  18. MackTheTaylor
    Honeycomb Jan 12, 2015

    MackTheTaylor , Jan 12, 2015 :
    When in doubt, reboot
    If still in doubt, reflash system
     

    #18
  19. ramsabi
    Jelly Bean Jan 12, 2015


    #19
  20. WillL
    Ice Cream Sandwich Jan 12, 2015

    WillL , Jan 12, 2015 :
    That is a very extreme solution which has no guarantee. If it is only people in India we may need OP to comment. Otherwise, probably an account issue.
     

    #20