Playing gallery videos - non default player

  1. markgranto
    Honeycomb Oct 24, 2014

    markgranto , Oct 24, 2014 :
    Is there anyway for playing the videos in the gallery in another media player by default other than the build in one, I have mx player installed and would like for the videos ive played in the gallery to play in that but if you click on the video in the gallery it just opens right up with no option as to what plays it. Searched the forum and have a found a few people asking but no one able to answer.

    Checked in the app info for gallery and mx player and cleared 'launch as default' but still just plays in the default app.
    Last edited: Oct 24, 2014

  2. markgranto
    Honeycomb Oct 24, 2014

  3. Pradeep.110391
    Cupcake Jan 8, 2015

    Pradeep.110391 , Jan 8, 2015 :
    I am also having the same problem... Someone please advise.
    I am not able to change the default video player. I am playing the videos from gallery. Installed MX player to play videos, but not able to use it :(

  4. stephenlotus
    KitKat Jan 8, 2015

    stephenlotus , Jan 8, 2015 :
    i think you just have to keep using it...
    after a couple days it only played using mx player.
    it should ask you to choose, though...

  5. CoolFX
    Donut Feb 24, 2015

    CoolFX , Feb 24, 2015 :
    Anyone?? I have the same problem... Just bought the MXplayer Pro and I still have to use the default video player on gallery. This is really strange! Where is the default video player on settings/apps?? Can't find it...

  6. lokesh3440
    Honeycomb Feb 24, 2015

    lokesh3440 , Feb 24, 2015 :
    If you open a video from Gallery,it will always open in default video player.Can you guys try my way ?
    1) Open ES Explorer or any file manager you use.
    2) Open video,it should prompt you to choose and there will be a checkbox to set is as default.

  7. Syam Sailendran
    Froyo Feb 24, 2015

    Syam Sailendran , Feb 24, 2015 :
    may be you choose to use the default player all the time while playing from gallery. If you have multiple players installed the OS will ask you to choose a player to play the video "just once" or "Always".. you might have choose the default player and choose always..now you need to reset the defaults from apps settings

  8. CoolFX
    Donut Feb 24, 2015

    CoolFX , Feb 24, 2015 :
    Just tried the ESExplorer solution, but it didn't work. It did asked me what player I wanted to play the file. I checked the box to make MXplayer the default player. But when I go back to the gallery it opens the movies with the default player. It must be a cyanogenmod default setting and maybe we can't gange the default video player inside the gallery app.

  9. Joydipta Banerjee
    Cupcake Mar 3, 2015

    Joydipta Banerjee , Mar 3, 2015 :
    Same problem faced by me. Its only when videos are played from 'gallary', it is choosing a program on its own (ignoring default player chosen by the user). When same video is played from file manager, it is following the default video player (VLC for my case). A definite bug in cynogenmod.

  10. trano
    Gingerbread Mar 5, 2015

    trano , Mar 5, 2015 :
    go to app info of your current default gallery then click remove defaults. your opo should then ask what app you want defaulted to view videos after you select a video file

  11. Cobrin
    Ice Cream Sandwich Mar 5, 2015

    Cobrin , Mar 5, 2015 :
    you could also kick the default gallery to the curb and install QuickPic instead. Super fast, feature rich, reliable and no privacy concern issues.

    will do as required and will be enjoyed when you tweak it to display only what folders you want.

    Gets an A+++ from me.

  12. mmediadev
    Jelly Bean Mar 5, 2015

    mmediadev , Mar 5, 2015 :
    Correct me if I am wrong but it seems to me that you have opened Videolan media player, and while using its built-in file browser, you want VLC to open the file on a different program.

    This works, if you are not already inside the media player program before attempting to open the files on a separate program to begin with.

    It is the reason why browsing and attempting to open a file with any media explorer will result in a list of options to open the file with.

  13. akshansh2000
    Honeycomb Mar 5, 2015

    akshansh2000 , Mar 5, 2015 :

    Use a third party gallery so and disable the stock one... Like quikpic..... Whenever you would play a video, it would ask you which player to use!!

    D3utschL4ND likes this.
  14. D3utschL4ND
    Froyo Mar 5, 2015

    D3utschL4ND , Mar 5, 2015 :
    He must have found his answer since he asked back in October lol. :mad: And no solution to tell us

    akshansh2000 likes this.
  15. akshansh2000
    Honeycomb Mar 5, 2015

    akshansh2000 , Mar 5, 2015 :
    Oops didn't see... Thanks:p

    D3utschL4ND likes this.