0
Please help! My phone got locked by CM Locker

  1. aluzcz
    Gingerbread Aug 28, 2015

    aluzcz , Aug 28, 2015 :
    Hi,

    recently i was experiencing issues with calls to the emergency numbers from my pocket so i decided to install new lock screen, my pick was CM Locker as recommended one of the best lock screen apps.
    After the installation and granting the admin rights to the CM Locker i briefly configed the app - set my 4 digit pin and then i turned the screen off for the first time to test it.

    The horror after i turned the screen on and the old lock screen was still there so i put my old pin to my old lock screen which gone away but the CML screen appeared so i entered the pin(same one) again but nothing is happening CML is not recognizing the password/pin i set, tried to restart the phone tried nearly everything in the gui but nothing is working looks like the security of the CML is solid :( unfortunetly for me.

    Fortunetly i have shell access thru 3rd party app(Carebarous security) and im able to connect to the phone from the emulated shell terminal from their site but since i dont have root enabled i cant do nearly anything useful like killing the com.cmcm.locker processes, adb uninstall is also not working.

    Any idea or suggestion how to get back into the phone? I don't want to lose all my data and because i have 64gb version i have plenty of them :( I have some backups but not a recent ones.
     

    #1
  2. aaqibismail
    Honeycomb Aug 28, 2015


    #2
  3. aluzcz
    Gingerbread Aug 28, 2015

    aluzcz , Aug 28, 2015 :
    Well the issue with this one is that i will loose all the data on the phone :(. I currently have the official CM12 and in the recovery the option you are suggesting is Wipe data/factory reset, which is my last resort.

    Any idea how to at least backup the data?
     

    #3
  4. aaqibismail
    Honeycomb Aug 28, 2015

    aaqibismail , Aug 28, 2015 :
    When your on lockscreen connect phone to computer and I your internal storage should pop up
     

    #4
  5. rgs
    Jelly Bean Aug 28, 2015


    #5
  6. aluzcz
    Gingerbread Aug 28, 2015

    aluzcz , Aug 28, 2015 :
    Yes i thought so, but the CML is blocking that as well :( so i cant connect the storage and backup my data :(
     

    #6
  7. AmelieA
    Ice Cream Sandwich Aug 28, 2015

    AmelieA , Aug 28, 2015 :
    Did you tried to remove the app from your computer (using the playStore website) ?
     

    #7
  8. MinecoFone
    Froyo Aug 28, 2015

    MinecoFone , Aug 28, 2015 :
    Some model phones allow you to reset your phone to factory setting by pressing power button and volume button at the same time for a few seconds if you can't even turn the phone on. :D
     

    #8
  9. aluzcz
    Gingerbread Aug 28, 2015

    aluzcz , Aug 28, 2015 :
    Call me the king!

    Even without the root access i managed to get rid of this crap! With soft restart it takes a while for this cr-app to load with the help of my remote shell access i was able to utilize the cpu as much *** possible that i was able to remove the app in the gui in the mean time before it got locked.

    ufffff time for backup!
     

    #9
    Indus and bussola99 like this.
  10. aluzcz
    Gingerbread Aug 28, 2015

    aluzcz , Aug 28, 2015 :
    My first idea but no luck from there.
     

    #10
  11. Tarfex
    Ice Cream Sandwich Aug 28, 2015

    Tarfex , Aug 28, 2015 :
    You were supposed to disable your lockscreen and then enable it so it doesn't mess up. But since you can't open it...I'm not sure maybe reset? Or try putting in the pin see if it works
     

    #11
  12. nirajmopari
    Gingerbread Aug 28, 2015


    #12
  13. aaqibismail
    Honeycomb Aug 28, 2015


    #13
  14. Me1256
    KitKat Aug 28, 2015

    Me1256 , Aug 28, 2015 :
    I'm pretty sure all you have to do is wipe the cache partition. You shouldn't lose any data, apart from some apps, which you can reinstall anyways.
     

    #14
  15. Spectre_Nine
    Honeycomb Aug 28, 2015


    #15
  16. alexl83
    Gingerbread Aug 28, 2015


    #16