117
Poor battery within the past 1/2 days - There IS a reason. Here's the fix!

  1. oscarvanl
    Jelly Bean Mar 1, 2015

    oscarvanl , Mar 1, 2015 :
    EDIT: THIS IS RESOLVED IN THE LATEST SYSTEM UPDATE, DOWNLOAD THAT!


    Have you noticed that battery has been poorer beginning in the past 1/2 days? That's not a coincidence.

    The new Google Play Services update is slowly rolling out to all Android devices, it happens in the background without you knowing and it occurs over the course of a week (so you might not have been hit yet - But you will be).

    This update has a flaw with devices running a custom ROM (eg CyanogenMod) where it keeps checking for updates (Specifically, the SystemUpdateService keeps the device awake), and thus using battery up very fast.

    How to check if you are affected by this or not:
    Use your phone for a day as normal, when it has been used for a decent amount of time do the following...
    1. Go to settings and tap on battery.
    2. In the battery menu, look for "Google Services" - If this is using a high portion of battery then you are probably affected by the bug, if you tap on it and look at CPU total and it is more than an hour then something is definitely wrong and you are likely affected.

    Here's the temporary fix if you are affected: (NON ROOT ONLY)
    1. Go to settings and press Privacy
    2. Press on Privacy Guard
    3. Press the Menu key and then tap on advanced
    4. Go to the Device tab and tap Google Play Services
    5. Scroll to "Keep Awake" and change it to "Denied"
    6. Close the menu, you are done!
    Note: I've heard from some that this needs to be repeated after a reboot, but for others it stays, keep an eye on the setting.

    This issue has occurred before in the past with the 25R update (A long time ago at the device launch but was fixed by a CyanogenMod update, but it affected devices for weeks before it was fixed.)

    Here's the fix if you are rooted: (ROOT ONLY)
    This fix is better because it actually fixes the real issue, rather than just blocking Google Play Services from waking your device up. It also survives reboots.
    1. Download the "Disable Service" app from the Play Store.
    2. Open and go to the "System" tab.
    3. Scroll and find Google Play Services and tap on it.
    4. Check "System Update Service" (Yes, I know checking it seems counter intuitive but do it anyway)
    5. Done!
    Note: Unfortunately this will not survive a reboot. You will need to redo this after reboots.

    IMPORTANT MESSAGE:
    If you have applied these settings and notice crashes or issues you didn't experience before, follow the same steps you did before but change the Google Play Services Keep Awake setting to Allowed again.
     
    Last edited: Aug 17, 2015

    #1
    RikoMMXV, mmalde, Charabia and 114 others like this.
  2. dblack84
    Gingerbread Mar 4, 2015

    dblack84 , Mar 4, 2015 :
    This new google play services 7.0 is a battery drainer at least this is my experience since i have updated last night . It doesn't let my phone go in deep sleep, it keeps it awake the whole time. wiped cache, dalvik cache didn't help. I had to change "keep awake" to Denied in Privacy settings . Anyone else having similar issue?
     

    #2
  3. Zachsaxe
    Lollipop Mar 4, 2015

    Zachsaxe , Mar 4, 2015 :
    I think you can turn background data off
     

    #3
    tomgha, burridm and ashutoshmn like this.
  4. ashutoshmn
    Ice Cream Sandwich Mar 4, 2015

    ashutoshmn , Mar 4, 2015 :
    does that option work for wifi too or just mobile data?
     

    #4
  5. Zachsaxe
    Lollipop Mar 4, 2015

    Zachsaxe , Mar 4, 2015 :
    I'm not sure there may be a way let me see
     

    #5
    caratoss likes this.
  6. Zachsaxe
    Lollipop Mar 4, 2015

    Zachsaxe , Mar 4, 2015 :
    Oh I think I know I have snapdragon battery guru and it can restrict apps from refresh rate
     

    #6
  7. DaxNagtegaal
    Marshmallow Mar 4, 2015


    #7
    km00, cxlhere, armannp and 8 others like this.
  8. CrownedSusanoo
    Honeycomb Mar 4, 2015

    CrownedSusanoo , Mar 4, 2015 :
    That shouldn't really be an issuemi think. But i personally would love a portable charger. Like a rechargeable case or something. I'm gonn getnthis phone so sexifies!
     

    #8
  9. jwinckelmann
    Eclair Mar 5, 2015

    jwinckelmann , Mar 5, 2015 :
    Same problem here, there is a wakelock on Systemupdateservice. I had to revert to the old services...
     

    #9
  10. Gamm86
    Jelly Bean Mar 5, 2015

    Gamm86 , Mar 5, 2015 :
    This!
     

    #10
    Thedulli likes this.
  11. grumfrommarch
    Honeycomb Mar 5, 2015


    #11
  12. smaug42
    Jelly Bean Mar 5, 2015

    smaug42 , Mar 5, 2015 :
    Just checked my setup... Denied 1,924,496 times since 18.09.14. Almost 2 million times it's been denied... yikes
     

    #12
    Joe de pro, aniketk1, Da Bozz and 6 others like this.
  13. zepphead
    Lollipop Mar 5, 2015

    zepphead , Mar 5, 2015 :
    Ha ha ha ... sounds like a familiar story!!;)
     

    #13
    Artur Deus, Wuhfel and House_Maniac like this.
  14. zepphead
    Lollipop Mar 5, 2015


    #14
  15. fenice
    KitKat Mar 5, 2015

    fenice , Mar 5, 2015 :
    Everybody should always do this. :)

    Why did you not deny it using Privacy Guard?
     

    #15
    nakeeb likes this.
  16. DaxNagtegaal
    Marshmallow Mar 5, 2015

    DaxNagtegaal , Mar 5, 2015 :
    Yup it's horrible
     

    #16
    smaug42 likes this.
  17. jimzorba
    Cupcake Mar 5, 2015

    jimzorba , Mar 5, 2015 :
    What is the typical battery life for the 64GB version when email push is used? I have a Z10 Blackberry and it is awful
     

    #17
  18. ashutoshmn
    Ice Cream Sandwich Mar 5, 2015

    ashutoshmn , Mar 5, 2015 :
    Never used email push so can't tell
     

    #18
  19. Gamm86
    Jelly Bean Mar 5, 2015

    Gamm86 , Mar 5, 2015 :
    All depends on usage. Noone will be able to give you a correct answer.
     

    #19
  20. phonehog
    Ice Cream Sandwich Mar 5, 2015

    phonehog , Mar 5, 2015 :
    I think another big hidden drainer is Google App.
    I see it moving in the background there under the Pivacy Guard.
    I haven't put a Deny on it yet but it seems to wakup or stays awake but doesn't stick out as say Play Services.

    Also - recently I noticed my battery drained a bit more after I put Services Framework on deny wakeup & keep awake.

    Thoughts?
     

    #20
    FlyErik and caratoss like this.