1
Popup msg : The default country/region code has been changed to +91 via OnePlus 7T

  1. G_GIRISH_G_nqJW
    Cupcake Oct 20, 2019

    G_GIRISH_G_nqJW , via OnePlus 7T , Oct 20, 2019 :
    1571542322360.jpg
    I am getting a popup message often while using both mobile network and WiFi.I bought this oneplus 7T device a month ago. Can anyone suggest me how to resolve this issue.
     

    #1
    S1571549370992 likes this.
  2. S1571549370992
    Cupcake Oct 20, 2019


    #2
    E1570008488656 likes this.
  3. JS.naidu
    Cupcake Oct 21, 2019

    JS.naidu , Oct 21, 2019 :
    yes i am also having the same problem.Its really annoying.Can anyone give a proper solution for this?!
     

    #3
    E1570008488656 likes this.
  4. Horsault
    Nougat Moderator Oct 21, 2019

    Horsault , Oct 21, 2019 :
    +91 is country code for India.
    Maybe you flashed a ROM which wasn't intended for your region.
    North-America, Europe, India and China have specific ROMs which shouldn't be installed in other regions if one doesn't want to risk strange behavior.
     

    #4
  5. guanyu210379
    Jelly Bean Oct 21, 2019

    guanyu210379 , Oct 21, 2019 :
    The question is more like, what kind of update did you have? OTA?
    If this is from OTA, Oneplus must fix this!
     

    #5
  6. dhadauzair
    Cupcake Oct 25, 2019


    #6
  7. Tejas_Ashok
    Eclair Nov 1, 2019

    Tejas_Ashok , via OnePlus 7 , Nov 1, 2019 :
    You flashed the correct rom. Go to Phone>settings>assisted dialing then switch off add country/region code automatically. That should fix the problem.
     

    #7
  8. V1572067810506
    Cupcake Nov 5, 2019

    V1572067810506 , Nov 5, 2019 :
    I knew I enabled this but I couldn't find this setting again to disable it. Thanks so much for the help.
     

    #8
    Tejas_Ashok likes this.
  9. C1573504085866
    Cupcake Nov 12, 2019


    #9
  10. Kashish0110
    Cupcake Nov 13, 2019


    #10
  11. One+Vikrant
    Cupcake Dec 13, 2019


    #11
  12. Tejas_Ashok
    Eclair Dec 16, 2019

    Tejas_Ashok , via OnePlus 7 , Dec 16, 2019 :
    This
     

    #12
    One+Vikrant likes this.
  13. Abhilash_PM
    Froyo Dec 16, 2019

    Abhilash_PM , Dec 16, 2019 :
    You may try disabling Assisted dialing option in the Phone Settings:
    1. Open your 'Phone' App (The one where you make your phone calls from)
    2. Touch on the three dots on the top right corner and select 'Settings'
    3. Select 'Assisted dialing'
    4. Disable 'Add country/region code automatically'
     

    #13
    H1570845317717 likes this.
  14. F1562243165122
    Cupcake Dec 19, 2019

    F1562243165122 , Dec 19, 2019 :
    same issue with my device also. from the date it OS got update it pops up the same msg. which is bit annoying. hope it will get a quick solution from #OnePlus team.
    I am attaching a image for reference.
    1576730775512.jpg
     

    Attached Files:


    #14
  15. Abhilash_PM
    Froyo Dec 19, 2019


    #15
  16. One+Vikrant
    Cupcake Jan 7, 2020


    #16
    Tejas_Ashok likes this.
  17. One+Vikrant
    Cupcake Jan 7, 2020


    #17
  18. Rahul Sapparapu
    Cupcake Jul 5, 2020

    Rahul Sapparapu , via OnePlus 8 , Jul 5, 2020 :
    I have faced the same problem with one plus 8. This happens when you accidentally select the option in phone (call) settings while setting up your phone for the first time. When your phone is roaming it helps you directly set the country code (wherever you are). But its annoying when there are so many popup notifications. To remove it follow the below steps:

    1. Open the "phone" app (The one we use to make calls and check contacts).
    2. In the top right corner you find three dots, click on it and select "settings".
    3. After entering settings, under "calls" section there will be an option called "Assisted Dialing". Click on it.
    4. Now uncheck/disable the option of "Add country/region code automatically".
    5. Done!
     

    #18