1
[Answered] private dns

  1. DickyBrojangles
    Cupcake Jan 16, 2019

    DickyBrojangles , Jan 16, 2019 :
    Private DNS no longer functions. Already had it set to Cloudfare during beta 2 update, could not connect. Tried Google DNS, same result. Steps required to reproduce: attempt to set private DNS to dns.google on OnePlus 6T with beta 2 installed. Unlocked 6T purchased from OnePlus website on Verizon.
     

    Attached Files:


    #1
    irinelturturea likes this.
  2. Jeff H.
    OnePlus Bug Hunter OnePlus Bug Hunter Jan 16, 2019

    Jeff H. , Jan 16, 2019 :
    Hi DickyBrojangles,

    Greetings. This is Jeff from OnePlus Bug Hunters Team, thanks for your feedback.

    As we confirmed that this issue will be fixed in the next update, and for this temporary we suggest you disabling Private DNS first.

    Thank you and have a nice day.

    High regards,
    OnePlus Bug Hunters
     
    Last edited: Jan 17, 2019

    #2
  3. DickyBrojangles
    Cupcake Jan 16, 2019


    #3
  4. walterkt
    Cupcake Jan 16, 2019

    Last edited: Jan 16, 2019

    #4
  5. DickyBrojangles
    Cupcake Jan 18, 2019


    #5
  6. walterkt
    Cupcake Feb 14, 2019


    #6
  7. cruzAD
    Gingerbread Jul 6, 2019

    cruzAD , Jul 6, 2019 :
    Not only on beta.
    Now july 07, and the private DNS doesn't work completely, there are constant connection problems, regardless of the DoT servers.
     

    #7
  8. mike_krb
    Gingerbread Jul 7, 2019

    mike_krb , Jul 7, 2019 :
    If you have a strict firewall on the network you are using, note that DNS over TLS require tcp port 853 open.
     

    #8
  9. Anoojprabhu
    Eclair Jul 13, 2019


    #9
  10. cruzAD
    Gingerbread Jul 24, 2019

    cruzAD , Jul 24, 2019 :
    It is not working properly anywhere. There is obviously, seemingly no will to fix it.
     

    #10
  11. cruzAD
    Gingerbread Jul 30, 2019

    cruzAD , Jul 30, 2019 :
    But it was not fixed in the "next update", nor in the next update to that, nor in the next update, nor in the next.... Do you ever want to fix it? It seems you dont...
     

    #11
  12. mike_krb
    Gingerbread Aug 18, 2019

    mike_krb , Aug 18, 2019 :
    I'm using https://securedns.eu/ w/ DOT and it connects fine, however for DNS over TLS I needed to adjust my outgoing firewall to allow tcp/853. DNS over HTTPS, DOH, is using 443 so that shouldn't cause any such issues.
     

    #12
  13. cruzAD
    Gingerbread Aug 18, 2019

    cruzAD , Aug 18, 2019 :
    Dont you get sooner or later, after a half hour or so, at least few hours "Couldn't connect" error message, and concret connection problems. The two not always come together. Sometimes it shows Couldn't connect, but the connection is ok, but rather sooner than later the actual connection problem comes s also. I tried a whole list of servers. Some performs better, some is worse, but everyone having the problem. But not in my PC, I use cloudflare on my PC, sometimes Quad9, never had problems, but in Android 9 it comes very soon. I use mobile net, there is no firewall. I can't believe it works for you well, you simple did not noticed it.
     

    #13
  14. cruzAD
    Gingerbread Aug 18, 2019

    cruzAD , Aug 18, 2019 :
    there are a whole list of servers, I tried everyone, and besides that, it is a KNOWN bug.

    Maybe the best worked me with the less problem is:

    Minimal log. (volume) :
    Surfnet (853, 443) :
    dnsovertls.sinodun.com
    dnsovertls1.sinodun.com

    dnsovertls3.sinodun.com
    dnsovertls2.sinodun.com
     

    #14
  15. cruzAD
    Gingerbread Aug 18, 2019

    cruzAD , Aug 18, 2019 :
    Test your connection with Speedtest.net or with whatever app, no way your connections quality stays good
     

    #15
  16. mike_krb
    Gingerbread Aug 18, 2019

    mike_krb , Aug 18, 2019 :
    hm.. maybe I'm missing something here.. but why would my connection speed be worse, once it resolve the dns name the app, thru android, should connect using the ip and probably cache it for some time.

    I tried resolving some local dns entries I have and that does not work, of course, with privatedns enabled. continuously.

    When switching between privatedns off and on I had to choose quit in the browser, if not it seemed to use the cached ip without resolving it again.
     

    #16
    cruzAD likes this.