0
problem with Google sync

  1. Ramdinpuia
    Honeycomb May 9, 2017

    Ramdinpuia , May 9, 2017 :
    Where isn't there individual options to sync to Google Chrome, contacts, fit, app data etc etc. Now looks like if one has to sync, one has to sync all of them under Google account. There should be individual option to sync only one as per user's need. Is this part of oxygenOS or Google
     

    #1
  2. Dunnow
    The Lab - OnePlus 6 Reviewer May 9, 2017

    Dunnow , May 9, 2017 :
    you can select whatever you want to sync in your google account through the "accounts" section in "settings app"
     

    #2
    DrAakash and varma246 like this.
  3. Dresa91
    User of the Year 2016; Most Active User 2020 May 9, 2017

    Dresa91 , May 9, 2017 :
    Go to settings - accounts -> select Google. There you can untick for example Google fit
     

    #3
    DrAakash, varma246 and ssiinnaahh like this.
  4. elanglois
    Lollipop May 9, 2017


    #4
    DrAakash and Dresa91 like this.
  5. Dresa91
    User of the Year 2016; Most Active User 2020 May 9, 2017


    #5
  6. Ramdinpuia
    Honeycomb May 9, 2017

    Ramdinpuia , May 9, 2017 :
    1494337359004.jpg
    Untick where?
     

    #6
    jvaldivia likes this.
  7. Ramdinpuia
    Honeycomb May 9, 2017


    #7
  8. Ramdinpuia
    Honeycomb May 9, 2017


    #8
  9. jvaldivia
    Cupcake Jul 19, 2017

    jvaldivia , Jul 19, 2017 :
    I'm having the same problem, looks like the option was removed I cannot select sync on google accounts, this is really frustrating!
     

    #9
  10. Ramdinpuia
    Honeycomb Jul 20, 2017

    Ramdinpuia , Jul 20, 2017 :
    I really respect you @elanglois
    I really thought you would know this.
    I found my answers after a long trial and error on my new honor 8. And works on my 3T.

    I found the solution.
    This is a problem in many Android phones.
    The problem lies in a program called Google contacts sync.
    In some forums, the app was disabled and in some, no apparent anomaly.
    Now, downloading an Apk and reinstalling may work.
    What worked for me and what I recommend is,
    settings>apps>show system apps>Google Contact Sync>

    Here, force stop the app.
    Clear data under storage and RESTART
     

    #10
  11. Ramdinpuia
    Honeycomb Jul 20, 2017

    Ramdinpuia , Jul 20, 2017 :
    I have solved it.
    Try the solution I posted.
    Let me know your progress
     

    #11
  12. Ramdinpuia
    Honeycomb Jul 20, 2017

    Ramdinpuia , Jul 20, 2017 :
    You got 3 likes from people ignorant of the problem. Many forums are flooded with this problem.
    I have now since solved it.
    Just informing
     

    #12
  13. elanglois
    Lollipop Jul 20, 2017

    elanglois , Jul 20, 2017 :
    Are you saying the data in the Contacts Sync, a background service, caused removal of the switches used to select what data you want to sync?
     

    #13
  14. Ramdinpuia
    Honeycomb Jul 20, 2017

    Ramdinpuia , Jul 20, 2017 :
    I don't know exactly what the problem is.
    Yes, the fix I posted solves the problem (the problem of inability to manually sync contact).

    In fact there are some instances where the contact sync does not appear at all/dissappear under accounts >Google (happened to me when i removed my Google account and tried to log back on a new redmi note 4)
    This also was fixed by the fix i posted
     

    #14
  15. elanglois
    Lollipop Jul 20, 2017

    elanglois , Jul 20, 2017 :
    The OP didn't say they couldn't manually sync contacts. I would definitely say wiping cache of Contact Sync would be a fix for that, then Data if Cache fails.

    The OP said that they didn't have toggles to choose what was being synced and what wasn't. That's why I posted the screenshot.
     

    #15
  16. elanglois
    Lollipop Jul 20, 2017


    #16
    axll likes this.
  17. elanglois
    Lollipop Jul 20, 2017

    elanglois , Jul 20, 2017 :
    Cant select what to automatically sync when you have auto sync turned off. Its letting you sync then one by one, immediately. Turn autosync back on!
     

    #17
    axll likes this.
  18. Ramdinpuia
    Honeycomb Jul 20, 2017

    Ramdinpuia , Jul 20, 2017 :
    Gosh
    Thanks man..
     

    #18
  19. puwazatza
    Cupcake Jan 12, 2019

    puwazatza , Jan 12, 2019 :
    Maybe I am having a similar issue on my One Plus 5T...I am trying to stop syncing my google drive on the phone. I toggled it off but it still syncing files...for instance, if I delete all the files in my google drive on the phone, even though I previously turned off the google drive sync in account setting, it actually deletes all the files online.

    My 64GB phone is filled up with synced Gooogle Drive files so I urgently need to delete all synced files but still exists in the cloud...I am using the latest Oxygen OS...what is the solution? Anyone having the same issue??
     

    Attached Files:


    #19
  20. F1573019393133
    Cupcake Nov 6, 2019

    F1573019393133 , Nov 6, 2019 :
    Most sync issues are temporary. Don't panic, everone. Usually, your account will sync again after a few minutes. I had the error message ("Sync is currently experiencing problems. Sync will be back shortly.") on myandroid phone this morning. After about 6 anxious hours (not exactly "shortly"), the error self-corrected, and the sync function had returned to normal. Patience proved that less is more. But if you keep having sync issues, try the following solutions.

    Manually sync your Gmail Account

    Open your phone’s Settings app.
    Tap Accounts. If you don't see "Accounts," tap Users & accounts.
    If you have more than one account on your phone, tap the one you want to sync.
    Tap Account sync.
    Tap More More And then Sync now.

    Or

    Go to Settings → Accounts → Exchange → Incoming Settings and change the security type to SSL/TLS from SSL/TLS (accept all certificates) and there you go. All the emails, contact, calender will start syncing.
     

    #20