0
Proximity sensor doesn't work via OnePlus 7T


  1. #1
  2. cyberfra
    Cupcake Dec 6, 2019


    #2
  3. Brain_Intruder
    Froyo Dec 9, 2019

    Brain_Intruder , Dec 9, 2019 :
    I own a OP7Pro and faced this sort of problem as well. The proximity sensor requires some machine learning I guess, because it does work but kinda unstable. When I am on a call the screen goes black but then suddenly turns on while the smartphone is still hold tight to the ear. well. why? This should not happen.
     

    #3
  4. bplesa
    Gingerbread Dec 11, 2019


    #4
  5. Brain_Intruder
    Froyo Dec 11, 2019

    Brain_Intruder , Dec 11, 2019 :
    Already figured out how to beat this bug. Just enable "wake up screen" feature from 2 types. During the call no issues were detected since I made this. Seems like there is a conflict with AOD when you are on a call. We do tap the screen accidentally with our face or ear while on a call - this basically wakes up the screen. this is not even the proximity sensor.
     

    #5
    Mukul.mg and AbeDZ like this.
  6. cyberfra
    Cupcake Dec 12, 2019

    cyberfra , Dec 12, 2019 :
    Hi, where do I find that feature?
    thank you!
     

    #6
  7. Brain_Intruder
    Froyo Dec 12, 2019

    Brain_Intruder , Dec 12, 2019 :
    Hi friend. Normally if you would go to the settings - screen and gestures- open the quick gestures menu and then select "double tap to wake up the screen" this must be enabled. Screenshots are attached below for your ease.
    1576135058564.jpg

    1576135058614.jpg

    1576135058646.jpg
     

    Attached Files:


    #7
    bplesa and cyberfra like this.
  8. cyberfra
    Cupcake Dec 12, 2019

    cyberfra , Dec 12, 2019 :
    Thank you!
    It's actually enabled on my 7T, still I have the issue for which I can't make phone calls without pushing things with my face... as the display keeps turning on and off randomly...
     

    #8
    S1575006483670 likes this.
  9. Brain_Intruder
    Froyo Dec 12, 2019

    Brain_Intruder , Dec 12, 2019 :
    This requires further investigation I guess.something else must be in conflict with AOD or something
     

    #9
    cyberfra likes this.
  10. cyberfra
    Cupcake Dec 12, 2019

    cyberfra , Dec 12, 2019 :
    I guess so.
    Anyways, thank you for your support!
     

    #10
  11. Brain_Intruder
    Froyo Dec 12, 2019

    Brain_Intruder , Dec 12, 2019 :
    Have a test call with someone and then try to test the proximity sensor with your hand by covering it. See if it works. If it does - you will have to check the rest.
     

    #11
  12. cyberfra
    Cupcake Dec 12, 2019

    cyberfra , Dec 12, 2019 :
    Thank you for your hint!

    I tried, couldn't figure out where exactly does the virtual sensor work, but it's somewhere in the upper part of the screen.
    Anyway, also by keeping my hand stichted on the screen all the time, the display suddenly turns on and the swipe down menu appears.
    It's really weird.

    I'm starting wondering whether it could depend on the original protective film which is still on my phone, but I don't think so.
     

    #12
  13. bplesa
    Gingerbread Dec 12, 2019

    bplesa , Dec 12, 2019 :
    This makes sense.
    I enabled DTW. This will trigger Ambient Display -> "Tap the Screen to Show" to be disabled.
    Tried and the screen still won't turn off when on a call with the phone on my ear.
    Both options disabled (no DTW and no TSS), still won't turn off.
    What did work though, was to turn off screen once with the power button:
    - I was in a call and the screen was on,
    - turned off the screen using power button,
    - I took the phone off my ear -> Screen on
    - put the phone back on my ear -> Screen off
    Maybe someone can make more sense of it.
     

    #13
    cyberfra and S1575006483670 like this.
  14. Brain_Intruder
    Froyo Dec 12, 2019

    Brain_Intruder , Dec 12, 2019 :
    Can be a good way out as well. Why not following an advice if it works. I have shared my experience and solution for OP7Pro, yet not sure the solution can fit each and every model. I hope that the developers will be able to review this and put some light on the existing issue.
     

    #14
    cyberfra likes this.
  15. cyberfra
    Cupcake Dec 13, 2019

    cyberfra , Dec 13, 2019 :
    thank you, I will try on mine as well!
     

    #15
  16. cyberfra
    Cupcake Dec 13, 2019

    cyberfra , Dec 13, 2019 :
    It seems it works!
    I also tried disabling both ambient display one-tap and gestures two-taps to wake, as a tentative.
    Let's keep fingers crossed!

    thank you both!
     

    #16
    S1575006483670 likes this.
  17. johnfelipe
    Donut Dec 14, 2019


    #17
  18. johnfelipe
    Donut Dec 14, 2019


    #18
  19. cyberfra
    Cupcake Dec 22, 2019

    cyberfra , Dec 22, 2019 :
    unfortunately, the issue is still there. It's bringing me to change the phone, it's unusable...
     

    #19
  20. bplesa
    Gingerbread Dec 22, 2019

    bplesa , Dec 22, 2019 :
    works well with the OnePlus dialer.
    no problems with screen off after answer calls.
     

    #20