77
Push Notification Issues

  1. aufnummersicher
    Cupcake Jun 20, 2016

    aufnummersicher , Jun 20, 2016 :
    Huawei Mate 8 had the same issue. It lasted a long long time until Huawei solved it. That was really annoying.

    I hope the service from OnePlus is a better one
     

    #81
  2. Randroid
    Cupcake Jun 20, 2016

    Randroid , Jun 20, 2016 :
    I wonder: does the problem persist when you are NOT connected to wifi? I also have this issue with WhatsApp and Gmail (oddly enough not with Slack?), but over LTE (wifi turned off) it seems fine, or better at least. Over LTE I do get notifications instantly it seems. However, in settings, it already says to keep wifi on when the phone is standby mode. I also tried all the other things: doze mode settings, priority settings, etc.

    It's driving me mad honestly because I don't have the issue with my OnePlus One.
     

    #82
  3. ieno
    Eclair Jun 20, 2016

    ieno , Jun 20, 2016 :
    I've been playing around with the settings, but unfortunately for me the same issue occurs whether I am or am not connected to wifi. Notifications don't stop working immediately, it takes some time before (I'm assuming) Doze fully kicks in... Both on wifi and LTE, let the phone rest for ~30min, trigger a notification, nothing...wake the screen up, immediate notifications.

    Perhaps the time between screen off and receiving notifications whilst on LTE is shorter (as one's usually on the go when not connected to wifi), so it feels like it works better on LTE?
     

    #83
  4. Randroid
    Cupcake Jun 20, 2016

    Randroid , Jun 20, 2016 :
    Yeah, guess you're right, I spoke too soon it seems. Why one can't just turn Doze off completely is beyond me. After leaving the phone on my desk for about 30 mins, it might as well just be a dumbphone that only wakes when someone is calling. Or a brick. Argh.
     

    #84
    TheFifeFlyer likes this.
  5. Bibin138
    Gingerbread Jun 20, 2016

    Bibin138 , Jun 20, 2016 :
    Even im having same issue, once the screen is off i dont get any notification though i removed those apps from the battery optimization
     

    #85
  6. purextc69
    Gingerbread Jun 20, 2016


    #86
  7. Aphex
    Gingerbread Jun 20, 2016

    Aphex , Jun 20, 2016 :
    It would be nice if we got some response from oneplus on this issue.
     

    #87
  8. ieno
    Eclair Jun 20, 2016

    ieno , Jun 20, 2016 :
    For the people experiencing this issue, it might help to open up a ticket about it to make sure the right people are informed about this...
     

    #88
  9. lfritzsche
    Cupcake Jun 20, 2016

    lfritzsche , Jun 20, 2016 :
    Same problem here. Awesome - a Smartphone without Push Notifications. Hope OP fix this soon.
     

    #89
  10. SanyaIV
    Donut Jun 20, 2016


    #90
  11. TheFifeFlyer
    Froyo Jun 20, 2016

    TheFifeFlyer , Jun 20, 2016 :
    i Had the same problems getting email notifications and this fixed it for me.

    Thanks shrijith
     

    #91
  12. shrijith1
    Gingerbread Jun 20, 2016

    shrijith1 , Jun 20, 2016 :
    So I have been testing the Push notifications today on 3 Apps - Whatsapp beta 2.16.130, Gmail and Hangouts. Here are my findings.
    Phone is kept stationary without charging for it to enter Doze mode.
    1) Whatsapp - Instantaneous notifications.
    2) Gmail - None. (Waited for 30 mins)
    3) Hangouts - Instantaneous notifications.

    I am beginning to think that Google may have set Gmail notifications to "Normal priority" instead of "High Priority" over GCM. I could see so many threads on xda, google forums, etc over the same.
     

    #92
  13. Aphex
    Gingerbread Jun 20, 2016


    #93
  14. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    if you want a quick way to view your GCM service Status, Connect interval, Heartbeat status
    and Doze status, go to the dialler and key in: *#*#426#*#*
     

    #94
    TrueBrush likes this.
  15. TrueBrush
    Ice Cream Sandwich Jun 20, 2016

    TrueBrush , Jun 20, 2016 :
    WhatsApp I can live without, that's for banging, but a missed email can cost me employment or at least a chunk of money, unacceptable even for 1 day.
     
    Last edited: Jun 20, 2016

    #95
  16. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    There is a fix for this..

    The problem is the device enters doze mode, and stops the GCM (Google Cloud Messaging) service from receiving it's
    push notifications and heartbeat.
    you can turn doze off, by using this command in adb
    adb shell dumpsys deviceidle disable

    the device will respond with: Idle Mode Disabled
    you don't need root permissions to do this, but it will revert back
    to the previous Doze mode Enabled settings on a reboot.
    Once Doze Mode is disabled, the phone performs all syncs and gets all notifications perfectly.
    Battery life will be shortened because the device won't doze,
    but you still get good standby time and SOT.
     

    #96
    run_dkc and MarkusRanz like this.
  17. OneplusMike64
    Eclair Jun 20, 2016

    OneplusMike64 , Jun 20, 2016 :
    Very interesting and thanks for sharing, is there a way to make this permanent ? (with or without using root)
     

    #97
    Deactivated User likes this.
  18. F_Diogo_Morgado_Saraiva_
    Cupcake Jun 20, 2016


    #98
  19. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    Root, and edit the global .sys file (adb pull>edit>adb push)

    or post this fix F.A.O OnePlus and see if a fix is forthcoming...
     

    #99
  20. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    Yes,,
    adb shell dumpsys deviceidle whitelist