77
Push Notification Issues

  1. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    this obviously enables the use of the "do not optimise" app list
     

  2. OneplusMike64
    Eclair Jun 20, 2016

    OneplusMike64 , Jun 20, 2016 :
    That i already tried adding all the apps that give notifications to the "do not optimise" list and giving them priority in notifications. But without any result sadly.
     

  3. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    That's because OnePlus has turned off the "Allow Whitelist" in the code.
    you can click all you like in the "do not optimise" section of battery optimisation,
    but it won't do anything, as it's turned off in the global system google android code.
     

  4. OneplusMike64
    Eclair Jun 20, 2016

    OneplusMike64 , Jun 20, 2016 :
    Incredible, it seems like they never tested the software before shipping the phone out. Strange that not everyone is getting the notification problems.
     

  5. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    Er.. No comment,
    and it is not just OnePlus.. Nexus did the same thing...
     

  6. WizeGuyDezignz
    Gingerbread Jun 20, 2016

    WizeGuyDezignz , Jun 20, 2016 :
    I'm having the same issue and will probably return the phone because of it. This is completely unacceptable and I can't wait for them to fix this since getting delayed notifications is a no-no for me. Such a bummer and I'm surprised a lot of other people aren't complaining about this.
     

  7. 4mger
    Eclair Jun 20, 2016

    4mger , Jun 20, 2016 :
    OK, can you explain how to do this in real simple terms?
     

    run_dkc likes this.
  8. purextc69
    Gingerbread Jun 20, 2016

    purextc69 , Jun 20, 2016 :
    If this is a system setting fault then surely every device would be having these problems? I would also appreciate a step by step on how to get this working without root, with doze still working if possible...
     

  9. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    Connect your phone to your computer,
    allow the adb drivers to auto install,
    Download 15 seconds adb install here:
    https://drive.google.com/file/d/0B0MKgCbUM0itNVB1elljU2NPR0k/view
    follow the instructions to install.
    open up a adb command prompt
    by going into the folder: c:\adb
    then hold down the shift key, whilst right click mouse once,
    select "open command prompt from here"
    make sure you select file transfer option on your phone (in the pull down options)
    Type: adb devices
    the adb deamon will start, then respond with your phones serial number,
    if it is correctly connected.
    then type :
    adb shell dumpsys deviceidle disable
    the phone will respond with: idle mode disabled.

    Done....
     

  10. OneplusMike64
    Eclair Jun 20, 2016

    OneplusMike64 , Jun 20, 2016 :
    - Install adb on your pc
    - Activate developer mode on the phone (touch build number 7 , or was it 9 , times)
    - Activate "Usb debugging mode" in the developer options menu
    - Open cmd prompt in your adb folder on the pc
    - type "adb devices"
    - Then excute command mentioned earlier

    If this does not make sense to you, google each item you don't understand. Not to worry cant destroy phone, unless you drop it from the table while typing. *joke

    EDIT : Ok we did it both at the same time, laughs.
     

  11. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    I can get you running with push notifications working,
    but with doze mode off.
    there is no magic fix to enable doze mode, and have push notifications working.
    it's one or the other, doze mode sucks, always has, and it's worse on android N.
    the problem lies with the GCM not being fully compliant with the android doze mode.
     

  12. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    thanks, I assumed the poster had enabled developer options
    on the phone.. you were right not to assume that,
    thanks..;)
     

    Alvie likes this.
  13. Adipekar
    Gingerbread Jun 20, 2016

    Adipekar , Jun 20, 2016 :
    Had a Oneplus tweet from their support twitter account come in replying to my tweet about this issue. I gave them a link to this thread, so hopefully someone will look into it soon.
    Issue persists with me on mobile and WiFi.
     

    Deactivated User likes this.
  14. Graham Robertson
    Jun 20, 2016


  15. purextc69
    Gingerbread Jun 20, 2016

    purextc69 , Jun 20, 2016 :
    Thank you guys... Appreciated. Might be fixed by the time I get my phone lol.

    So doing this only works until a reboot, then it reverts?
     

    Deactivated User likes this.
  16. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    Exactly.
    needs root access to modify the /global.sys file.
    no root = doze mode enabled again after phone reboot, power off.
     

  17. purextc69
    Gingerbread Jun 20, 2016

    purextc69 , Jun 20, 2016 :
    Do you think all op3's are affected?
     

  18. JasonMR
    Lollipop Jun 20, 2016

    JasonMR , Jun 20, 2016 :
    So reading up about Doze it all starts to make sense, but I also read that the phone won't enter Doze if it's plugged into a charger so if you charge overnight like I do I guess that explains why I hadn't noticed the issue?

    Or have I got that all wrong?
     

  19. Graham Robertson
    Jun 20, 2016


  20. Graham Robertson
    Jun 20, 2016

    Graham Robertson , Jun 20, 2016 :
    Spot on my man.
    that's why you get multiple notifications all coming in together when you
    go to your phone and turn the screen on or unlock it,
    when it is not plugged in to the charger.
    doze is not enabled whilst charging.
     

    JasonMR likes this.