272
OP2

[Q&A] The Ultimate OnePlus 2 Guide - Solutions e.t.c.

  1. Spannaa KitKat May 31, 2017

    Spannaa, May 31, 2017 :
    TWRP 3.0.2-2 should work with OOS 2.2.1

    Later versions of TWRP for the OP2 require the OOS 3 bootloader.
     

  2. F_KöTî_ZêÑõ_cwIq Cupcake Jun 1, 2017


  3. Kirppu21 Donut Jun 1, 2017

    Kirppu21, Jun 1, 2017 :
    still not working
     

  4. Spannaa KitKat Jun 1, 2017

    Spannaa, Jun 1, 2017 :
    If you really want any help, try giving full details of what you're doing and the full error messages
     

  5. Kirppu21 Donut Jun 1, 2017

    Kirppu21, Jun 1, 2017 :
    I am trying to put new recovery, so i can run android 6 as the default recovery refuses to let me use anything newer than the default rom/twrp2.8.7.0.
    Every time i try to boot android 6 based rom the phone hangs up on the "oneplus" screen. Same happens when i try to use anything newer than twrp 2.8.7.0
    on the recovery it's "fastboot flash recovery twrp.img"
    does ok, but when i try "fastboot boot twrp" it shows the infamous "Remote failed: dtb not found"
     
    Last edited: Jun 1, 2017

  6. G_Madhusudhan_Reddy_NhyV Cupcake Jun 1, 2017


  7. Spannaa KitKat Jun 2, 2017

    Spannaa, Jun 2, 2017 :
    So:

    Wipe system, data and both caches
    Flash the rom zip
    Flash the latest TWRP as an image to recovery
    Reboot recovery
    Flash the rom zip again
    Reboot system
     

  8. Kirppu21 Donut Jun 2, 2017

    Kirppu21, Jun 2, 2017 :
    Tried to flash twrp 3.1.1.0 and the phone stays on the logo, doesn't move to the recovery.

    I'm starting to think that it has something gone bust with the firmware or the bootloader

    Should've stated this earlier but a few months back the phone bricked when i tried francos kernel and lineage os,(everything was going fine until in few weeks when Lineageos updated) where i managed to get it to recover from it but since then it has been doing this, the recovery itself was the same twrp that you recommended, but now it doesn't want to do it.

    Flashing Lineage OS is impossible as it prints out error "Error executing updater binary in zip", with 3 diffirent builds, even the one i had working

    Again personally i'm fearing that the "little" incident made the bootloader to go "read-only"-mode making the "dtb not found" error, thought the phone is unlocked, according to the "fastboot device info"- command so that can't be it

    Still i am grateful that you want to help
     
    Last edited: Jun 2, 2017

  9. Spannaa KitKat Jun 2, 2017

    Spannaa, Jun 2, 2017 :
    Did you try fixing it by following the steps I gave you exactly?

    dtb not found happens when the bootloader isn't compatible with the version of TWRP you're using.

    That's why I suggested flashing the rom zip followed by the newer version of TWRP and then rebooting TWRP directly and re-flashing the rom zip. All of this needs to be done in one go, without booting system in between.
     

  10. G_preetham_Masetty_YZfk Eclair Jun 2, 2017


  11. Kirppu21 Donut Jun 2, 2017

    Kirppu21, Jun 2, 2017 :
    yes
     

  12. Spannaa KitKat Jun 3, 2017

    Spannaa, Jun 3, 2017 :
    Are you using the OnePlus community app? It doesn't work properly with their own forums!

    Use a web browser and you'll see the answers when you click the spoiler buttons.
     

  13. Spannaa KitKat Jun 3, 2017


  14. Kirppu21 Donut Jun 3, 2017

    Kirppu21, Jun 3, 2017 :
    i finally managed to fix it
    What i did was the following
    Used Qfil from this site: https://androidmtk.com/download-qualcomm-flash-image-loader-qfil
    And used this firmware: https://forums.oneplus.net/threads/...ck-guide-for-a-hard-bricked-oneplus-2.347607/
    Basically i used the steps from method 1 but instead of the firehose i used Qfil
    with the qfil however it's extremely important that your folder where you load the .MBN files do NOT have spaces like "new folder" instead use underscore like this "new_folder" and qfil should work.
    Also you can use the Mega un-brick guide's MBN, and it works wonders

    MBNs being the firmware files, be extremely careful with them as you can FUBAR the phone with wrong file

    and as always do not blame me for bad files, and this may/may not work for you
    all damage is on you and you only, this is just a sidenote
     

    Alvie and kaihp like this.
  15. jsb007 Gingerbread Jun 5, 2017


    Kirppu21 likes this.
  16. Spannaa KitKat Jun 5, 2017

    Spannaa, Jun 5, 2017 :
    Glad you're sorted ;)

    Another solution may have been @fareed_xtreme's OFFICIAL ONEPLUS 2 STOCK RESET
     

    Alvie and Kirppu21 like this.
  17. Kirppu21 Donut Jun 5, 2017


  18. quarterpounder Cupcake Jun 11, 2017

    quarterpounder, Jun 11, 2017 :
    Hi!

    Since last year I used CM14.1 and now decided to upgrade to LOS14.1.
    After installing LOS14.1 via TWRP (after wiping data-cache-system) I tried to encrypt the phone, but after rebooting, it came up unencrypted.

    Tried another round with clean installs of LOS14.1 and XenonHD7.1, both didn't work.

    I already went back to OP original recovery and OxygenOS 3.5.8, even there the phone claims to encrypt, reboots and comes back after a few seconds unencrypted.

    Any idea, what to change to get the OP2 encrypted?


    Regards,

    quarterpounder
     

  19. psyconoaut Cupcake Jun 22, 2017

    psyconoaut, Jun 22, 2017 :
    Hello" I like using open camera as my default camera app but since os 3.5.6 I cant open it by double pressing the power button. Does anyone know how to fix this as its really handy for me to quickly open camera
     

  20. psyconoaut Cupcake Jun 22, 2017

    psyconoaut, Jun 22, 2017 :
    Im on 3.5.8 but it still doesnt work. Double press only works when switching to stock camera..